Ecran noir GDM (ou kdm ...)


#1

Mon écran se met en veille (il s’éteint carrément) systématiquement dès que j’arrive sur la fenêtre de login GDM (et c’est pareil avec un autre gestionnaire de sessions). Je tape mes identifiants dans le noir (!) et ça marche, je suis alors dans ma session, tout se rallume et fonctionne parfaitement. J’aimerais comprendre et remédier à cela … Merci.


#2

Si tu es sous gnome, je ne sais pas mais si tu es sous KDE, essaie d’aller ds menu K / Centre de config / administration système / gestionnaire de connexion.
Là, regarde si tt va bien au niveau de l’écran de connexion ou si tu n’as pas une connexion automatique pour un user défini.


#3

Je suis sous Gnome, mais c’est pas ça : j’ai mis une connexion automatique pour éviter cette phase de la page noire. Mais si je l’enlève, le problème est toujours là.


#4

Il y a peut être une modif à faire genre ‘option dpms no’ (ou false, je ne sais plus trés bien), à mettre dans la section carte graphique de ta config X, non ?
sinon, j’imagines que tu as choisi par gout le login manager gnome, mais indépendament de ce que tu utilises en session, rien ne t’empèche d’installer kdm ou xdm, pour voir si le problême persiste (tu pourra toujours les desinstaller aprés).


#5

Qu’as-tu dans la dernière section “ServerLayout” de /etc/X11/XF86Config-4 ?

Moi qui n’utilise pas la mise en veille de l’écran j’ai :

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        Option          "OffTime"       ""
EndSection