Ecran noir lors de l'installation clé USB Debian 9

stretch
clé-usb
installation
Tags: #<Tag:0x00007f09453cc350> #<Tag:0x00007f09453d3678> #<Tag:0x00007f09453d2ed0>

#41

Je n’ai ni mode legacy ni mode CSM dans le BIOS.


#42

Et ici aussi pour réparer
https://wiki.debian.org/GrubEFIReinstall

Je vais regarder GribEFIRenstall.

Merci d’avoir cherché sur différents sites. Ayant eu au départ un problème d’installation (écran noir) de Debian, j’ai installé XUbuntu et n’ai pas rencontré de problème particulier. Mais c’est Debian que je souhaite installer et non Ubuntu.
J’ai l’impression d’être proche du but puisque l’installation s’est bien passée mais je ne comprends absolument pas ce qui se passe au niveau de l’EFI…


#43

@Eugenie

Je ne propose pas Ubuntu ni Fedora.

Je propose la méthode utilisée pour un modèle d’ordinateur que je pense être identique au tien ou alors très semblable.

Cette méthode comporte essentiellement deux points :

  • Mettre un mot de passe au “supervisor” du BIOS pour rendre enfin le choix Legacy accessible.

  • Utiliser deux options relatives au module nouveau pour amorcer le média USB Debian d’installation.

Il est fait aussi mention dans le lien d’une option du BIOS relative au trackpad à modifier avant de procéder à l’installation.

Je ne suis évidemment pas infaillible et je peux me tromper complètement…

Je suis en mode mobile, loin de mon ordi.

Bonne chance !

ps : j’utilise BIOS par abus de langage ; je ne sais pas encore employer (U)EFI correctement et firmware ou micro-logiciel n’est pas complètement rentré dans les mœurs ama


Avec le lien https://github.com/jgriffiths/Acer-VN7-792G/blob/master/Linux_Install.md#fedora-vn7-792g
J’ai été directement à la méthode à adapter.

Mais https://github.com/jgriffiths/Acer-VN7-792G précise bien :

Information for the Acer Aspire V 17 Nitro Black Edition VN7-792G laptop.
Some of this may be more generally useful to related Acer laptop lines.

Autant te mettre au courant tout de suite, le Wifi peut ne pas être opérationnel immédiatement.
Et le micro interne semble ne pas encore vouloir fonctionner (Voir https://github.com/jgriffiths/Acer-VN7-792G/blob/master/Issues.md)

com


#44

efibootmgr ne modifie pas la partition EFI. Il ne manipule que les variables de boot EFI qui sont stockées dans la mémoire non volatile (NVRAM) de la carte mère, un peu comme les paramètres du BIOS.
Si le firmware UEFI ne tient pas compte du boot order ni du chargeur par défaut EFI/BOOT/bootx64.efi de la partition EFI, je ne sais plus quoi faire. Essaie la suggestion de @r2mi.
En dernier recours, tu peux installer Xubuntu sur une petite partie du disque et utiliser son menu de démarrage pour démarrer Debian.


#45

J’ai pu enfin démarrer Debian !
Je n’ai pas pu modifier le paramètre trackpad dans le BIOS car cette option n’existe pas dans le modèle 793G dont je dispose.

J’ai réactivé le SecureBoot et défini le fichier Debian grubx64.efi comme fichier à utiliser. Debian a démarré certes avec des erreurs relatives au firmware at10k manquant (je n’avais pas pu les fournir à l’installateur) mais Debian fonctionne.

efibootmgr -v donne le résultat suivant :

root@furtif:/boot/efi/EFI# efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,2001,2002,2003
Boot0000* deb	PciRoot(0x0)/Pci(0x17,0x0)/Sata(2,0,0)/HD(1,GPT,09eb2286-3bcf-486a-a844-b6a65311a5ab,0x800,0x100000)/File(\EFI\debian\grubx64.efi)A01 ..
Boot0001* Unknown Device: 	HD(1,GPT,09eb2286-3bcf-486a-a844-b6a65311a5ab,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0002* Unknown Device: 	HD(1,GPT,09e7fa83-9240-4c6a-896d-415c74008021,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0003* Unknown Device: 	HD(1,GPT,09e7fa83-9240-4c6a-896d-415c74008021,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0004* debian	HD(1,GPT,09eb2286-3bcf-486a-a844-b6a65311a5ab,0x800,0x100000)/File(\EFI\debian\grubx64.efi)
Boot0005* ubuntu	HD(1,GPT,09eb2286-3bcf-486a-a844-b6a65311a5ab,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0006* ubuntu	HD(1,GPT,09eb2286-3bcf-486a-a844-b6a65311a5ab,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0007* ubuntu	HD(1,GPT,09eb2286-3bcf-486a-a844-b6a65311a5ab,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

Ma nouvelle entrée deb apparaît.

Le listing complet de la partition EFI est :

root@furtif:/boot/efi/EFI# ls -algR
.:
total 20
drwx------ 5 root 4096 nov.  27 09:04 .
drwx------ 3 root 4096 janv.  1  1970 ..
drwx------ 2 root 4096 déc.   3 15:26 BOOT
drwx------ 2 root 4096 nov.  27 09:05 debian
drwx------ 3 root 4096 oct.  14 22:39 ubuntu

./BOOT:
total 1316
drwx------ 2 root    4096 déc.   3 15:26 .
drwx------ 5 root    4096 nov.  27 09:04 ..
-rwx------ 1 root  121856 déc.   3 15:26 bootx64.efi
-rwx------ 1 root 1213032 oct.  26 17:30 fbx64.efi

./debian:
total 128
drwx------ 2 root   4096 nov.  27 09:05 .
drwx------ 5 root   4096 nov.  27 09:04 ..
-rwx------ 1 root 121856 nov.  27 09:38 grubx64.efi

./ubuntu:
total 3728
drwx------ 3 root    4096 oct.  14 22:39 .
drwx------ 5 root    4096 nov.  27 09:04 ..
-rwx------ 1 root     108 oct.  26 17:30 BOOTX64.CSV
drwx------ 2 root    4096 oct.  14 22:37 fw
-rwx------ 1 root   71400 oct.  14 22:37 fwupx64.efi
-rwx------ 1 root     126 oct.  26 17:30 grub.cfg
-rwx------ 1 root 1116024 oct.  26 17:30 grubx64.efi
-rwx------ 1 root 1269496 oct.  26 17:30 mmx64.efi
-rwx------ 1 root 1334816 oct.  26 17:30 shimx64.efi

./ubuntu/fw:
total 8
drwx------ 2 root 4096 oct.  14 22:37 .
drwx------ 3 root 4096 oct.  14 22:39 ..

Les fichiers debian/grubx64.efi et BOOT/bootx64.efi sont bien identiques.

Peut-être que le problème a persisté du fait que j’avais au début copié le fichier grubx64.efi en bootx64.efi sans supprimer au préalable BOOTX64.EFI.

Merci à tous pour votre patience, votre aide et tous les conseils apportés sans lesquels je n’aurais pas pu venir à bout de l’installation.


#46

Ça, tu l’avais déjà fait il y a 8 jours :

Qu’est-ce qui a changé pour que l’erreur disparaisse ?

Non, aucun rapport et de toute façon avec les options de montage par défaut ça ne change rien car FAT n’est pas sensible à la casse des noms de fichiers, donc bootx64.efi remplace BOOTX64.EFI.


#47

Lorsque j’ai copié il y a 8 jours le fichier grubx64.efi en bootx64.efi dans le répertoire BOOT, je n’avais pas écrasé le fichier BOOTX64.EFI. En listant les fichiers de répertoire BOOT, j’avais les 2 fichiers bootx64.efi et BOOTX64.EFI.

En rebootant en mode BootSecured, j’ai eu le message “Secure Boot forbids…”.

J’ai donc rebooté avec ma clé live et ai remarqué que je n’avais plus qu’un fichier BOOTX64.EFI dans la partition EFI.

Après que tu m’aies demandé d’écraser le fichier BOOTX64.EFI, j’ai refait la copie du fichier grubx64.efi en bootx64.efi puis ai essayé de rebooter en désactivant le Boot Secured. J’avais alors l’erreur “No Bootable Device”.

Les changements portent donc à la fois sur :

  • l’écrasement du fichier BOOTX64.EFI
  • la copie du fichier debian/grubx64.efi en BOOT/bootx64.efi
  • la réactivation du mode Boot Secured et la spécification du fichier fichier grubx64.efi à utiliser