Envoi d'e-mails par un script PHP


#1

Bonsoir,

J’ai un script PHP d’envoi d’e-mail mais il n’a l’air de fonctionner qu’en interne (jerome@debian). Si j’en envoie un e-mail sur une véritable adresse, je ne reçois rien. Y a-t-il quelque chose à configurer sous Debian (MTA ou autre) ?


#2

quand tu envoies sur une autre adresse, qu’est ce que tu as dans ton /var/log/mail.log ?
quel mta as tu installé ?
es tu en sendmail, ou en smarthost ?


#3

[quote=“MattOTop”]quand tu envoies sur une autre adresse, qu’est ce que tu as dans ton /var/log/mail.log ?
quel mta as tu installé ?
es tu en sendmail, ou en smarthost ?[/quote]
/var/log/mail.log est vide. Sinon, j’ai reconfiguré Exim mais je ne sais pas trop quoi choisir.


#4

moi, je suis sous courrier, mais bon, le mieux c’est de reconfigurer ton mta pour qu’il envoie par le biais d’un smarthost. il te faut l’adresse du smtp de ton fai, et normalement, lors d’un dpkg-reconfigure exim4 (ou exim4-base, je ne sais pas) tu trouve l’endroit ou on te demande si tu envoies par un smarthost, tu repond oui, et tu met le smtp de ton fai. si tu as encore des problemes, tu recommence, mais tu te mets en “sendmail” et tu reesayes.


#5

et dans /var/log/exim4/mainlog ?


#6

dpkg-reconfigure exim4-config me donne les choix suivant :

[code]Distribution directe par SMTP (Site Internet)
Envoi via relais (Smarthost) - Réception SMTP ou Fetchmail
Envoi via relais (Smarthost) - Pas de courrier local
Distribution locale seulement

Si je choisis Réception SMTP ou Fetchmail, j’ai ensuite :
Nom de courriel du système : Debian ?
Liste d’adresses IP où Exim sera en attente de connexions SMTP entrantes : ?
Autres destinations dont le courriel doit être accepté : ?
Machines à relayer : ?
Relais de courriel : smtp.tele2.fr ?
Nom de domaine visible pour les utilisateurs locaux : ?
Faut-il minimiser les requêtes DNS : ?
[/code]


#7

[quote]Si je choisis Réception SMTP ou Fetchmail, j’ai ensuite :
Nom de courriel du système : Debian ? [/quote]
c’est le nom qu’il va considerer comme local en premier. si tu as réservé un domaine et si tu veux en faire ton MX ca sera qqchose du genre . (le MX declaré pour la zone).

laisse vide, sinon, il n’acceptera que les adresses que tu auras spécifiées.

[quote] Autres destinations dont le courriel doit être accepté : ?
Machines à relayer : ? [/quote]
sans raison particuliere, tu laisse vide

OK

je ne me souviens plus, ca doit gèner le “reply-to”, si tu configures mal, mais ca n’est pas bloquant. je laisserais vide

ben, faut voir …


#8

Rien à faire ! Par contre le script fonctionne chez l’hébergeur.


#9

as tu essayé d’envoyer des mails tout bêtement avec “mail”:
un petit mail depuis ta ligne de commande ver un user local, puis vers un user distant.
Bon, mais il va falloir regarder dans les ficgiers de conf de /etc/exim4…
Esayer de comprendre et tatonner sur les options…
Sinon, as tu fini par trouver dans /var/log, les logs de ton exim ?
parceque la, …