Envoyer des courriels


#1

Bonsoir et bonne année à tous,
je suis en train d’essayer d’installer la sarge (version netinstall) et je bloque depuis quelques jours sur l’envoi des courriels vers l’extérieur (tout va bien en interne)
comme exim4 est le MTA installé par défaut je l’ai gardé
à chaque essai je trouve ceci dans le log d’exim4:
dest@fai.fr R=smarthost T=remote_smtp_smarthost: SMTP error from remote mailer after RCPT TO:dest@fai.fr: host smtp.cegetel.net [212.94.174.24]: 554 <localhost.localdomain>: Helo command rejected: Invalid name

apparemment 554 veut dire spam
et localhost.localdomain vient de mon fichier /etc/hosts

j’ai bien mis dans passwd.client le nom du serveur smtp.cegetel.net
mon nom de user et mon mot de passe
j’ai viré l’authentification dans exim4.conf.templates
et je bloque là

je n’ai rien trouvé dans tout de que j’ai pu lire qui me permette de trouver un début de piste (je suis plutôt débutant !)

Merci
Jacques


#2

j’ai eu le même problème: tu n’es pas autorisé parceque l’adresse depuis laquelle tu souhaite émettre n’est déclarée comme MX pour aucune zone. pas MX en reverse lookup => considèré comme spammer.
J’ai résolu le pb dans certains cas en créant un domaine sur dyndns, et en déclarant la machine qui se réfèrence en IP comme MX, mais ca ne fonctionne que si tu es en ip statique (rendant ainsi peu utile le coté réferencement dynamique=autant s’acheter son propre domaine).
Tu dois avoir aussi des possibilités de faire ca si tu es chez free, et il me semble que ca marche sans déclarer de zone chez Wanadoo, si tu a payé (cher) une adresse statique.
Si tu n’utilises pas de smarthost, ton problème d’emission n’arrivera pas systematiquement: ca dépendra du smtp qui recoit.
Mais le problème n’est pas spécifique linux, donc tu peux aussi rechercher sur les ressources windows.
PS: je n’ai pas eu le temps de creuser parceque ce n’etait pas critique pour moi sur les machines qui ne marchaient pas. Par contre, je suis interressé si tu trouves la solution.
PPS: si tu as accés à un SMTP que tu peux configurer en relais pour toi et qui fonctionne bien en emission, tu peux l’utiliser comme smarthost (d’ailleurs tiens, si je ne perd pas tout mon temps sur ce forum, je vais faire ca pour ma machine perso)…


#3

Merci,
je n’ai pas tout compris !
mais j’ai oublié de préciser que tout va bien sous W98 et j’ai peine à croire que Linux serait plus limité dans ce domaine
Je continuerai à fouiller demain (mais je ne sais plus dans quelle direction !)
Bonne nuit à tous


#4

j’ai oublié de préciser que j’ai un pc et un seul user (en plus de root!)
donc une config mini


#5

Alors si ton problème est juste d’envoyer des mails, et que tu te moques que la commande ‘mail’ fonctionne ou pas, tu n’as pas forcément besoin de te préoccuper d’un MTA… Un logiciel comme kmail, ou d’autres, se configurent un peu comme outlook ou outlook express.
Il suffit de leur dire que tu n’utilise pas de sendmail (pas de MTA, donc), et que tu veux être client smtp de smtp.cegetel.fr , et c’est tout.
Simplement, si tu veux que toutes les applications qui envoient du mail puissent envoyer du courrier, le MTA sert de pile de traitement commune pour le transfert, mais nécessite plus de configuration, car c’est une configuration pour du transfert de serveur à serveur…
Désolé si je t’ai inondé de mots techniques grossiers, mais ton vocabulaire était assez précis pour que je te croies “de la partie”… :slightly_smiling:
Sinon, si tu as besoin de distribuer du mail “local”, ou si tu veux rappatrier du mail depuis une plusieurs boites distantes avec fetchmail, tu as besoin d’un smtp comme exim, donc cette installe la n’est pas inutile, puisqu’ele est faite…


#6

sinon, juste une question, parceque je dis peut etre un peu de conneries en disant que ton exim est catalogué comme spammer parcequ’il n’est pas reconnu:
j’avais pas lu le truc sur localhost.localdomain…
dans ta config de exim4, tu devrais retrouver localhost.localdomain, peut etre simplement que smtp.cegetel.fr refuse de relayer pour un host qui s’appelle localhost.localdomain.
Si tu veux malgré tout configurer ton MTA, essayes de remplacer par ton adresse ip, et sinon, essayes le nom associé à cette ip (tu l’obtiendras avec 'host ’ ou 'nslookup ').


#7

Bonjour,
merci pour les réponses,
je n’ai pas été assez précis:

J’ai réussi à configurer fetchmail pour récupérer le courrier dans deux serveurs pop (mes trois adresses) et exim fonctionne bien en interne pour la distribution.

J’ai essayé avec sylpheed et evolution d’envoyer directement au serveur de cegetel mais j’ai exactement le même résultat, par contre je ne suis pas sûr que ça passe direct car je vois dans ce cas la même erreur dans le log d’exim

Quant à mettre mon ads ip à la place de localhost.localdomain je n’ai pas encore réussi à trouver où dans la config d’exim se cache cette variable, j’ai l’impression que cette valeur sort du fichier /etc/hosts

ce que je me propose de faire dans la journée:
1- désinstaller purement et simplement exim4
2- essayer à nouveau en direct avec un ou deux MUA
3- installer postfix ou un autre MTA dont je trouverai une explication à ma portée

quant à host çà ne donne rien
"
bureau:/home/jacques# host 192.168.1.2
Host 2.1.168.192.in-addr.arpa not found: 3(NXDOMAIN)
bureau:/home/jacques#
"

en tout cas merci de l’aide
Jacques


#8

bon, si tes MUA provoquent des messages exim, c’est qu’ils envoient sur un mode “sendmail” et font appel au MTA. Revérifies donc si tu n’as pas d’autres options d’emission pour passer en SMTP dans sylpheed et evolution. Personnellement, chez moi avec Kmail, ca passe.
pour le nom de ta machine tel que l’utilise exim, il le prendrait bien soit dans /etc/hostname.
On pourrait penser qu’il il le resoudrait en cherchant le nom associé à 192.168.1.2 dans /etc/hosts, mais le fait que host 192.168.1.2 ne donne rien, ca veut dire qu’il n’y a rien a trouver dans /etc/hosts.
Bon, sinon, 192.168.1.2, c’est une adresse LAN, donc soit tu es en NAT derriere un routeur sur un LAN, soit tu utilise un modem ethernet. Dans les deux cas, cette adresse n’est pas ce que l’on appelle ton adresse externe, et n’a qu’un usage local. pour connaitre ton adresse “externe” celle que voient les serveurs quand tu leur cause, tu va sur un site qui t’affiche l’ip que lui voit, genre le site whatsmyip.org/
sur la page tu auras ta VRAIE adresse.


#9

j’ajoute que changer de MTA ne resoudra pas le pb: tu sera obligé de configurer le HELO entre ton MTA et le smarthost. Mais c’est vrai que postfix, ca se configure avec webmin, et ca simplifie salement les choses…


#10

Oui j’avais fait une erreur dans la config du MUA en direct vers cegetel
je viens de refaire et cette fois ça marche en direct

par contre j’ai retiré exim4 et j’essaie postfix cet apm

j’ai effectivement un routeur avec modem intégré (Bewan 600) et il y a bien NAT

voilà le résultat de host
host 213.223.147.120
120.147.223.213.in-addr.arpa domain name pointer 213-223-147-120.dti.cegetel.net.


#11

[quote=“Jacques”]Oui j’avais fait une erreur dans la config du MUA en direct vers cegetel
je viens de refaire et cette fois ça marche en direct[/quote]
ah ! :slightly_smiling:

[quote=“Jacques”]<…>
voilà le résultat de host
host 213.223.147.120
120.147.223.213.in-addr.arpa domain name pointer 213-223-147-120.dti.cegetel.net.[/quote]
bon, ben ca veut dire que ton nom IP, pour un noeud externe, c’est 213-223-147-120.dti.cegetel.net, tout betement, mais je crains que tu ne soit en adresse IP dynamique, et que ca ne te rende difficile l’envoi de mail au travers de smtp.cegetel.fr.
enfin. le principal, tu l’as déja, maintenant…


#12

Bonsoir,
j’ai progressé dans une direction et régressé dans l’autre !
grâce à Postfix et webmin et aussi un papier que j’ai trouvé expliquant les sender_canonical et recipient_canonical je peux maintenant expédier vers le serveur smtp de cegetel tout va bien de ce côté

malheureusement tout ce que je reçois de l’extérieur par fetchmail est renvoyé aussitôt à l’expéditeur (c’est en tout cas ce que je crois d’après l’étude du log).
Pour le moment je ne vois pas ou est l’erreur mais je cherche…
Jacques


#13

Eh bien finalement la réinstallation complète de Postfix a résolu le problème.