Envoyer messages sur réseau à la fermeture / gladenetsend


#1

Salut,

je voudrais envoyer un message sur l’ensemble des ordinateurs à la fermeture de mon serveur… En cherchant un peu j’ai trouvé gladenetsend qui est un projet appelé LinWinTalk.

J’aimerais avoir un retour de ceux qui connaissent ce projet sinon, ceux qui ont de meilleures idées je suis preneur.

Merci!


#2

Qu’entends-tu par “fermeture de ton serveur” ?
[ul]

  • shutdown
  • logout
  • arrêt de l’application
    [/ul]

:question: :question: :question:


#3

quand l’ordinateur s’éteint donc shutdown :slightly_smiling:


#4

Ca a l’air pas mal ton truc mais je connais pas et ça à l’air d’être uniquement graphique.

Ca serait peut-être mieux d’imaginer un script qui envoye un message broadcast (sur l’adresse .255) de ton réseau, avant que ta machine ne descende dans les runlevels.
Et mettre ce script dans /etc/init.d par exemple.
Mais pour l’instant, je me rappelle plus des outils à prendre pour faire un broadcast… :blush:


#5

effectivement, avec un script init. Mais il n’y a pas moyen d’envoyer du ‘winpopup’ à toutes les machines d’un domaine, avec les outils samba ?


#6

j’ai essayé quelques commandes avec samba genre :

smbclient -L machine message

smbclient -M machine message

smbclient -I machine message

et la combinaison de ces derniers trucs mais je n’ai pas réussit à envoyer de message… mais de toute facon à ce que j’ai compris smbclient n’envoie de message que vers windows…


#7

bon, de ce que j’ai lu, c’est bien ‘smbclient -M’ ( nagios.org/faqs/viewfaq.php?faq_id=63 ), mais si je me souviens bien, le service est maintenant désactivé par défaut sous win, à cause d’un vers, je crois.
De toutes les manières, sans rien installer sur les windows…


#8

ca me parait plus intéressant que ce que j’ai trouvé jusq’à présent… je me penche dessus et je reviens :slightly_smiling:


#9

Je n’y arrive toujours pas, il me dit

ou bien

[quote]Ignoring unknown parameter "secutity"
session request failed
[/quote]

Je pense que ca doit venir de venir de windows mais j’ai désactivé le firewall pourtant! :question:


#10

Heu… dans ton message d’erreur, il me semble lire “secutity” au lieu de… au hasard disons “security” ? :wink:


#11

Je suis anti-windows mais là je suis sûr que c’est pas sa fôte, cette fois ça sera la faute à titi et gros-minet.


#12

as tu verifié déjà de machine windows à machine windows ?
as tu essayé en t’identifiant avec kerberos (-k)…
Quel windows utilises tu ?
As tu un partage sur tes clients ?
As tu activé le compte “invité” sur tes machines ?


#13

[quote=“MattOTop”]as tu verifié déjà de machine windows à machine windows ?
as tu essayé en t’identifiant avec kerberos (-k)…
Quel windows utilises tu ?
As tu un partage sur tes clients ?
As tu activé le compte “invité” sur tes machines ?[/quote]

Je vais faire toutes ces vérifications…
Déjà je n’ai pas la session invité d’activé ca s’est sur…
Merci. Je reviens dès que j’ai tout vérifié et que j’ai fait d’autres tests…

Merci à tous les deux… je ne sais pas ce que je pourrais faire sans VOUS! :smiley: