Erreur au montage CDROM :


#1

Bonjour,

Sous Sarge, lorsque je veux monter le graveur DVD, j’ai le message d’erreur suivant :
mount: mount point /media/cdrom0 does not exist

Mon /etc/fstab contient :
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0

Pour que ça marche, il me suffit de créer un dossier /media/cdrom0 en root.
Mais à chaque boot, ce dossier est supprimé.
Voilà le contenu de /media :
athlon:/etc/apt# ls -a /media
. … cdrom floppy floppy0

Sur le net, j’ai lu que discover devrait permettre de résoudre ce problème. Mais que nenni :frowning:

Comment puis-je faire pour ne plus être obligé de créer ce foutu dossier à la main à chaque boot ?

Merci d’avance.


#2

Est-ce que le module qui gère le cd est chargé ?

Pour le savoir: lsmod | egrep ‘(ide-cd|ide-disk|ide-generic|ide-scsi)’

ca doit se trouver dans un de ces modules, je ne me rappelle plus lequel exactement. Essayes les l’un après l’autre et en même temps, trace ce qui se passe dans
/var/log/messages : tail -f /var/log/messages (dans une aute console)

Si le module n’est pas chargé: modprobe le_nom_du_module.

Si le directory disparaît. C’est probablement parceque les devices dans /dev sont créés dynamiquement à chaque reboot du système, ceci en fonction des modules chargés au démarrage. Ca dépend de ta config de kernel.

Ensuite, je suppose (je n’en suis pas sûr) que les entrées dans /media sont crées en fonction de ce qui est trouvé dans /dev.


#3

J’oubliais, si c’est bien un problème de module non chargé, il suffira de rajouter le nom du module dans le fichier /etc/modules (sans l’extension .ko) et tu auras ton lecteur de CD à chaque démarrage.


#4

Voici les modules chargés :

athlon:/etc/apt# lsmod | grep ide ide_cd 42528 0 cdrom 40284 1 ide_cd ide_generic 1472 0 ide_disk 19264 14 ide_core 138724 5 usb_storage,ide_cd,ide_generic,ide_disk,via82cxxx


#5

Est-ce que tu n’as pas une question de démontage qui serait oublié avant de fermer ton ordi ?


#6

J’avais pas fait attention à la ligne:

Mon /etc/fstab contient :
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0

Créé un directory ou tu veux:
mnt/cdrom0 ou /toto ca na pas d’importance

modifies ton fstab comme ca:
/dev/hdc /mnt/cdrom0 iso9660 ro,user,noauto 0 0

et essaye de refaire un mount

avant de re-tenter le mount, ouvre une 2ème console et tapes:

tail -f /var/log/messages

Tu verras tout de suite s’il y a des erreurs

Il semble que le répertoire /media est une nouveauté (de sarge ou du kernel 2.6 ?) et que c’est réservé aux montages automatiques mais je n’en connais pas encore le détail.

Si tes modules sont chargés il n’y a pas de raison que ca ne fonctionne pas …

Ricardo,

Est-ce que tu n’as pas une question de démontage qui serait oublié avant de fermer ton ordi ?

Etant donné qu’il s’agit d’un cdrom, qui est bien sûr en read-only, il ne peut pas y avoir de problème de ce côté là…
Et en ce qui concerne les file systems en read-write, le shutdown fait le ménage correctement en faisant des sync dessus avant de les démonter, donc pas de soucis de ce côté là …


#7

OK Jabba !


#8

Jabba, ta méthode fonctionne : merci :stuck_out_tongue: