Erreur de connexion Samba: error NT_status_connection_refused

Tags: #<Tag:0x00007fd6de70b2e8> #<Tag:0x00007fd6de70b220>

Bonjour à tous.
Je suis un nouveau sur Debian. Je dois mettre installer et configurer un serveur Debian avec un domaine créé avec Samba.
J’ai suivi donc un tutoriel qui m’a permis l’installation et la configuration de samba. Tout s’est bien passé. Mais je suis bloqué à l’étape de test d’authentification du serveur notamment avec la commande: /usr/local/samba/bin/smbclient -L localhost -U% .
J’ai la réponse suivante: connection to localhost failed error NT_status_connection_refused.
Même avec /usr/local/samba/bin/smbclient -L 192.168.1.2 (aadresse du serveur) , j’ai le même résultat.
Mes configurations
Debian 10.4
adresse du serveur 192.168.1.2
Samba serveur 4.12.5
smbclient 4.12.5

Merci de m’aider.

Bonjour

Juste pour information, au cas où :

https://www.cert.ssi.gouv.fr/

@MicP, merci pour l’info.
Mon problème est que je dois rendre mon rapport d’activité dans 5 jours. C’est dans le cadre éducatif.
Je viens de revoir mes commandes, le problème semble être le démarrage de samba.
En effet, la commande /usr/local/samba/sbin/samba -i -M single qui retourne ce message d’erreur suivant:
Failed to listen on 0.0.0.0:53 – NT_STATUS_ADDRESS_ALREADY_ASSOCIATED .

Bonjour,

Dommage de na pas avoir utilisé une installation standard avec les paquets debian…
Le dernier message d’erreur obtenu indique que samba ne peut se mettre en écoute sur le port 53 car un autre service l’utilise déjà.
Il suffit de te demander à quel service est habituellement attribué le port 53 et agir en conséquence.
netstat te permettra de voir qui est en écoute sur quel port.
La doc Samba t’aidera à faire un choix : https://wiki.samba.org/index.php/DNS_Administration

Bonjour
voici le résultat de la commande
netstat -llptun
sur ma machine virtuelle (virtualbox) Debian server 10.4 hébergée par windows 10.
CAPTURE netstat sur ma machine virtuelle debian server

configuration réseau machine virtuelle
interfaces réseaux de la machine
enp0s3 dhcp nat
enp0s8 static 192.168.1.2 /29
SAMBA est installé sur la machine virtuelle
Le résultat de netstat montre que le port 53 est utilisé par « named » sur TCP IP. Je ne suis pas sûr, mais ça doit être le service DNS de la machine qui utilise ce port. Dans ce cas, il ne dervrait pas avoir de blocage non?
J’ai fais des recherches depuis 2 jours.
Merci de me donner des pistes de solutions.

Je pense que tu as déjà tous les éléments en main pour trouver la solution et c’était déjà le cas avec le message d’erreur en #3.
Tu ne peux pas avoir deux services en écoute sur le même port. Tu as déjà un serveur DNS installé et configuré (par toi) en écoute sur le port 53. Samba tente de démarrer avec son propre serveur DNS interne en écoute sur le même port ce qui provoque son échec.

J’ai déjà donné le lien vers le Wiki Samba qui explique comment configurer samba avec différents DNS.

Merci pour votre aide, tout se passe bien.
J’ai arrêté le service bind. Pourtant hier, j’y pensais, mais je me disait que samba n’a pas son propre service DNS.
ça été deux jours de recherches instructives.
Encore une fois Merci.

ceci dit le serveur DNS samba ne fait pas le poids face à Bind.

C’est pour ça que Bruno1 avait conseillé de lire la documentation.