Erreur mise à jour des paquets

Tags: #<Tag:0x00007feddb94bbe8> #<Tag:0x00007feddb94baf8> #<Tag:0x00007feddb94b8a0>

Bonjour, en réalisant la commande
sudo apt update
je me retrouve avec des erreurs et un truc louche :
je suis sur un chromebook, dans lequel il y a debian 12, seulement le terminal, le reste fonctionne sur chromeOS, et il y a une recherche sur kali linux, je comprends pas trop parce qu’il n’y a pas kali du tout sur mon chromebook.

Get:7 http://archive-4.kali.org/kali kali-rolling InRelease [41.5 kB]

ensuite je me retrouve avec une erreur concernant apt-key, je sais qu’il est obsolète, j’ai cherché sur google un truc pour régler le problème mais, j’étais incapable de comprendre ce qu’il fallait faire donc bon…

    W: GPG error: http://archive-4.kali.org/kali kali-rolling InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY ED444FF07D8D0BF6
    E: The repository 'http://http.kali.org/kali kali-rolling InRelease' is not signed.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: https://hub.unity3d.com/linux/repos/deb/dists/stable/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

Si jamais quelqu’un a une solution je suis preneur, merci :smiley:

(PS : le site veut pas que je publie parce qu’on a le droit qu’à 2 liens par message, donc j’enlève un t de tous les http/https)

Je viens de corriger, il suffit que tu utilises les bonnes balises :wink:

lesquelles sont-elles ?

Edites ton premier messages pour les voir :wink: , il s’agit de triple quote :wink:

Bonjour,

Que vient faire du dépôt Kali Linux dans une Debian?

Peux-tu nous donner le contenu de tes sources.list et sources.list.d/

Simple c’est un Kali Linux l’OS :smiley:

Peut-être en te rapprochant d’un forum dédié à Kali déjà, le problème n’a rien à voir avec la couche Debian mais avec la sécurisation du dépôts KALI :wink:

1 J'aime
the public key is not available: NO_PUBKEY ED444FF07D8D0BF6

sudo gpg --keyserver keyserver.ubuntu.com --recv-key ED444FF07D8D0BF6

voilà sources.list :
deb https://deb.debian.org/debian bookworm main deb https://deb.debian.org/debian bookworm-updates main deb https://deb.debian.org/debian-security/ bookworm-security main deb http://http.kali.org/kali kali-rolling main contrib non-free deb https://deb.debian.org/debian bookworm main deb https://deb.debian.org/debian bookworm-updates main deb https://deb.debian.org/debian-security/ bookworm-security main deb http://http.kali.org/kali kali-rolling main contrib non-free
et ici sources.list.d :
cros.list google-chrome.list unityhub.list vscode.list

Cela n’a pas fonctionné il me renvoie :
gpg: key ED444FF07D8D0BF6: 2 duplicate signatures removed gpg: key ED444FF07D8D0BF6: "Kali Linux Repository <devel@kali.org>" not changed gpg: Total number processed: 1 gpg: unchanged: 1
l’erreur est encore exactement la même

C’est bien ce que je pensais tu as cumulé Kali Linux et Debian, c’est une mauvaise idée.

Mais j’ai rien fait moi… :disappointed_relieved:
je suis sur chromeOS j’ai juste activé leur terminal linux intégré et j’ai pas tenté de mettre kali sur cet ordi, donc bon, moi ça me va se supprimer la partie kali mais j’ai aucune idée de si elle est utile ou pas

  1. il s’agissait de réparer sudo apt update : ça met l’erreur ou pas ?

  2. les sources.lsit sont les endroits ou ton ordi va se mettre à jour en prenant l’un plutot que l’autre selon des critères
    chez toi on a donc debian/bookworm kali/rolling et ce qui est dans les 4 fichiers cros.list google-chrome.list unityhub.list vscode.list

une debian ne comprend que les lignes du sources.list contenant https://deb.debian.org/

pourquoi activer un terminal intégré à un navigateur alors que tu as un terminal fourni par la distribution sur ta machine?

je ne comprends pas tout non plus :
l’OS de ton ordi , c’est quoi?
tu l’as installé toi même?
tu as mis les fichiers dans sources.list.d? que contiennent-ils?

Je l’invite à ce rapprocher d’un forum Kali (voir même spécialisé sur ChromeOS) :wink: c’est pas pour rien …

Il est sur ChromeOS et il y a des occurrences à Kali linux dessus :wink:

Je tente un autre forum alors

oui l’erreur est toujours là,
ce que tu me dis c’est qu’il faut que toutes mes lignes du sources.list soit avec https://deb.debian.org/ au début ?

l’OS de mon ordi c’est chromeOS, je n’ai rien fait moi-même, c’est un chromebook avec chromeOS installé en paramètre d’usine. Dans ce chromeOS, il y a un terminal, dit terminal linux, et quand je regarde la version, il m’indique que c’est un debian 12. C’est tout ce que je sais. Et je n’ai rien mis moi même dans sources.list.d, ça s’est fait automatiquement.

ce n’est pas un terminal en navigateur, c’est le terminal de la machine, simplement chromeOS en lui-même n’a pas de terminal, donc la je suis sur le terminal linux qui est fourni directement par la machine.

J’ai finalement trouvé une solution, je la poste ici au cas où :

wget http://http.kali.org/kali/pool/main/k/kali-archive-keyring/kali-archive-keyring_2024.1_all.deb
sudo dpkg -i kali-archive-keyring_2024.1_all.deb
rm kali-archive-keyring_2024.1_all.deb

j’ai trouvé ça sur : linux - apt-get update issue in Kali - Super User
et ça m’a supprimé l’erreur, mais je comprends pas bien pourquoi, si quelqu’un comprends, hésitez pas à m’expliquer