erreurà make menuconfig


#1

Bonjour à tous

je tente présentement de compiler le noyau, et lors du makemenuconfig, j’ai toute une série d’erreurs apparement liées au fichier fixdep.c dans scripts/ …
j’y ai droit avec le 2.6.1 et le 2.6.3

pourtant avant de devoir reformater, j’avais compilé le 2.6.1 ‘sans’ problèmes…

sinon, oui j’ai installé tout ce qui est spécifié dans Documentation/Changes, et je suis en unstable…

Vous avez déjà vu ça?

eop


#2

au cas ou … as tu recupere le .config d’un noyau precedent ? Sinon assures toi d’avoir une version mise à jour de GCC


#3

non, je pars des sources décompactées telles quelles, sans avoir touché quoi que se soit.
pour gcc j’ai déjà 2.72 , 2.95 et 3.3 …

est-ce que ça pourrait venir d’un paquet que j’ai oublié d’installer ?

eop


#4

modules-init-tools est necessaire pour la serie des 2.6.x, peut etre celui la … sinon … ?


#5

non non, déjà installé en dernière version celui-là…

bon, je vais tenter un apt-get upgrade pour voir…

merci quand-même

eop


#6

Pour installer le noyau, il est recommandé de posséder également modutil
s et libncurses5-dev

Normalement avec ca, ca devrait passer.
Assure toi d’être en root, ca peut éventuellement résoudre le problème.


#7

Bravo!
c’était ncurses…

merci

eop