Et pour Kmail sous Sid, comment ?


#1

[code]ricardo3@debian-sid:~$ sudo apt-get install kmail
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.

Puisque vous n’avez demandé qu’une seule opération, le paquet n’est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
kmail: Dépend: kdelibs4 (>= 4:3.4.3-0mea0) mais ne sera pas installé
Dépend: libkcal2a (>= 4:3.4.3-0mea0) mais ne sera pas installé
Dépend: libkdepim1 (>= 4:3.4.3-0mea0) mais ne sera pas installé
Dépend: libkleopatra0a (>= 4:3.4.3) mais ne sera pas installé
Dépend: libkpimidentities1 (>= 4:3.4.3-0mea0) mais ne sera pas installé
Dépend: libksieve0 (>= 4:3.4.3-0mea0) mais ne sera pas installé
Dépend: libmimelib1a (>= 4:3.4.3) mais 4:3.3.2-3 devra être installé
Dépend: libqt3c102-mt (>= 3:3.3.4) mais ne sera pas installé
E: Paquets défectueux
ricardo3@debian-sid:~$
[/code]


#2
Cette librairie la pose un serieux probleme en testing mais je pensais que c'etais réglé sous sid??

Cette librairie la pose un serieux probleme en testing mais je pensais que c’etais réglé sous sid??


#3

Ricardo, est ce que tu penses à regarder dans synaptic les combinaisons de versions et de dépendances des paquets dont tu disposes pour voir si tu peux trouver toi même une configuration compatible à la main.
Sinon, as tu mis des préferences pour favoriser ce qui vient de ton dépot kde “bleeding edge” de chez alioth ?
ca va peut être t’obliger à downgrader des dépendances comme la libqt, mais au moins, aprés, tu devrais rester homogène.


#4

[quote]Ricardo, est ce que tu penses à regarder dans synaptic [/quote]Je voudrais bien mais encore faudrait-il que je le pusse. :laughing: :laughing: :laughing:


#5

perso j’ai l’impression que ton “debian-desktop” il fout un peu le souk dans tes dépendences …

rien de tel que les dépôts officiels moi je dis :smiley:


#6

Si c’est pas avec synaptic, mets des priorités sur tes dépots. Regardes à quoi ca ressemble dans le fil trucs et astuces “sources.list”, et compare avec la sortie d’apt-cache policy (sans paquet) pour comprendre les caracteristiques qui te permettent d’affecter une priorité particuliere à un dépot.
Lis le man preferences pour comprendre les différentes valeurs de priorité, et essayes de choisir une priorité differente (quand tu le peux) a chacune de tes sources.
Ensuite, relis le manuel d’apt-get, en particulier, dans apt-get install, les options pour spécifier une version de paquet: il y en a trois:
apt-get -t , qui force l’installation d’un paquet en prenant ses dépendances dans la même distrib
apt-get install /, pour choisir la distrib dans laquelle tu prend un paquet
apt-get install = = =, pour spécifier toute une combinaison de versions de paquets que tu veux installer simultanément (c’est sans doutes dans ce sens que tu trouveras la solution à ton problême).

Finalement, quand je n’arrive pas à trouver une combinaison qui me satisfasse, je passe par dselect, qui me trouve souvent des combinaisons installables.