/etc/apt/preferences absent de ma Debian !


#1

Bonsoir,

J’ai envie d’installer beagle sur ma testing, et j’ai donc ajouté des référentiels (j’ai failli écrire “dépôts” :slightly_smiling: ) de “unstable” à mon /etc/apt/sources.list.

Ne voulant pas faire de bétises, j’ai relu mon bouquin “Les cahiers de l’admin”, et je voulais maintenir un maximum de paquets en testing. Je me rappelais que c’était possible en modifiant un fichier de configuration.
D’après mon bouquin et mes recherches sur le forum, ce fichier doit être /etc/apt/preferences.

Mais moi, je n’ai pas ce fichier sur ma machine :blush:

Questions : n’existe-t-il pas en standard ? Si oui, cela signifie qu’il me faut l’écrire ?

Désolé de ma méconnaissance du sujet.


#2

Arggggh, j’ai posté dans le mauvais forum :open_mouth:

Et comme on ne peut pas supprimer un message, mais juste l’éditer, je suis bien ennuyé.

Y a-t-il un modérateur qui accepterait gentiment de le déplacer vers GNU/Linux général SVP ?

Désolé, je n’ai pas fait attention :confused:

J’ai cherché des réponses à mes questions, et franchement je ne trouve pas de clé :
http://www.fr.debian.org/doc/manuals/apt-howto/ch-apt-get.fr.html#s-dist-upgrade explique qu’il faut modifier les fichier /etc/apt/apt.conf aussi, mais celui-là n’est pas plus présent dans ma Debian…
J’ai par contre un dossier /etc/apt/apt.conf.d dans lequel se trouve 2 fichiers :
10apt-listbugs et 70debconf

L’un de vous pourrait-il me donner un exemple de fichier de configuration /etc/apt/preferences pour une Testing ?

Merci, et encore désolé pour mon erreur de forum.


#3

:laughing:


#4

ha, c’est malin :stuck_out_tongue: :laughing: :smiley:


#5

Ha, non d’une pipe, je n’y comprends rien !
J’ai donc créé un fichier /etc/apt/preferences contenant :[code]Explanation: Fichier construit selon le modèle indiqué sur le site http://www.debian.org/doc/manuals/reference/ch-package.fr.html#s-apt-install

Package: *
Pin: release a=testing
Pin-Priority: 800

 Package: *
 Pin: release a=stable
 Pin-Priority: 600

[/code]
Quand je lance la commande “Recharger” sous Synaptic, je me retrouve avec plus aucun paquets disponibles.
Si je renomme le fichier /etc/apt/preferences en /etc/apt/preferences.old, et je lance de nouveau “Recharcher” sous Synaptic, tous les paquets réapparaissent.

Pas glop de truc.

Je vais attendre vos avis et aides, sinon je crois que je faire de grosses bétises.


#6

Dans Synaptic, tu as la possibilité de bloquer directement un package à sa version, empéchant ainsi son upgrade lors d’une mise-à-jour, par le menu. Tu as aussi la possibilité de mettre à la fois des sources en testing et en unstable ; mais bon, le mieux à mon avis, si tu veux vraiment installer ton logiciel qui se trouve en unstable, c’est de mettre la source instable juste le temps d’installer ce logiciel, puis de désactiver ce dépot, si tu tiens à avoir un système suffisemment stable ; et si ce logiciel demande à mettre des paquets systèmes en unstable, ne l’installe pas, tout simplement.


#7

l’absence du paquet préfèrence est normale.
C’est un peu bizarre que tu n’aies pas d’apt.conf, mais ceci étant, apt utilise en même temps apt.conf, et apt.conf.d.
apt.conf et les fichiers d’apt.conf.d sont mis bout à bout pour former l’apt.conf qu’utilisera apt.

Maintenant, ton problême en particulier:
pour voir si ta configuration de preferences est correcte, tu fais un update et tu vérifies ce que donne la config de preferences avec apt-cache policy.
Maintenant, si tu n’as aucun paquet sous ynaptic, ca n’est pas normal.
PS: j’ai déplacé le fil. Sinon, tu as mon exemple de sources avec un fichier de pref dans le “trucs et astuces” sur les sources.list.


#8

Oui, ça, je l’ai déjà pratiqué notamment pour bloquer cdrecord qui rendait k3b inutilisable. Le problème, c’est que si je force tous les paquets demandés par l’installation de beagle, en testing, beagle ne s’installe pas (problème de dépendances).

C’est ce que je suis en train de tester sur ma Debian de test sur ma vieille machine… mais quelle lenteur… donc j’attends que l’installation se termine :slightly_smiling:

Merci des conseils.


#9

Me voilà déjà rassuré sur ce point.

[quote=“MattOTop”]C’est un peu bizarre que tu n’aies pas d’apt.conf, mais ceci étant, apt utilise en même temps apt.conf, et apt.conf.d.
apt.conf et les fichiers d’apt.conf.d sont mis bout à bout pour former l’apt.conf qu’utilisera apt.[/quote]
Je viens de regarder sur ma Debian de test sur ma vieille machine, je n’ai pas non plus ni preferences, ni apt.conf. Bizarre quand même !

[quote=“MattOTop”]Maintenant, ton problême en particulier:
pour voir si ta configuration de preferences est correcte, tu fais un update et tu vérifies ce que donne la config de preferences avec apt-cache policy.[/quote]
Voici le résultat :$ apt-cache policy Fichiers du paquet : 100 /var/lib/dpkg/status release a=now 500 ftp://ftp.nerim.net testing/non-free Packages release o=Debian,a=testing,l=Debian,c=non-free origin ftp.nerim.net 500 ftp://ftp.nerim.net testing/contrib Packages release o=Debian,a=testing,l=Debian,c=contrib origin ftp.nerim.net 500 ftp://ftp.nerim.net testing/main Packages release o=Debian,a=testing,l=Debian,c=main origin ftp.nerim.net 990 ftp://ftp.nerim.net stable/non-free Packages release v=3.1r1,o=Debian,a=stable,l=Debian,c=non-free origin ftp.nerim.net 990 ftp://ftp.nerim.net stable/contrib Packages release v=3.1r1,o=Debian,a=stable,l=Debian,c=contrib origin ftp.nerim.net 990 ftp://ftp.nerim.net stable/main Packages release v=3.1r1,o=Debian,a=stable,l=Debian,c=main origin ftp.nerim.net 500 http://ftp.rfc822.org testing/updates/non-free Packages release o=Debian,a=testing,l=Debian-Security,c=non-free origin ftp.rfc822.org 500 http://ftp.rfc822.org testing/updates/contrib Packages release o=Debian,a=testing,l=Debian-Security,c=contrib origin ftp.rfc822.org 500 http://ftp.rfc822.org testing/updates/main Packages release o=Debian,a=testing,l=Debian-Security,c=main origin ftp.rfc822.org 990 http://ftp.rfc822.org stable/updates/non-free Packages release v=3.1,o=Debian,a=stable,l=Debian-Security,c=non-free origin ftp.rfc822.org 990 http://ftp.rfc822.org stable/updates/contrib Packages release v=3.1,o=Debian,a=stable,l=Debian-Security,c=contrib origin ftp.rfc822.org 990 http://ftp.rfc822.org stable/updates/main Packages release v=3.1,o=Debian,a=stable,l=Debian-Security,c=main origin ftp.rfc822.org 500 http://security.debian.org testing/updates/non-free Packages release o=Debian,a=testing,l=Debian-Security,c=non-free origin security.debian.org 500 http://security.debian.org testing/updates/contrib Packages release o=Debian,a=testing,l=Debian-Security,c=contrib origin security.debian.org 500 http://security.debian.org testing/updates/main Packages release o=Debian,a=testing,l=Debian-Security,c=main origin security.debian.org 990 http://security.debian.org stable/updates/non-free Packages release v=3.1,o=Debian,a=stable,l=Debian-Security,c=non-free origin security.debian.org 990 http://security.debian.org stable/updates/contrib Packages release v=3.1,o=Debian,a=stable,l=Debian-Security,c=contrib origin security.debian.org 990 http://security.debian.org stable/updates/main Packages release v=3.1,o=Debian,a=stable,l=Debian-Security,c=main origin security.debian.org 500 ftp://ftp2.fr.debian.org testing/main Packages release o=Debian,a=testing,l=Debian,c=main origin ftp2.fr.debian.org Paquets étiquetés :

Ca ne me fait ça que si je place un fichier /etc/apt/preferences. Si je le supprime ou le renomme, synaptic a de nouveau un comportement normal.

Ok, merci d’avoir remis le fil au bon endroit, et merci pour les conseils, je vais creuser la question. J’avais fait une recherche non concluante sur le forum. J’ai souvent du mal à trouver la bonne information sur les forums :blush:


#10

Tu peux regarder par la quelques infos interressante

forum.debian-fr.org/viewtopic.php?t=1728

andesi.org/index.php?node=130


#11

Merci Ashgenesis, je vais lire tout ça attentivement, et je reposerai des questions sur ce que je n’aurai pas compris (donc à bientôt 8) ).