Euj j'ai la poisse ou c'est normal ?


#1

Bonjour

j’ai un petit serveur (Debian 9) samba à la maison constitué d’un raid5 de disque western digital 2TO

J’avais quelques alertes smart sur sdb1 depuis un moment donc en prévision, j’achète un disque dur de remplacement.

Jusqu’au moment ou, 8 mois plus tard, je reçois le fameux message:

Personalities : [raid6] [raid5] [raid4] [linear] [multipath] [raid0] [raid1] [raid10]
md0 : active raid5 sde1[4] sdd1[3] sda1[0] sdb1[1](F) sdc1[2]
      7813529600 blocks super 1.2 level 5, 512k chunk, algorithm 2 [5/4] [U_UUU]
      bitmap: 6/15 pages [24KB], 65536KB chunk

Number   Major   Minor   RaidDevice State
       0       8        1        0      active sync   /dev/sda1
       -       0        0        1      removed
       2       8       33        2      active sync   /dev/sdc1
       3       8       49        3      active sync   /dev/sdd1
       4       8       65        4      active sync   /dev/sde1

       1       8       17        -      faulty   /dev/sdb1

pas grave

J’ouvre le serveur, met mon disque neuf à la place, redemarre, un fdisk me confirme que c’est bien sdb qui est neuf donc c’est parti pour la remise en place du raid software

sfdisk -d /dev/sda | sfdisk /dev/sdb

suivi de

mdadm --manage /dev/md0 --add /dev/sdb1

la reconstruction commence, arrive à 5% et la le disque sdb passe en faulty à son tour et plus de réponse sur un smartctl -a /dev/sdb

Donc j’ai la poisse ou j’ai raté quelque chose?


#2

Peut-être que l’électronique ou l’alimentation du disque à cet emplacement est défectueuse. On peut appeler cela avoir la poisse mais c’est une possibilité à envisager.
Je suppose que le disque neuf est encore sous garantie.
Quelle est la marque du petit serveur ? Avez-vous déjà eu des problèmes avec ?

Cordialement,
Regards,
Mit freundlichen Grüßen,
مع تحياتي الخالصة


F. Petitjean
Ingénieur civil du Génie Maritime.

« Celui qui, parti de rien, n’est arrivé nulle part n’a de merci à dire à personne !! »
Pierre Dac


#3

Ben un disque neuf sorti d’un emballage scéllé qui est HS après 5 minutes de rotation (jamais vu de mon coté en plus de 20 ans d’informatique), oui c’est la poisse …

Pour le serveur c’est du home made sur base d’une carte mère Asus E35M1-l deluxe et il tourne nickel, aucun soucis depuis que je l’ai. J’ai juste dû changer une alim (un comble d’ailleurs vu la conso de la carte)


#4

Comme le dit LittleJohn c’est peut-être le connecteur SATA et/ou l’alimentation de l’emplacement du disque qui sont défectueux, ça vaut la peine d’effectuer des tests croisés pour en avoir le cœur net.


#5

Ce que dit @littlejohn75 (avec beaucoup de mots souvent) c’est que ton problème vient peut être de ce sur quoi tu connectes tes disques mais que tes deux disques sont peut être sains.
Je crois.


#6

En effet c’est des possibilités à envisager.

Mardi je vais recevoir un autre HDD, donc je vais en avoir le coeur net, mais bon:

L’ancien disque allait rendre l’âme ça je le savais vu la quantité d’erreurs smart du type OfflineUncorrectableSector (Device: /dev/sdb [SAT], 21 Offline uncorrectable sectors sur le dernier rapport) et CurrentPendingSector (Device: /dev/sdb [SAT], 646 Currently unreadable (pending) sectors).

Maintenant:
Coté alim: d’autres disques sont branchés sur le même cable d’alim que le disque en question et pas de soucis pour eux.
Coté cable sata: si le connecteur avait été défectueux, à mon avis sur le fdisk -l ce serait déjà parti en vrille avec une non reconnaissance du disque, voir même lors de la création de la partition.

Par contre, une fois le disque changé, au boot aprés grub, j’ai eu le message: ata2: softreset failed (device not ready) qui a disparu aprés 1 minute d’attente. J’ai mis cela sur le fait que le nouveau disque était vierge et que md0 était en mode dégradé.

Bon sinon bien sûr je vais tester le disque. J’ai un dock externe pour cela.

Déja voila le rapport crystaldiskinfo de l’ancien disque:

----------------------------------------------------------------------------
 (5) WDC WD20EARS-00MVWB0
----------------------------------------------------------------------------
           Model : WDC WD20EARS-00MVWB0
        Firmware : 51.0AB51
   Serial Number : WD-WMAZA4387355
       Disk Size : 2000,3 GB (8,4/137,4/2000,3/2000,3)
     Buffer Size : Inconnu
     Queue Depth : 32
    # of Sectors : 3907029168
   Rotation Rate : Inconnu
       Interface : UASP (Serial ATA)
   Major Version : ATA8-ACS
   Minor Version : ----
   Transfer Mode : ---- | SATA/300
  Power On Hours : 72582 heures
  Power On Count : 91 x
     Temperature : 20 C (68 F)
   Health Status : Prudence
        Features : S.M.A.R.T., 48bit LBA, NCQ
       APM Level : ----
       AAM Level : ----
    Drive Letter : 

-- S.M.A.R.T. --------------------------------------------------------------
ID Cur Wor Thr RawValues(6) Attribute Name
01 _99 _99 _51 0000000613DA Taux Erreur en Lecture
03 253 253 _21 0000000003E8 Temps moyen mise en rotation
04 100 100 __0 00000000005C Décompte des cycles de mise en rotation
05 170 170 140 00000000023E Nombre de secteurs réalloués
07 200 200 __0 000000000000 Taux d'erreurs d'accès des têtes
09 __1 __1 __0 000000011B86 Heures de Fonctionnement
0A 100 253 __0 000000000000 Nombre d'essais de relancement de la rotation
0B 100 253 __0 000000000000 Nombre de recalibration
0C 100 100 __0 00000000005B Nombre total de cycles marche/arrêt du disque dur
C0 200 200 __0 000000000033 Nombre de fois que l'armature magnétique a été rétractée automatiquement suite à une coupure secteur
C1 __1 __1 __0 0000006A477B Nombre de fois que la tête a changé de position
C2 130 _85 __0 000000000014 Température interne actuelle.
C4 __1 __1 __0 000000000221 Nombre d'opérations de réallocation (remap)
C5 199 198 __0 000000000286 Nombre de secteurs "instables"
C6 200 200 __0 000000000015 Nombre total d'erreurs incorrigibles d'un secteur
C7 200 200 __0 000000000000 Nombre d'erreurs dans le transfert de données via le câble d'interface
C8 __1 __1 __0 00000001C182 Nombre total d'erreurs à l'écriture d'un secteur

#7

Ca peut venir du contrôleur, pas forcément du disque, même si le “unreadable sector” est quand même inquiétant.


#8

Bon ben voilà, nouveau disque reçu, installé et j’en suis à 50% de la reconstruction du raid, tout va bien…pour le moment :smirk:

Premiere fois qu’un disque dur neuf me lâche…


#9

deux en une semaine chez moi : le premier a crâmé la connectique ( avec fumée blanche mais pas de pape, et à rouen on se méfie des fumées - et des préfets ) le deuxième refuse simplement. Les 2 de LDLC


#10

arff sur ce coup tu gagne :rofl::rofl:


#11

A une époque où je vendais du matos, je me souviens d’une génération de hdd 30Go, les premiers 7100 tours, je crois, pourtant de bonne marque (j’ai oublié laquelle) où j’avais eu pas loin de 20% de retours dans les 6 mois.
Ca a duré genre 1 an avant que les disques de cette marque redeviennent fiable.
Genre Boeing.
Ca arrive.