Exécutables non reconnus comme tels ?


#1

Bonjour,

Après près de deux ans d’absence de cette distribution, je redécouvre Debian (dans sa version 9 x64) et je suis particulièrement séduit par l’interface Cinnamon.

Cependant, je découvre aussi des nouveautés qui me posent de petits problèmes.

En effet, je développe de petits utilitaires avec l’IDE QB64 qui cré des exécutables après traduction du source écrit en BASIC en C++ puis compilation avec g++.

Or, si je double clique sur un de ces exécutables, j’ai d’abord un message qui dit : “Unknown file type” puis je doit cliquer sur le bouton “Make Executable and Run” pour lancer le programme.

En revanche, ces exécutables se lancent sans problème avec la ligne de commande comme par exemple “./mon_programme”.

Que dois-je faire pour que ces exécutables soient reconnus comme tels et puissent être lancés par un double click ?

Merci d’avance de votre aide.


#2

Peut-être créer un lanceur pour ?


#3

Merci Clochette de cette suggestion.

Oui ce serait effectivement une solution (à la OS/X) !!!

Cependant, ce n’est pas ce que je ce que je cherche.

Il me semble, par rapport à des versions antérieures de Debian (et à d’autres distributions), que Debian 9 crée maintenant des exécutables “untrusted”.

Ma question est donc de savoir comment modifier (quelle commande utiliser) ces exécutables et les qualifier de “trusted” pour qu’ils puissent être lancés par un double click.

Un truc du genre “chmod -xyz my_prog” justement pour éviter la demande de “Make Executable and Run” ?

Justement, que fait donc cette commande et comment la rendre permanente car à chaque lancement par double click, la question est posée.

Merci d’avance pour d’autres idées.

Cordialement.


#4

chmod a+x my_prog


#5

Merci gilles2

Je vais essayer ça.


#6

Oops, ça ne fonctionne pas.

En fait, j’ai bien précisé que les programmes étaient bien des exécutables que je peux lancer via la ligne de commande et donc le chmod +x ne sert à rien puisque c’est déjà fait.

En fait, j’ai trouvé la solution qui est due à un problème de paramétrage de g++.

J’ai eu un problème similaire sous Mint 19 et Ubuntu 18.04 car le paramétrage de g++ indiquait --enable-default-pie ce qui a été corrigé par l’ajout du paramètre -no-pie dans la ligne de commande de compilation.

Heureusement, cela fonctionne aussi avec Debian 9.

Merci de votre temps.