Exim4 et smtp gmail sécurisé

Tags: #<Tag:0x00007f58ce17d328>

Bonjour à tous,
Depuis fin mai 2022 ma configuration Exim4 pour gmail ne fonctionne plus car Google a modifié les règles de sécurité. J’avais autorisé dans la configuration gmail les application moins sécurisées mais cette option est maintenant désactivée.

Sur les OS j’avais ensuite simplement configuré le serveur smtp (IP address or host name of the outgoing smarthost: smtp.gmail.com::587 ) ainsi que les user/password et tout ceci fonctionnait très bien pour l’envoi de mails via le système comme un message au boot de la machine ou encore les sorties logwatch ou domoticz.

Quelqu’un aurait-il une solution pour la configuration smtp gmail , ou éventuellement une autre passerelle smtp à me conseiller ?

J’utilise Debian 11 et RaspiOS

Merci

Donc ton adresse GMail reçoit des e-mails à transférer via un domaine local OU tu utilises un client / outil au boot qui se connecte à ton compte pour envoyer l’e-mail ?

Je ne suis pas très sûr d’avoir compris ta situation.

Bonjour

as tu générer un mot de passe pour l’application exim comme le recommande google?

Exim envoie les mails par « smarthost » via un compte gmail que j’ai créé spécialement pour cela.
Je fournis à exim le nom du serveur smtp.gmail.com::587 et le user/password de connexion à gmail dans /etc/exim4/passwd.client sous la forme smtp.gmail.com::

Je fournis à exim le nom du serveur smtp.gmail.com::587 et le user/password de connexion à gmail dans /etc/exim4/passwd.client sous la forme smtp.gmail.com::

Le mot de passe est en clair et pas généré, c’est peut-être ça. Je vais chercher les explications google , si tu peux me guider …

Si je comprend bien, un smarthost est juste une sorte de relais entre un client et un serveur mail qui enverra pour de bon l’e-mail. J’ai bon ?

Si c’est le cas ce smarthost doit respecter je suppose des règles très strictes de la part de Google, notamment SPF et DKIM par exemple ?

As-tu un domaine que l’on peut checker via différents outils pour s’assurer que ta configuration est valide selon saint Google ? Toujours dans l’idée qu’il y a bien un domaine qui communique, de toute façon au moins une IP je présume.

PS: Je m’y connais un peu en mail mais ça reste un point faible chez moi :slight_smile: !

Je crois si ma mémoire est bonne

il faut generer un mot de passe par application
donc tu remplace ton mot de passe par celui generér

mot de passe application google

J’utilise le même système.

en gros tous les messages (emails) sont routé vers le serveur smtp de google.
Il récris l’email expéditeur par son email google

et voila

Donc ce smarthost doit se plier aux règles de Google ? Notamment, SPF & DKIM ?

non

c’est different.
tous les mails sont envoyé par le serveur mx de google donc pas de spf ni dkim.

exim fais la réécriture vers le serveur google.fr

Et comment Google s’assurent que les e-mails sont OK pour partir ?

Ils reçoivent quoi qu’il arrive les e-mails et valide ou non ensuite leur envoie ?

ils sont bloqué dans queue si google ne les prend pas .

et renvoyé des que le serveur mx google est accessible.

Bonjour
Il faut passer en authentification OAuth2, dans un client mail comme Thunderbird cela se fait simplement, mais pour Exim4 aucune idée

Non, pas forcément. L’OAuth2 fonctionne mais n’est pas LE seul moyen.

J’ai expliqué dans un autre post, comment je faisais avec la 2FA :

  • aller dans les paramètres de sécurité du compte Google, lié au compte Gmail,
  • activer la 2FA
  • générer un mot de passe par application.
  • dans le MUA (ou Exim dans ce cas), pour la connexion, au lieu de mettre le mot de passe lié au compte, mettre le pass par application.
1 J'aime

Cette méthode ne fonctionne plus depuis le 31 mai 2022, d’où l’ouverture de ce sujet.

Bonjour à tous(tes),
ça marche !!

J’ai utilisé la méthode de « Mots de passe des applications » dans la partie « Sécurité » « Connexion » à google. (Je ne connaissais pas cette option)
J’ai sélectionné l’application « messagerie » et « autre » pour le nom de l’appareil.

Puis dans /etc/exim4/passwd.client , j’ai mis le mot de passe généré à la place de l’ancien

Mes petites machines perso peuvent à nouveau envoyer des mail via Google

Merci à tous pour votre aide !

2 J'aime

elle fonctionne, je l’utilise. et elle fonctionne pour l’auteur du sujet.

2 J'aime