Firmware non trouvé sur carte SD après update

Tags: #<Tag:0x00007fb999291468>

Bonjour,

J’ai un raspberry 4 et raspberry OS sur une carte SD. Comme cela fait plusieurs semaines que je ne l’avais pas utilisé, j’ai voulu mettre à jour en suivant les conseils sur leur forum.

sudo apt update
sudo apt full-upgrade

Après la deuxième commande, une erreur est apparue. Elle indiquait que je n’avais plus assez de place sur la carte or, j’ai 16 Go et quasi rien de plus que l’installation.

Je n’ai pas le message exact, car j’ai rebooté et « firmware non trouvé. Veuillez insérer une carte SD » est le seul message que j’ai.

Ayant une autre carte, j’ai essayé et cela fonctionne sans que je ne mette à jour. Si quelqu’un pouvait m’aider ce serait top, car je n’ai pas envie de reformater ma carte.

Merci beaucoup,

Nico

Pas évident.
Il est peut être possible d’utiliser sur un PC l’autre carte pour tenter de voir ce qui manque en comparant les contenus des deux cartes.
La carte rapsberry est formatée avec deux partitions, une petite en FAT (boot) l’autre en ext4 (système).
Bonne chance !

On dirait juste un problème de carte, non?
Teste la carte sd sur un ordi.

Bonjour, merci pour vos réponses. Pour le moment, je n’arrive à rien car je n’ai pas d’ordi avec lecteur de carte SD. Je suis en train de chipoter pour démarrer mon raspberry à leur d’une clef USB, puis je verrai ce qui est écrit sur la carte sd. Encore merci, désolé que je n’arrive pas à répondre rapidement. Nico

Voilà où j’en suis: le dossier boot ne contient que 25,5 kio et 6 fichiers, mais je n’arrive pas à y accéder, car le propriétaire est root et c’est le seul qui a les accès, même pour afficher les fichiers. Je présume que c’est chown et chmod… Je vais chipoter.

Je suis connecté en tant que pi, qui est considéré comme le super-utilisateur sur raspberry pi

Opération non permise si je rentre chmod -R 777 ./pi

(Le chemin est correct: je suis bien sur la carte SD avec cd media)

Si je rajoute sudo devant rien ne se passe, il ne me demande même pas mon mot de passe.

J’ai essayé de lancer pcmanfm en sudo pour changer les autorisations en mode graphique, rien n’y fait non plus: (

Ah, oui, il manque des trucs, le mien fait 46 Mio pour 249 fichiers.

Le dossier boot du Raspi est une partition en FAT32, ça dépend des options de montage, le FAT32 ne gérant pas les droits d’accès. Voici les options que j’ai dans le retour de mount :

fmask=0022,dmask=0022

Normalement, ce sont celles par défaut, mais essaie de les ajouter explicitement en montant le système de fichier et ça devrait aller.

Non, l’utilisateur pi est juste dans le groupe sudo. Si tu lances la commande id et que le champ uid ne vaut pas 0, tu n’es pas le super-utilisateur.

┌ (almtesh@Lookout + 0) (23/09/21 - 7:02:48) (0.42 - 0%) (~)
└% sudo id
uid=0(route) gid=0(root) groupes=0(root)
┌ (almtesh@Lookout + 0) (23/09/21 - 7:02:53) (0.39 - 0%) (~)
└% id
uid=1000(almtesh) gid=27(sudo) groupes=27(sudo),4(adm),20(dialout),24(cdrom),29(audio),44(video),46(plugdev),60(games),100(users),105(input),109(netdev),997(gpio),998(i2c),999(spi)

Là, almtesh n’est pas super-utilisateur, mais peut utiliser sudo, alors que route est le super-utilisateur.