Fonctionnement Freebox serveur et player à travers vpn


#1

Bonjour à tous, je me permet de recreer un sujet qui a deja ete vu en 2016 mais malheureusement je n’arrive pas à mes fin à 100% Après une semaine de recherche et le poste en question est classé résolu. Que les admin me fouette si j’ai fait une bêtise :wink:

Voilà ma configuration :
A ma boutique :
internet — Freebox serveur v6 — (eth0) raspberry pi 3 (serveur vpn interface tap0) — connection maison

Jai créé un pont (br0) entre eth0.100 et tap0.100 afin d’envoyer la synchro du player A la maison par le vpn.

A la maison :
Internet — routeur Huawei 4g illimité — (eth0) odroid c2 sous debian (eth1- clé USB rj45) — Freebox player

L’odroid c2 est connecté au serveur vpn de la boutique et réceptionne sous tap0 les donnes du vpn.

J’ai créé un pont (br1) entre tap0.100 et eth1.100 pour récupérer la synchro pour le player.

Jusque là tout fonctionne pour le mieux. Ma synchro fonctionne et je peux avoir la télé donc voici ma configuration de départ. Demain, tout à l’heure c’est 2h du mat, je posterai mes fichiers configuration.

Voilà mon problème, peut être que quelqu’un l’as déjà eu. Je ne peux recevoir que le service tv tous les services annexes, YouTube et autres appli ne fonctionne pas en fait c’est simple j’ai le réseau en croix en bas de l’écran. Mais la tv pas de problème.

J’ai essayé de créé un pont entre eth0 qui a internet à 80mb et eth1 avec br0 mais rien n’y fait je perd toute connection avec L’odroid. Je ne peux plus le joindre, je dois à chaque fois réparer le fichier etc/network/interface pour enlever br0 et la je récupère ma connection à l’odroid.

Avez vous déjà rencontré ce problème. Pensez vous que je dois simplement ajouter des règles de routage ou je fais quelque chose de surréaliste ?

Merci d’avance pour vos reponses.

Richard

Nota

Le réseau 4g de la maison est sous 192.168.0.0 alors que celui pour le Freebox player est sous 192.168.1.0
voir mon fichier en dessous


#2

Voilà mon fichier

GNU nano 2.7.4 Fichier : /etc/network/interfaces

source /etc/network/interfaces.d/*

# Network is managed by Network manager

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet manual

auto br0
iface br0 inet manual
address 192.168.1.1
network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255
bridge_ports eth0 eth1

# pont inter freebox

auto br1
iface br1 inet manual
bridge_ports tap0.100 eth1.100
bridge_stp off
bridge_maxwait 0
post-up sysctl -w net.bridge.bridge-nf-call-iptables=0

#3

Dans cette situation je ferais une capture du trafic du player pour voir avec quoi il essaie de communiquer.


#4

Bonsoir,
Ok c’est vrai que je n’y avais pas pensé. Je m’en occupe demain. Je ne sais pas comment faire mais je vais tâcher de chercher :wink:

Et la je vais faire un rapide test mais ma dernière configuration ne fait plus planter ma carte reseau avec les 2 bridges. Ça ne fonctionnait toujours pas quand meme et surtout plus de synchro player… et en cherchant le probleme je me suis rendu compte que mon rpi3 avec le serveur vpn, bridge vlan100 et la Freebox v6 connecté avait perdu le pont du vlan100 donc maintenant que j’ai tout réparé et automatisé je vous tiendrai au courant.
Si ça fonctionne je mettrai toutes les sources en cas de besoin pour d’autres.

Bonne nuit :wink: