Forcer CRON a exécuter une commande


#1

Salut,

J’ai un cron qui exécute une gravure de DVD tous les jours à une heure donnée.

Quand le DVD est un DVD-R ou DVD-RW vierge la gravure marche mais si c’est un DVD-RW déjà commencé ca ne marche pas.

Si j’exécute la commande à la main, quand c’est un DVD-RW déjà commencé, il me fait :

[quote]localhost:/etc# growisofs -Z /dev/hda -r -J -speed=4 /mnt/dienst/backup
WARNING: /dev/hda already carries isofs!
About to execute 'mkisofs -r -J /mnt/dienst/backup | builtin_dd of=/dev/hda obs=32k seek=0’
Sleeping for 5 sec…
Sleeping for 4 sec…
Sleeping for 3 sec…
Sleeping for 2 sec…
Sleeping for 1 sec…
[/quote]
(quand le dvd est vierge il n’y a pas de décompte)
Donc je pense que c’est à cause de décompte que la gravure est blockée…

Mais je n’ai pas trouvé de solution pour y parer…

Est ce que quelqu’un peut me donner un coup de main?

MERCI!!!


#2

j’ai changé le titre du topic peut etre que cela interpellera plus :frowning:


#3

dis donc, tu n’avais pas déjà un problême de cron sur le même sujet :wink:
as tu essayé -log-file log_file Redirect all error, warning and informational messages to log_file instead of the standard error. et-quiet This makes mkisofs even less verbose. No progress output will be provided
as tu lu la doc de mkisofs ?


#4

:blush: Oui je l’avais bien… et il n’est toujours pas résolu, donc je me suis dit qu’il valait mieux repartir sur d’autres bases…

Donc tout ce que tu as mis j’ai déjà essayé et le “quiet” eh bien il n’est pas aussi tranquil que je le voudrais et ca me fait le meme prob que la normale… et pour le -log ca ne change pas grand chose non plus…


#5

essayes d’executer ta commande avec une redirection du genre 2>&1 >/dev/null
2>&1 -> renvoie stderr vers stdout

/dev/null -> renvoie ensuite le tout vers le null device

Ca devrait t’éviter toute trace…


#6

PS: tu as essayé de mettre ta commande dans un script, et de tester plusieurs shells ( ‘#!/bin/bash’, ‘#!/bin/ash’, ‘#!/bin/csh’, etc…).
Même de passer des arguments au shell (-q)
PPS: et aussi, maintenant que j’y pense, de prendre ton entrée standard sur /dev/yes (genre ‘commande </dev/yes’) .


#7

[quote=“MattOTop”]PS: tu as essayé de mettre ta commande dans un script, et de tester plusieurs shells ( ‘#!/bin/bash’, ‘#!/bin/ash’, ‘#!/bin/csh’, etc…).
Même de passer des arguments au shell (-q)
PPS: et aussi, maintenant que j’y pense, de prendre ton entrée standard sur /dev/yes (genre ‘commande </dev/yes’) .[/quote]
Salut,

J’ai essayé 2>&1 >/dev/null et ca ne marche pas… il ne fait pas de redirection… c’est un genre de décompte et ca doit etre pour ca doit que les sorties ne sont pas interceptées…

et pour le reste… j avais mon code dans un fichier #!/bin/sh mais je ne sais pas si ca fait une différence avec bash et les autres (j’ai essayé avec bash c’est le meme résultat.)

par contre je ne comprends pas ce que tu entends par passer l’argument shell -q
et c’est quoi le /dev/yes… j’ai essayé quelques variante ca fait toujours le meme prob…


#8

une seule réponse -use-the-force-luke
j’en reviens pas


#9

c’est vrai que ça m’a l’air d’être un sacré fourre tout, cette option :laughing: