Fstab & activation d'un service


#1

voila ma table :

/etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 /dos vfat defaults 0 2
/dev/hda5 /windows vfat defaults 0 2
/dev/hda3 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
~
~

Je veux pouvoir accéder en simple utilisateur a la partition /dos et /windows. Donnez moi un coup de main je pige rien .

Autre chose, comment activer un service quel qu’il soit. NTP ou Xscreensaver ou autre. Je suppose qu’il y a une methode générale. Non?


#2

man fstab
man mount

Tu corriges comme ça:

/dev/hda6 /dos vfat rw,user,noauto 0 2

/dev/hda5 /windows vfat rw,user,noauto 0 2

Et après t’'as plus qu’à taper mount /dos et mount /windows en user normal.

apt-cache search ntp
Et tu installes le client ntp qui te convient.

man ntpdate

Ensuite, tu tapes par exemple:
ntpdate un_serveur_de_synchronisation

ntpdate sous linux, sauf erreur, c’est un machin que tu lances manuellement ou via la crontab.
Il y a aussi des outils qui se lancent via les runlevels (/etc/init.d) du genre xntpd. Je les connais pas sous linux. Essayes aussi de chercher avec apt-cache search …
Un conseil: va regarder le répertoire /etc/init.d et voit ce que font les scripts. Ce sont tous les services démarrés au boot de la machine. (et stoppés au shutdown…)

apt-get install xscreensaver et ensuite tu vas dans le panneau de contrôle gnome ou kde pour l’activer


#3

man update-rc.d


#4

Grand merci pour toutes ces infos.
Mais je me demande quand même pourquoi quand mon fstab est en noauto ça marche, et quand il n’y a rien ça ne m’affiche qu’un permission denied.
Merci pour les precisions sur les services. :smiley:


#5

quand tu mets le disque en “noauto,user”, le disque n’est pas monté à l’origine, mais n’importe quel user peut le monter. Seulement l’user qui le monte se l’approprie, et les autres users ne peuvent rien faire avec (sauf avec des droits super).
De la même manière, si tu le met en “auto”, même en “user”, comme c’est le “root” qui le monte au boot, les autres users n’ont pas le droit d’y accèder, tant que le root ne l’a pas démonté.
Une solution pour qu’il soit monté et que tout le monde puisse y accèder, c’est de le mettre en “users” (avec un ‘s’). on peut aussi mettre une option “gid=6” (le 6, c’est le group “disk”) et rajouter les users qui auront le droit de (dé)monter dans ce même groupe.


#6

C’est vraiment bien fait linux. Je suis content d’apprendre autant grace à cette distro.
Bon d’après Matt, si j’ai tout bien compris, la solution de mettre users (aux pluriel) pose quand même des soucis de securité, puisque dans ce cas précis n’importe qui s’introduisant sur mon micro peut avoir accés aux fichiers.
Donc le solution alternative et de rajouter gid=6 en option dans le fstab. Mais je ne sais pas coment rajouter un utilisateur dans un groupe. Est-ce que vous pouvez me donner une idée, ou j’abuse de la gentillesse de tout le monde sur le forum?
Cependant, promis quand je serai plus calé, j’aiderai les autres aussi.


#7

Voila une petite aide sur le fichier fstab

Voila un exemple pour l’utilisation du gid


#8

et pour ajouter ‘toto’ au group ‘disk’:
adduser toto disk