GMusicBrowser - Dossier Music sur NAS

Tags: #<Tag:0x00007ff8e6183d78> #<Tag:0x00007ff8e6183c60> #<Tag:0x00007ff8e6183b70>

Bonjour…
J’ai peut-être enfin trouvé mon lecteur audio sur Linux: GMusicBrowser.
Voici le lien du site officiel (en): https://gmusicbrowser.org/
Il me convient pour sa gestion de bibliothèque musical conséquente.
J’ai environs un peu moins de 2To principalement en .flac (compress: 5). C’est assez conséquent.
Donc le tout est sur un NAS Asustor en local. (Nas: vieux coucou. Pour moi c’est un mauvais achat.)

Ce NAS est monté chez moi /media/XYZ/Nas. (Il ne se monte pas automatiquement, faut se connecter à chaque début de session).

Et depuis GMusicBrowser, je n’y ai pas accès. Son gestionnaire de fichier ne donne pas accès au dossier /media.
Donc je me disais qu’il y avait possiblement le moyen de un, le monter à chaque ouverture de session via un script au démarrage, serte, mais le monter par exemple dans /home/XYZ/Musique/DossierZiq.

J’espère ainsi pouvoir le mentionner dans GMusiqueBrowser comme chemin d’accès pour la Bibliothèque, vu que via le gestionnaire de fichier pour choisir son dossier musique, donne accès entre autre à /home/XYZ/Musique/

Merci
à bientôt

cr.


Si je puis ajouter (hors de ce contexte) ceci:
Tout cela dit, si je ne me trompe, ce lecteur audio m’a l’air assez bien et réellement performant. Pas spécialement si on recherche une qualité ‹ Audiophile ›. (là, je ne sais pas de trop, on parle souvent de Audacious sur un système optimisé et ne servant qu’à l’écoute, soit soit, le sujet est long). Mais à mes premier regards: c’est agréable.

Tu utilises /etc/fstab pour faire un montage automatique, pas besoin d’un script.

Quand au logiciel s’il ne voit pas le point de montage c’est qu’il n’a pas les droits nécessaires.

1000 excuses !

J’avais, en rédigeant, penser à mettre la ligne correspondante du /etc/fstab
oubli.

De plus, double excuse, j’y vois une ‹ erreur › dans cette ligne…
J’y ai inscit comme point de montage: /mnt/302T/music
Me semble donc qu’en renseignant /home/XYZ/Musique/Nas
cela devrait aller…

Tout de même voici mon fichier fstab (rectifié) pour mon NAS:

/IP-NAS-LOCAL/crp-music   /home/XYZ/Musique/Nas   cifs   noauto,comment=systemd.automount,iocharset=utf8,rw,_netdev,username=XYZ,credentials=/home/XYZ/.302T.txt,vers=3.0,defaults  0 0

C’est ma ligne en d’options (en gras) qui me semble un peu longue (mais elle fonctionne).
J’ai jamais été plus loin pour savoir.

Voilà
vais essayer tout cela et je reviens vous dire.

merci a+

Si la ligne te semble un peu longue, tu peux enlever les deux 0 à la fin (car ce sont les valeurs par défaut et l’option defaults.
Autre chose, mes compétences en point de montage CIFS sont un peu rouillées, mais il ne me semble pas que l’option username soit la bonne. Tu as user pour spécifier le nom de l’utilisateur lors de l’autentification (que tu peux mettre dans le fichier pointé par credential) et uid qui est utile avec nounix (ou forceuid ou un serveur SMB non-Unix) pour spécifier le propriétaire des fichiers exposés dans le point de montage, mais je ne sais pas lequel des deux tu veux dire.