Gnome control center : erreur de segmentation


#1

Bonjour,

Enfin je me décide à vous écrire car depuis le début (c’est à dire dès l’installation de Debian) je n’ai jamais pu lancer “gnome-control-center” que ce soit via le menu : l’application apparais dans la barre des taches en bas puis disparais sans qu’il n’y ais d’interface, et via la commande (même en root) j’obtiens : erreur de segmentation !

je met régulièrement mon système à jour via l’update automatique et je n’ai rien modifié de particulier sur l’installation par défaut.

Operating system Debian Linux 7
Kernel and CPU Linux 3.2.0-4-686-pae on i686
gnome-control-center : 1.3.4.3.1-2 (32bits)

Si l’un de vous à une idée ou piste à creuser je suis preneur et je vous en remercie par avance.

PS : indiquez moi toutes les commandes à faire car je ne suis pas du tout un pro de linux/debian (bien que j’arrive à me débrouiller).


#2

tu utilises une ancienne version de debian
la version actuelle est la 8
je ne sais pas si ça résoudra ton problème mais c’est a envisager si ta machine en a les capacités


#3

Arf… j’avais pas vu que la version 8 est sortie !

mais bon, le PC sous Debian me sert principalement de passerelle/firewall pour l’ADSL et se trouve dans le garage donc je ne l’utilise directement très souvent.

En fait, je souhaite régler le PB du control center uniquement pour voir si je peux paramétrer différemment le PC et notamment la mise en veille des disques.
Donc soit le pb est connu et il y a une solution simple, soit je verrais ultérieurement pour changer de système (pas évident de trouver un créneau pour arrêter l’ADSL de la maison, j’ai rapidement des utilisateurs qui râlent :wink: )

En tous cas merci pour la réponse Très rapide 8)


#4

Ajouter un paramètre aide-t-il ?

Par exemple, est-ce que [mono]$ gnome-control-center printers[/mono] affiche les paramètres d’impression ?


#5

Non :frowning:

[quote]# gnome-control-center printers
Erreur de segmentation[/quote]


#6

En théorie, il est plus verbeux avec l’option -v.

Que donne [mono]$ gnome-control-center -v[/mono] ?


#7

pas mieux :confused: mais merci quand même 8)

[quote]# gnome-control-center -v
Erreur de segmentation[/quote]


#8

Le bug non résolu qui se rapproche le plus est
gnome-control-center segfaults
Il concerne une version antérieure 1:3.4.2-2 au lieu de 1:3.4.3.1-2


#9

Hum, pas rassurant si le Bug n’est pas corrigé :12


#10

Pour tenter de résoudre le problème, installer le paquet gdb-minimal et lancer

$ gdb gnome-control-center

En retour, apparaît

GNU gdb (GDB) 7.4.1-debian
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/gnome-control-center...(no debugging symbols found)...done.
(gdb)

La ligne mono[/mono] est l’invite de commande de gdb.

gdb est démarré et prêt à débugger le programme donné en paramètre, gnome-control-center.

Pour le lancer, taper [mono]run[/mono].

(gdb) run

Comme le programme dysfonctionne, il va s’arrêter. Taper alors [mono]bt[/mono] à l’invite de gdb.

(gdb) bt

Copier le résultat en réponse.


#11

voici le résultat demander :

[code]# gdb gnome-control-center
GNU gdb (GDB) 7.4.1-debian
Copyright © 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and “show warranty” for details.
This GDB was configured as “i486-linux-gnu”.
For bug reporting instructions, please see:
http://www.gnu.org/software/gdb/bugs/
Reading symbols from /usr/bin/gnome-control-center…(no debugging symbols found)…done.
(gdb) run
Starting program: /usr/bin/gnome-control-center
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib/i386-linux-gnu/i686/cmov/libthread_db.so.1”.

Program received signal SIGSEGV, Segmentation fault.
0xac866af1 in ?? () from /usr/lib/i386-linux-gnu/dri/nouveau_vieux_dri.so
(gdb) bt
#0 0xac866af1 in ?? () from /usr/lib/i386-linux-gnu/dri/nouveau_vieux_dri.so
#1 0xac868508 in ?? () from /usr/lib/i386-linux-gnu/dri/nouveau_vieux_dri.so
#2 0xac86655d in ?? () from /usr/lib/i386-linux-gnu/dri/nouveau_vieux_dri.so
#3 0xac8334ec in nouveau_pushbuf_flush ()
from /usr/lib/i386-linux-gnu/libdrm_nouveau.so.1
#4 0xac833878 in nouveau_grobj_free ()
from /usr/lib/i386-linux-gnu/libdrm_nouveau.so.1
#5 0xac8664c8 in ?? () from /usr/lib/i386-linux-gnu/dri/nouveau_vieux_dri.so
#6 0xac861818 in ?? () from /usr/lib/i386-linux-gnu/dri/nouveau_vieux_dri.so
#7 0xac85df0a in ?? () from /usr/lib/i386-linux-gnu/dri/nouveau_vieux_dri.so
#8 0xaed3d3ca in ?? () from /usr/lib/i386-linux-gnu/libGL.so.1
#9 0xaed143c8 in glXDestroyContext () from /usr/lib/i386-linux-gnu/libGL.so.1
#10 0xacd541ec in ?? () from /usr/lib/i386-linux-gnu/libcogl.so.9
#11 0xacd0cd5c in ?? () from /usr/lib/i386-linux-gnu/libcogl.so.9
#12 0xacd0e36b in ?? () from /usr/lib/i386-linux-gnu/libcogl.so.9
#13 0xacd0e2cf in cogl_object_unref ()
from /usr/lib/i386-linux-gnu/libcogl.so.9
#14 0xacd0c72a in cogl_renderer_check_onscreen_template ()
from /usr/lib/i386-linux-gnu/libcogl.so.9
#15 0xacdacb94 in ?? () from /usr/lib/i386-linux-gnu/libclutter-1.0.so.0
#16 0xacde28cc in ?? () from /usr/lib/i386-linux-gnu/libclutter-1.0.so.0
—Type to continue, or q to quit—
#17 0xacde2f17 in ?? () from /usr/lib/i386-linux-gnu/libclutter-1.0.so.0
#18 0xacdfc501 in ?? () from /usr/lib/i386-linux-gnu/libclutter-1.0.so.0
#19 0xace08f6d in ?? () from /usr/lib/i386-linux-gnu/libclutter-1.0.so.0
#20 0xace091bd in ?? () from /usr/lib/i386-linux-gnu/libclutter-1.0.so.0
#21 0xb769133a in g_option_context_parse ()
from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0xace0953e in clutter_init ()
from /usr/lib/i386-linux-gnu/libclutter-1.0.so.0
#23 0xacc4ae92 in gtk_clutter_init ()
from /usr/lib/i386-linux-gnu/libclutter-gtk-1.0.so.0
#24 0xaced3ef3 in cheese_gtk_init ()
from /usr/lib/i386-linux-gnu/libcheese-gtk.so.21
#25 0xacf0dde4 in g_io_module_load ()
from /usr/lib/control-center-1/panels/libuser-accounts.so
#26 0xb77e17ce in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#27 0xb776d686 in g_type_module_use ()
from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#28 0xb77e1c69 in g_io_modules_load_all_in_directory_with_scope ()
from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#29 0xb77e1d23 in g_io_modules_load_all_in_directory ()
from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
—Type to continue, or q to quit—
#30 0x08050e92 in ?? ()
#31 0xb776a537 in g_type_create_instance ()
from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#32 0xb774cd11 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#33 0xb774ea39 in g_object_newv ()
from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#34 0xb774efd8 in g_object_new ()
from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#35 0x08051748 in gnome_control_center_new ()
#36 0x0804ee79 in main ()
(gdb) [/code]

j’espère que cela va nous éclairer :geek:


#12

Ah ok. Problème connu dans debian mais non résolu malheureusement.

Réf : dri: nouveau_vieux segfaults when called from gnome-control-center

Essayer de démarrer une session gnome classique depuis le gestionnaire de connexion et lancer gnome-control-center.

Si le problème persiste, il est possible de forcer temporairement l’utilisation du pilote VESA à la place de NOUVEAU avec un fichier xorg.conf adéquat.


#13

heu, questions bêtes :

comment on fait ? il est ou le gestionnaire de connexion ?

sinon :

[quote]
Si le problème persiste, il est possible de forcer temporairement l’utilisation du pilote VESA à la place de NOUVEAU avec un fichier xorg.conf adéquat.[/quote]

Pareil, comment faut procéder ?

PS : désolé, je suis pas très doué sur ce système :confused:


#14

tu indiques que tu as une barre des tâches en bas , c’est donc que tu es déjà en gnome-classique


#15

Ah oui, j’ai mal lu. :confused:

Avant de passer à VESA, essayer FBDEV.
En tant que root, créer le fichier [mono]/usr/share/X11/xorg.conf.d/99-fbdev.conf[/mono] contenant :

Section "Device"
	Identifier  "Card0"
	Driver      "fbdev"
EndSection

Pour que ça prenne effet, fermer la session en cours.


#16

j’ai essayé ça :

[quote]En tant que root, créer le fichier /usr/share/X11/xorg.conf.d/99-fbdev.conf contenant :
Code:
Section "Device"
Identifier "Card0"
Driver "fbdev"
EndSection

Pour que ça prenne effet, fermer la session en cours.
[/quote]

Résultat Bureau planté (écran complètement figé), j’ai heureusement trouvé une solution pour renommer le fichier est j’ai rebooté :083


#17

Décidément… Pas sûr que VESA aide davantage alors essayer de désactiver l’accélération vidéo pour voir.

Sur le même principe, créer un fichier [mono]/usr/share/X11/xorg.conf.d/99-noaccel.conf[/mono] contenant :

Section "Device" Identifier "Card0" Option "NoAccel" "True" Driver "nouveau" EndSection


#18

Yesss :smiley:

Un grand Merci : le noaccel ça marche :041

j’ai enfin pu voir le GUI du Control center :dance:

bon bien sur c’est devenu un peu mou, mais pour ce que j’en fait ça me va très bien.

Merci encore et à bientôt 8)