Gros problème installation SID


#1

Bonjour à tous, j’ai réinstallé ma debian SID et horreur, j’ai un énorme problème de dépendances lorsque j’upgrade de stable vers sid…
En fait, je veux installer un kernel 2.6.16-1-686 et pour ce faire il veut mettre à jour udv aussi… Et là c’est le drame… Les deux paquets semblent dépendre l’un de l’autre, ce qui fait que sans linux-image-2.6.16-1-686 pas de udev et inversement…
Est-ce que quelqu’un aurait une idée pour sortir de ce cercle vicieux??? Je précise que j’ai essayé sans aucun succès de forcer les install…

Merci d’avance :smiley:


#2

as tu essayé de transiter par un 2.6.15 pour qu’udev s’installe, et ensuite de passer en 2.6.16 ?
(PS: si ça ne passe pas, donnes PRECISEMENT le message d’erreur de l’upgrade, car ton explication n’est pas trés claire pour moi)


#3

Le même problème se rencontre quand on veut passer de sarge à etch …

Pour que le noyau se mette à jour le noyau 2.6.8 --> 2.6.15 (ou plus je suppose) le système veut mettre à jour udev, ce qui ne peut se faire qu’avec un noyau 2.6.12 (ou +) en fonctionnement …
De mon point de vue, je ne vois que 3 solutions :

  • partir d’une stable avec noyau 2.6.12 , mais il faut avoir fait une netinstall avec un cd adapté dès le départ …

  • Commencer par désinstaller udev, faire son apt-get dist-upgrade, redémarrer pour avoir le nouveau noyau. Il est probable que le serveur X ne fonctionne pas car udev ne détecte pas le moniteur (et pour cause !). Donc: apt-get install udev et redémarrer pour que udev détecte le matériel au départ. Il risque peut-être d’y avoir autre chose à paramétrer, style xorg, le pilote graphique …

  • installer un noyau que l’on compile soi-même : il y a un tuto ici

J’ai testé la deuxième méthode sur une etch (noyau 2.6.15) et elle a fonctionné.

Bon courage


#4

Synaptic :
recharger = update
lnux-image-2.6.16-1-686
appliquer. = upgrade ou dist-upgrade selon la config.
C’est tout.
Sauf si, comme moi, tu as une NVIDIA à configurer en plus :cry: mais on y arrive.


#5

Bonjour!
Bon j’ai pris mon courage a deux mains pour compiler un 2.6.16 et ca y est ca fonctionne!!
Pas évident quand même cette histoire…
Par contre (ça n’a rien a voir…) je n’arrive pas à remettre les drivers nvidia :frowning:
la compilation du driver se fait bien mais x ne se lance que si load “glx” est desactivé et si j utilise le driver nv… Cela doit etre du aux mises a jour de xorg…


#6

envoie ici ton xorg.conf
ds driver il faut “nvidia” et non “nv”


#7

pour nvidia, il ne faut pas oublier d’installer nvidia-glx en même temps qu’on compile ou qu’on installe le module nvidia, ce qui permet l’option “glx”.
Par contre, avec le pilote nv, tu dois pouvoir activer “glcore”, et ca doit te donner l’opengl, je crois.


#8

je ne suis pas chez moi… je ne peux donc pas envoyer mon xorg.conf.
Ceci dit, il fonctionnait parfaitement avant que je reinstalle (je l ai copié puis remis…). A priori le problème ne vient pas de là.

En fait je voulais dire que avec glx activé et nvidia comme driver le serveur x ne parvient pas à démarrer. C’est pourquoi si je veux une interface graphique je dois commenter glx et remplacer nvidia par nv…
J’espere que je suis un peu plus clair désolé.

Euh sinon c’est quoi cette histoire de nvidia-glx?? Je fais ca via le NVIDIA-8756.sh (ce n est pas le nom exact mais ca y ressemble) que je télécharge depuis le site nvidia. Avant je n avais rien d autre à télécharger…

Est-ce que ce ne serait pas à cause de xorg 7.0??? Mais je vais essayer “glcore” avec le driver nv…

Merci à tous de répondre si vite!


#9

ah désolé, nvidia-glx, c’est quand on installe le module proprement.
Je n’utilises jamais les outils du site nvidia.


#10

Oui, fais une recherche ds les derniers 10 jours, j’ai eu ce problème et tu dois retrouver un topic qui explique comment faire.
Sino, on en reparle ce soir.


#11

Effectivment j’ai trouvé le topic… J’essaierais ca dès que je rentre @ home! (dans 2 jours lol)

Merci à tous


#12

Bonjour! Bon j’ai essayé une install “propre” en ajoutant non-free a mon sources.list et voila le message :

debian:/home/francois# apt-get install nvidia-glx
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.

Puisque vous n’avez demandé qu’une seule opération, le paquet n’est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
nvidia-glx: Dépend: nvidia-kernel-1.0.8756 mais il n’est pas installable
E: Paquets défectueux

A priori je vais devoir attendre un peu… :stuck_out_tongue:


#13

Chez moi, il a été généré après une compil du kernel 2.6.16 mais je ne le trouve pas à l’état pur.


#14

je crois soudain me souvenir que le problême est circulaire: la compil du nvidia-kernel nécessite nvidia-glx, et c’est la version de nvidia-glx qui détermine la version du paquet nvidia-kernel produit. Comme nvidia-glx necessite nvidia-kernel pour s’installer, tu te retrouves marron, sauf si tu avais installé les sources avant que le problême n’apparaisse…
Bon, je vais aller regarder dans le BTS (=bug tracking sysstem) voir sur la page bugs.debian.org/nvidia-glx


#15

bon, j’ai trouvé ça bugs.debian.org/cgi-bin/bugreport.cgi?bug=362768 ou un mainteneur du paquet dit [quote]Hi,
the need to update the prebuilt nvidia modules is already reported on
#362424.
nvidia-glx isn’t uninstallable, you just need to build the module yourself.

[/quote]
Donc il semblerait que la compil ne dépende pas de la presence de nvidia-glx, et qu’il faille commencer par compiler le paquet nvidia, puis ensuite l’installer, ce qui à priori devrait pouvoir se faire.


#16

Bonjur à tous! mon problème est résolu suite à la mise à jour d’ajourd’hui, avec xserver-xorg 7.0.16 le driver s’est parfaitement installé. Merci à tous a + :smiley: