Htaccess sur le port 9090


#1

Bonjour,

Je dois placer un fichier htaccess sur un VHost. Jusque la rien de bien difficile. Le truc c’est que ce Vhost écoute sur le port 9900et qu’il refuse de prendre en compte mon htacess.
Lorsque je passe le Vhost en écoute sur le port 80, le htacces est bien pris en compte et demande l’authentification, mais lorsque je le passe sur le port 9900, la page s’affiche sans authentification. Je ne parviens pas à comprendre pourquoi.

Voici le Vhost en question:

<VirtualHost *:9900>

  Define servername serveurexemple.com
  Define project-path /var/web/bcm_graylog
  Define htpasswd .htpasswd_graylog

  ServerName     ${servername}

  DocumentRoot    ${project-path}
  DirectoryIndex index.html

  ProxyPass / http://127.0.0.1:12201
  ProxyPassReverse / http://127.0.0.1:12201

  <Directory "${project-path}">
    Options +Indexes +FollowSymLinks +MultiViews
    AuthType Basic
    AuthName "identification"
    AuthUserFile /etc/conf/vhost_conf/htpasswd/.htpasswd
    <IfModule !mod_authz_core.c>
      Deny from all
      Require valid-user
      Satisfy Any
    </IfModule>
    <IfModule mod_authz_core.c>
      Require all denied
      Require valid-user
    </IfModule>
  </Directory>

</VirtualHost>

#2

J’ai pas d’idée, mais c’est normal que dans ton vhost tu parles de 9900, et partout ailleurs de 9090 ?


#3

Bien vu! Il s’agissait bien du port 9900, j’ai donc modifié en conséquence.
Merci


#4

Pourquoi ce renommage ? Sécurité ?
Tu as essayé en le laissant standard, à tous hasard ?

Pourquoi hors de l’arborescence DocumentRoot ?
Idem à tester: mettre le htpasswd dans ${project-path}

Ce sont des tests qui me viennent à l’esprit en voyant les particularités de config de ton vhost:
c’est pour tâtonner et si ça marche, il sera temps de comprendre pourquoi.

Je ne sais pas trop par ailleurs si ta config ProxyPass/ProxyPassReverse peut être désactivée, mais ça mérite d’être testé pour voir le comportement sans le proxy (c’est un nginx en cache ?).