Impossible à installer Debian (surtout Grub)

Tags: #<Tag:0x00007fedd849ac00> #<Tag:0x00007fedd849ab38> #<Tag:0x00007fedd849aa48>

Bonjour à tous,
J’ai trouvé un ordinateur qui était utilisé comme serveur à la base avec un Windows server 2012.
J’ai décidé d’y installer Debian pour créer un serveur apache. Donc j’installe debian avec une clé usb. Je décide de l’installer sur tout le disque entier (donc formate windows server 2012).
Sauf qu’au moment d’installer grub, ça me met ‹ erreur fatale ›.
Donc impossible de boot sur debian.

Là ça fait 2 jours que j’essaie de l’installer… J’ai un peu modifié tout dans le bios (legacy mode, ahcpi, etc…) en espérant que ça marche, mais non…
Et vu que j’ai plus windows server, bah je ne peux plus y accéder pour essayer de voir de là bas si quelque chose ne va pas .

Voilà, comment dois-je m’y prendre ? (ps: je suis débutant, je pense que vous l’avez déjà compris xd)

Avec quelle image ISO (nom complet) ? Clé USB préparée comment (procédure complète, commande exacte…) ?

Si image ISO « live », avec quel installateur ? Celui lancé depuis le menu de boot de la clé ou depuis le bureau de la session live ?

1 J'aime

Merci pour ta réponse.
J’ai essayé ces ISO : firmware-11.3.0-amd64-netinst, debian-11.3.0-amd64-DVD-1, debian-11.3.0-amd64-netinst.
La clé de 16 Go, je l’ai préparé avec Rufus avec le format MBR lors des premiers essais, puis GPT. Pour voir si ça change, mais non.
Installateur ? C’est l’installateur classique avec le « graphical install » au début.

Images d’installation donc installateur classique.
Amorçage de la clé en mode BIOS ou UEFI ? Cela affecte l’installation de GRUB.
Comment savoir ?

  • UEFI : avec GRUB, c’est marqué dans l’écran du menu de démarrage.
  • BIOS : avec ISOLinux, ce n’est affiché que brièvement avant l’écran du menu de démarrage. Des écrans d’aide sont disponibles avec les touches F1, F2

En mode UEFI, il faut une partition système EFI. Le partitionnement assisté utilisant un disque entier la crée automatiquement. Par contre il peut y avoir une erreurs lors de l’enregistrement dans les variables de boot EFI avec certains firmwares UEFI.

En mode BIOS, si on utilise le partitionnement GPT il est préférable voire obligatoire d’avoir une partition d’amorçage BIOS (« BIOS boot » ou « bios_grub »).

Dans tous les cas, après une erreur on peut basculer dans la console tty4 avec Ctrl+Alt+F4 pour afficher les derniers messages qui devraient fournir une indication sur la cause de l’échec. Pour voir les messages plus anciens, on peut aller dans la console tty2 (Alt+F2) et avoir accès à un interpréteur de commande (ou « shell »). Par exemple pour afficher les 100 dernières lignes de logs page par page :

tail -n 100 /var/log/syslog | more

espace pour afficher la page suivante, entrée pour afficher la ligne suivante, q pour revenir à l’invite de commande.
Pour revenir à l’installateur graphique (tty5) : Alt+F5

Avez-vous essayé de booter sur une session-live de boot-repair (boot-repair-disk-64bit.iso) ?
Ceci permet de réparer l’accès au démarrage de votre session Debian (accès internet souhaité).
Bon courage.

Ou d’empirer la situation. Et dans tous les cas, on n’a rien appris donc le problème se reproduira.

OK, j’ai moi-même réussi à retrouver l’accès au démarrage dans tous les cas où il avait disparu, mais je suis amateur d’une explication si c’est abordable à mon niveau de connaissance de Linux.