Impossible de compiler Alsa!


#1

Lorsque j’essaye de compiler Alsa, 0.9.6, 0.9.7 ou 0.9.7a il me met une erreur au cours du Make (configuré pour une audigy, c’est à dire pour emu10k1):
In file included from memalloc.c:27:
/usr/src/linux/include/linux/proc_fs.h:213: error: redefinition of PDE' /usr/src/alsa-driver-0.9.7a/include/adriver.h:133: error:PDE’ previously defined here
make[1]: *** [memalloc.o] Erreur 1
make[1]: Leaving directory `/usr/src/alsa-driver-0.9.7a/acore’
make: *** [compile] Erreur 1

Pourtant je les avait déjà compilés avant mais là impossible.
Est-ce que quelqu’un connait ce problème? Une solution pour m’aider, parce que sans le son, c’est pas cool.


#2

as tu precisé au moment du ./configure le type de carte que tu utilises ? un truc du genre ./configure --with-cards=audigy …


#3

Oui oui, j’ai fait un ./configure --with-cards=emu10k1 --with-sequencer=yes. Mais ensuite quand je fait make j’ai l’erreur ci-dessus.
Mais je pense que ça vient du noyau (2.4.23-pre6). Ca marchait avec le 2.4.23-pre4.