Impossible de démarrer Xorg sur Debian

Tags: #<Tag:0x00007fc5f731de08> #<Tag:0x00007fc5f731dd40>

Bonjour à tous,

Je viens d’installer debian 10.0.0 stable sur mon PC (avec plasma comme seul environnement de bureau).

Or, quand l’ordinateur démarre, au moment de charger le graphique il fait écran noir.

Donc, j’accède à une console en faisant Alt + F1.

Je me connecte, et, à force de faire des tests (startx, sudo systemctl start sddm,…) je me suis rendu compte que xorg se lançait puis restait bloqué, je m’explique :

startx

tout se lance comme prévu : il affiche des messages normaux pour le démarrage sans signaler d’erreurs puis reste bloqué comme ça…

J’ai donc essayé de voir si les pilotes sont installés et… ils le sont ! J’ai essayé de le reconfigurer (sudo dpkg-reconfigure xorg.…).

J’ai aussi essayé de le reconfigurer avec “sudo X -configure” puis en essayant la nouvelle configuration… Mais rien n’y fait.

Ma carte graphique est Intel HD Graphics, je ne connaît pas le numéro de série, j’ai 4Go de RAM et un processeur Intel Celeron 4 coeurs (c’est un minipc…). Lors de l’installation, le pad ne fonctionnait pas. Enfin mon écran est tactile. J’ai beau chercher, je ne trouve rien sur internet…

Voilà tout ce que je peux dire pour vous aider.

Merci d’avance de votre aide,

Cordialement, timfa21.

Des extraits de logs (/var/log/xorg* ou dans le répertoire utilisateur pour startx) seraient bienvenus.

Je cite la fin du fichier /var/log/Xorg.0.log :

event3 - Power Button: device removed
event4 - Video Bus: device removed
event2 - Power Button: device removed
event7 - TOSHIBA Web Camera - HD: TOSHIB: device removed
event6 - ELAN Touchscreen: device removed
event0 - AT Translated Set 2 keyboard: device removed
event5 - SynPS/2 Synaptics TouchPad: device removed

La fin du fichier $HOME/.xsession-errors indique 6 fois la même phrase à la suite après plein de phrases qui semblent indiquer que tout fonctionne… :
The X11 connection broke (error 1). Did the X11 server die ?

Ben ça aurait été mieux d’avoir les messages d’erreur (lignes avec “(EE)”) ou éventuellement les warning “(W)” que tu trouves significatifs (qui ne parlent pas de la souris ou de trucs accessoires), ou bien que tu repères ce qu’il dit sur ce qu’il a détecté comme carte graphique pour voir si ça colle avec ce que tu as, parce que là, c’est pas super pertinent comme lignes choisies pour le diagnostic.

Idem, dans la sortie de dmesg (en root), si tu as des couleurs, regarde s’il y a des choses en rouges intéressantes, sinon si tu n’as pas de couleur, épluches la sortie de dmesg pour y repérer les erreurs.

Autres éléments utiles pour nous, le résultat de lspci -k | grep VGA -A 3 pour mieux connaître ta carte graphique, et savoir par quel module noyau elle est actuellement gérée.

Avant, essayes à tous hasard d’installer intel-microcode (c’est normalement pour le CPU donc au pire, ça améliorera le fonctionnement de ton celeron et sait on jamais, ça peut concerner ta carte).

Que donne cette séquence ? :
alt-F1alt-F2alt-F1

Le fichier “/var/log/Xorg.0.log” ne contient aucun message d’erreur… Mais 5 Warning… Les voici :

[     244.187]  (WW)  The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[     244.187]  (WW)  The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[     244.187]  (WW)  Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmouse' will be disabled.
[     244.188]  (WW)  Disabling Mouse0
[     244.188]  (WW)  Disabling Keyboard0

sudo dmesg | grep error” et “sudo dmesg | grep warning” ne donnent aucun résultat…
après avoir épluché ce que donne “sudo dmesg”, je n’ai rien trouvé d’intéressant…

lspci -k |grep VGA -A 3” donne des résultats qui correspondent à mon matériel…

J’ai installé “intel-microcode” et redémarré, sans résultat…

Cette séquence me connecte sur tty1 puis tty2 puis tty1

Je ne sais plus quoi penser… Faut-il mettre à niveau vers Debian testing ? Utiliser une autre distribution ? Quoi qu’il en soit, merci de votre aide à tout les deux !

Ben on peut voir aussi exactement toute la sortie ?

As tu essayé de killer ton serveur avec ctrl+alt+backspace pour voir la fin des messages du startx en console ?
Est ce que tu peux repasser en console avec ctrl+alt+FX, à ce moment là ?

Ben là en fait, ton serveur x a l’air de bien se lancer, vu l’absence de messages, d’où mes dernières questions pour confirmer.
Il y a peut être un réglage à faire dessus simplement pour qu’il ne te présente pas un écran noir, déjà.
Et sinon, sans changer de distrib, déjà changer de noyau peut mériter un test.

Je posais cette question car il m’est arrivé d’avoir un blocage que cette séquence réglait. En fait j’ai mis à jour le firmware avec des paquets non-free et tout est rentré dans l’ordre. Ceci dit mon problème était peut-être plutôt lié a gdm3 qu’au serveur lui-même, à la réflexion. Mes connaissances sont très modestes sur le sujet.

La sortie donne :

00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev21)
                Subsystem: Toshiba America Info Systems Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
                 Kernel drive in use: i915
                 Kernel modules: i915

Je peux le killer de cette façon en effet (soit avec Ctrl + C soit avec Ctrl + Alt + Barre Espace (et non Backspace…)) mais seulement si après je passe en mode console et retourne au tty du serveur X. Sinon il ne répond pas… Si je le kill de cette façon j’accède à des messages d’erreurs (messages qui sont décalés les uns par-rapport aux autres, non reproduit ici) :

xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) modeset (0): Initializing kms color map for depth 24, 8bpc.
(II) AIGLX: Suspending AIGLX clients for VTswitch
(EE)
Fatal server error: 
(EE) EnterVT failed for screen 0
(EE)
(EE)
Please consult the X.org Foundation Support at http://wiki.x.org for help.
(EE) Please also check the log file at "HOME$/.local/share/xorg/Xorg.0.log" for additionnal information.
(EE)
(II) AIGLX: Suspending AIGLX clients for VT switch
(EE) Server terminated with error (1). Closing log file.
xinit: connection to X server lost

Je peux aussi le killer en passant en mode console et retournant au tty du serveur X… Par contre, si je le kill de cette façon, il marque juste :

xinit: connection to X server lost

waiting for X server to shut down

Voici les lignes d’erreurs et de warning du fichier HOME$/.local/share/xorg/Xorg.0.log :

(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) Falling back to old probe method for fbdev
(WW) VGA arbiter: cannot open kernel arbiter, no multi-card support

ET

(EE) modeset(0): failed to set mode: Invalid argument
(EE) modeset(0): failed to set mode: Invalid argument
(EE)
(EE) EnterVT failed for screen 0
(EE)
(EE)
(EE) Please also check the log file at "HOME$/.local/share/xorg/Xorg.0.log" for additionnal information.
(EE)
(EE) Server terminated with error (1). Closing log file.

Je ne sais pas comment faire pour changer de noyau ni même ceux qui existent…
Lors de l’installation en mode expert (pour mieux tout choisir…) j’ai pris le noyau normal où “4.19.X” n’était pas écrit dessus…
J’ai aussi choisi une image générique des pilotes pour le démarrage comme ça, si je change de composant, je suis tranquille…

Ah ! OK, je ne comprenais pas bien ta question au début, en effet…
Tu as mis à jour quel Firmware au juste (celui de la carte graphique certainement…) ? Tu sais peut-être qu’il en existe plusieurs :
Pour le CPU, la carte Wi-Fi, la carte Graphique…

Bon, ben je m’étais trompé, le serveur ne démarre pas, on a des erreurs, finalement.
Et plein d’infos, dont une intéressante:

On sait quel module noyau est sensé se monter avec ta carte.
Je vois qu’il y a des firmwares i915 dans le paquet firmware-misc-nonfree , ça mériterait d’être installé, même si c’est non libre.

mj@mercure:/var/log$ aptitude show firmware-misc-nonfree | grep i915
 * Intel "Broxton" DMC firmware, version 1.07 (i915/bxt_dmc_ver1_07.bin, i915/bxt_dmc_ver1.bin) 
 * Intel "Broxton" GuC firmware, version 8.7 (i915/bxt_guc_ver8_7.bin) 
 * Intel "Broxton" GuC firmware, version 9.29 (i915/bxt_guc_ver9_29.bin) 
 * Intel "Broxton" HuC firmware, version 1.07.1398 (i915/bxt_huc_ver01_07_1398.bin) 
 * Intel "Cannonlake" DMC firmware, version 1.07 (i915/cnl_dmc_ver1_07.bin) 
 * Intel "Geminilake" DMC firmware, version 1.04 (i915/glk_dmc_ver1_04.bin) 
 * Intel "Kabylake" DMC firmware, version 1.01 (i915/kbl_dmc_ver1_01.bin, i915/kbl_dmc_ver1.bin) 
 * Intel "Kabylake" DMC firmware, version 1.04 (i915/kbl_dmc_ver1_04.bin) 
 * Intel "Kabylake" GuC firmware, version 9.14 (i915/kbl_guc_ver9_14.bin) 
 * Intel "Kabylake" GuC firmware, version 9.39 (i915/kbl_guc_ver9_39.bin) 
 * Intel "Kabylake" HuC firmware, version 2.0.1810 (i915/kbl_huc_ver02_00_1810.bin) 
 * Intel "Skylake" DMC firmware, version 1.23 (i915/skl_dmc_ver1_23.bin) 
 * Intel "Skylake" DMC firmware, version 1.26 (i915/skl_dmc_ver1_26.bin, i915/skl_dmc_ver1.bin) 
 * Intel "Skylake" DMC firmware, version 1.27 (i915/skl_dmc_ver1_27.bin) 
 * Intel "Skylake" GuC firmware, version 1.1059 (i915/skl_guc_ver1.bin) 
 * Intel "Skylake" GuC firmware, version 4.3 (i915/skl_guc_ver4.bin) 
 * Intel "Skylake" GuC firmware, version 6.1 (i915/skl_guc_ver6_1.bin, i915/skl_guc_ver6.bin) 
 * Intel "Skylake" GuC firmware, version 9.33 (i915/skl_guc_ver9_33.bin) 
 * Intel "Skylake" HuC firmware, version 1.07.1398 (i915/skl_huc_ver01_07_1398.bin) 

Si cette install ne suffit pas, que donne lsmod | grep i915 ?
Et sudo grep i915 /var/log/kern.log (ou peut être le syslog, mais je crois que le kern.log est mieux).

Trés simple: tu regardes ceux qui sont disponibles:
aptitude search linux-image
Et tu choisis le noyau que tu veux ajouter, tu l’installes.

Après, grub te présentera plusieurs choix, et bootera par défaut si tu ne choisis pas avec le noyau de plus haut numéro d’ordre (sauf réglage différent de grub).

Après avoir installé le paquet firmware-misc-nonfree et avoir redémarré, ce sont les mêmes erreurs qui s’affichent :cry:

lsmod | grep i915 affiche :

i915                 1728512  2
i2c_algo_bit           16384  1 i915
drm_kms_helper        200704  1 i915
drm                   483328  3 drm_kms_helper,i915
video                  45056  2 toshiba_acpi,i915

Les fichiers kern.log et syslog dans le répertoire /var/log/ donnent exactement les mêmes résultats ! :

Aug 26 11:24:53 faurem kernel: [    3.384007] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 26 11:24:53 faurem kernel: [    3.610840] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 26 11:24:53 faurem kernel: [    4.896806] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 26 11:24:53 faurem kernel: [   16.009605] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 26 11:42:33 faurem kernel: [    3.439136] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 26 11:42:33 faurem kernel: [    3.662720] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 26 11:42:33 faurem kernel: [    4.998635] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 26 11:42:33 faurem kernel: [   16.478152] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 26 11:45:53 faurem kernel: [    3.413424] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 26 11:45:53 faurem kernel: [    3.634859] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 26 11:45:53 faurem kernel: [    4.937338] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 26 11:45:53 faurem kernel: [   15.707193] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 26 11:50:09 faurem kernel: [    3.445040] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 26 11:50:09 faurem kernel: [    3.666653] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 26 11:50:09 faurem kernel: [    4.972849] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 26 11:50:09 faurem kernel: [   15.111870] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 28 16:19:23 faurem kernel: [    3.363169] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 28 16:19:23 faurem kernel: [    3.576843] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 28 16:19:23 faurem kernel: [    4.864507] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 28 16:19:23 faurem kernel: [   15.521354] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 29 10:52:25 faurem kernel: [    3.289666] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 29 10:52:25 faurem kernel: [    3.511869] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 29 10:52:25 faurem kernel: [    4.802647] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 29 10:52:25 faurem kernel: [   15.449661] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 29 11:02:50 faurem kernel: [    3.515687] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 29 11:02:50 faurem kernel: [    3.744316] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 29 11:02:50 faurem kernel: [    5.037609] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 29 11:02:50 faurem kernel: [   15.396380] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 29 15:30:38 faurem kernel: [    3.384807] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 29 15:30:38 faurem kernel: [    3.608481] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 29 15:30:38 faurem kernel: [    4.904029] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 29 15:30:38 faurem kernel: [   16.183674] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 29 19:19:53 faurem kernel: [    3.371456] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 29 19:19:53 faurem kernel: [    3.598308] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 29 19:19:53 faurem kernel: [    4.905360] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 29 19:19:53 faurem kernel: [   16.191657] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 29 19:22:35 faurem kernel: [    3.494042] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 29 19:22:35 faurem kernel: [    3.709733] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 29 19:22:35 faurem kernel: [    5.006484] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 29 19:22:35 faurem kernel: [   15.812367] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Aug 30 09:58:22 faurem kernel: [    3.494665] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
Aug 30 09:58:22 faurem kernel: [    3.710708] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
Aug 30 09:58:22 faurem kernel: [    4.990096] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Aug 30 09:58:22 faurem kernel: [   15.802862] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

Quel noyau prendre ? Je n’ai que l’embarras du choix…:face_with_raised_eyebrow:

OK, le module se charge bien.
Je suis en train d’éplucher les résultats sur “linux i915 black screen”, j’ai pas fini, mais le moins qu’on puisse dire, c’est que le “i915 black screen” est un probléme récurrent.
Il y a déjà une bonne liste de trucs à tester (mais on va attendre le résultat du changement de noyau):
https://florian-berger.de/en/articles/i915-black-screen-on-boot-issue/

Ben nous on a pas cet embarras, vu qu’on n’a pas la liste de ce que tu peux installer.

Excuse moi… Je n’y avais pas pensé…
La voici :

i A linux-image-4.19.0-5-amd64 - Linux 4.19 for 64-bit PCs (signed)
p  linux-image-4.19.0-5-amd64-dbg - Debug symbols for linux-image-4.19.0-5-amd64
p  linux-image-4.19.0-5-amd64-unsigned - Linux 4.19 for 64-bit PCs
p  linux-image-4.19.0-5-cloud-amd64 - Linux 4.19 for x86-64 cloud (signed)
p  linux-image-4.19.0-5-cloud-amd64-dbg - Debug symbols for linux-image-4.19.0-5-cloud-amd64
p  linux-image-4.19.0-5-cloud-amd64-unsigned - Linux 4.19 for x86-64 cloud
p  linux-image-4.19.0-5-rt-amd64 - Linux 4.19 for 64-bit PCs, PREEMPT_RT (signed)
p  linux-image-4.19.0-5-rt-amd64-dbg - Debug symbols for linux-image-4.19.0-5-rt-amd64
p  linux-image-4.19.0-5-rt-amd64-unsigned - Linux 4.19 for 64-bit PCs, PREEMPT_RT
i  linux-image-amd64 - Linux for 64-bit PCs (meta-package)
p  linux-image-amd64-dbg - Debugging symbols for Linux amd64 configuration (meta-package)
p  linux-image-amd64-signed-template - Template for signed linux-image packages for amd64
p  linux-image-cloud-amd64 - Linux for x86-64 cloud (meta-package)
p  linux-image-cloud-amd64-dbg - Debugging symbols for Linux cloud-amd64 configuration (meta-package)
p  linux-image-rt-amd64 - Linux for 64-bit PCs (meta-package), PREEMPT_RT
p  linux-image-rt-amd64-dbg - Debugging symbols for Linux rt-amd64 configuration (meta-package)

J’essaye avec linux-image-rt-amd64 ? Il me semble bien.

Non, ça, c’est une version préhemptive du noyau, ça améliore la réactivité visuelle du systéme, et c’est adapté aux tâches temps réel comme la musique ou la vidéo, mais ça a des défauts pour sa stabilité et la tenue en charge des services.
Bref, en fait, c’est la même version de noyau, tu peux toujours l’essayer pour voir, mais je doute que ça change grand chose, il faudrait un autre “numéro” de noyau.

Tu peux essayer un plus vieux noyau en ajoutant des sources.list stretch d’avant (mais ça ne marchait pas avant sur noyau stretch, il me semble), ou au contraire installer les sources sid

Mais faut résoudre le probléme autrement: est ce que tu sais ce que veut dire passer l’argument acpi=off au noyau, dans grub ? Si oui, essaye.

As tu creé le fichier nécessaire?
j’ai le même soucis et c’est résolu comme ceci.

/etc/X11/xorg.conf.d/20-intel.conf

Section "OutputClass"
  Identifier "Intel Graphics"
  MatchDriver "i915"
  Driver "intel"
  Option "TearFree" "true"
EndSection
2 J'aime

J’ai fait ce que tu m’as dit de faire… Et ça marche !!! Pas besoin de changer de noyau ou quoi que ce soit !!! Incroyable ! Merci de tout coeur @cleloup !!!

1 J'aime