Impossible d'écrire sur le disque dur de windows depuis linux debian

stretch
Tags: #<Tag:0x00007fdf1d920a50>

#1

bonjour

j’ai debian sur un disque dur externe qui est sur un ordinateur qui est sous windows 10,
avec la commande /etc/fstab un pote ma ajouté cette ligne


/dev/sdb3       /media/duncan/Windows   ntfs    rw,gid=100,uid=1000,umask=002,exec,user,auto    0       0

pour que debian monte le disque dur de windows au demarage,
mais impossible de écrire sur le dique dur

la commande mount affiche

/dev/sdb3 on /media/duncan/Windows type fuseblk (ro,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,user)

dont le ro qui fait que je peux pas ecrire sur le disque dur

je ne sais pas ce qu’il faut changer sur la ligne pour que sa fonctionne

Merci d’avance pour votre aide


#2

Il est possible que Windows n’a pas été vraiment arrêté mais mis en hibernation (démarrage rapide) et a laissé le système de fichier dans un état impropre au montage en écriture. Tu peux vérifier avec

umount /dev/sdb3
mount /dev/sdb3

Note : c’est une mauvaise idée d’utiliser la notation /dev/sdb3 dans /etc/fstab. Les noms de périphériques des disques /dev/sd* peuvent varier à chaque démarrage. Il vaut mieux utiliser UUID= ou LABEL= avec la valeur affichée par blkid /dev/sdb3.


#3

umount /dev/sdb3 donne

umount: /media/duncan/Windows : échec de démontage: Opération non permise

mount /dev/sdb3 donne

Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the ‘fuser’ command.

avant de passer sur linux j’ai fait arréter, une fois eteint attendu quelque secondes puis redemarrer l’ordinateur sous linux


#4

Tu as exécuté les commandes en root ?
Au lieu d’arrêter, choisis redémarrer depuis Windows et lance Debian directement.


#5

j’ai déja fait souvent pour passer sur linux quand je sur windows de faire redemarrer au lieu de arrêter,
mais impossible de écrire quand même sur le disque dur.

ps: avec l’UUID sa ma pourri le boot j’ai du passer par un liveCD pour supprimer la ligne


#6

ses bon je ses pas se que ses qui fait que sa marche mais sa marche,

merci pour l’aide


#7

Tu peux ajouter l’option “nofail” aux montages non indispensables pour ne pas bloquer le démarrage en cas d’échec.


#8

Alors, mes notions en systèmes de fichiers Windows date un peu, mais, à une époque, il fallait installer le paquet ntfs-3g pour avoir un accès en écriture. Je ne sais pas si c’est toujours le cas, mais tu peux sans doute aller voir de ce côté.
Sinon, pour les versions ultérieures ou égales à la 8 de Windows, le bouton éteindre n’éteind pas à coup sûr le Windows. N’hésite pas à faire Windows+R, puis lancer shutdown -s -t 0 pour vraiment éteindre l’ordinateur.


#9

C’est toujours le cas pour avoir un accès en écriture “décent”. Le pilote ntfs du noyau a des capacités très limitées en écriture, en gros il ne permet que de modifier les fichiers existants. Mais la ligne affichée par mount contient “fuseblk”, ce qui indique que c’est bien le pilote ntfs-3g (qui utilise FUSE) qui a été utilisé.


#10

Perso j’utilise ça pour mes disques usb ntfs

https://doc.ubuntu-fr.org/tutoriel/ntfs#avec_ntfs-config


#11

ou il faut le mettre l’option “no fail”?


#12

“nofail” en un mot. Il faut l’ajouter dans le champ d’options de la ligne correspondante dans le fichier /etc/fstab. Pour les détails, cf.

man fstab