Impossible d'ouvrir ma session

Bonjour,

Je viens d’installer debian squeeze avec gnome sur mon ordinateur
nouvellement acquis, un Acer Aspire 5315.
L’installation s’est bien passée, j’ai donc pu installer un certain
nombre de logiciels, faire marcher le wifi etc.

Or, après le premier redémarrage, impossible de me reconnecter…
J’arrive bien sur l’écran de connexion, mais après avoir rentré mon mot de
passe il s’affiche un écran noir, puis ça revient sur ce même écran.

En cherchant sur internet j’ai trouvé quelqu’un sous ubuntu ayant le
même problème que moi : http://forum.ubuntu-fr.org/viewtopic.php?id=191380
J’ai donc suivi les indications données dans une réponse :

CTRL+ALT+F1 pour ouvrir un terminal, sur lequel je me logge en root, puis

#/etc/init.d/gdm stop #echo "exec gnome-session" > /home/moi/.xinitrc #su moi §startx

Et la session s’est ouverte.

Le problème, c’est que je dois recommencer la procédure à chaque démarrage…
Une idée de comment je peux me connecter normalement?
Merci pour vos réponses.

1 J'aime

Salut,

Sans être sûr de mon coup mais sans risque :

Vérifier que tous les fichiers /home/moi appartienne bien à “moi” ( faire cette manoeuvre avant de sortir de session.)
La commande ls -la

Le pourquoi : Certaines commandes se permettent d’attribuer à root des fichiers de ton home ! Il te resteras à trouver laquelle chez toi :slightly_smiling:

Le fichier .xinitrc était à root
J’ai fait chown moi .xinitrc
et rebooté, mais le problème subsiste

Bonjour,

[quote=“BenjaminVu”]Le problème, c’est que je dois recommencer la procédure à chaque démarrage…
Une idée de comment je peux me connecter normalement?[/quote]
Je n’ai pas compris. “Normalement” ? Via gdm?

Sinon,

$echo "exec gnome-session" > .xinitrc $startx Y’a pas de raison que ça ne marche pas.

:006

En faisant

/etc/init.d gdm stop startx
ça marche bien, mais j’aimerais pouvoir me connecter sans avoir
à ouvrir un terminal

bonjour,

[quote=“BenjaminVu”]
ça marche bien, mais j’aimerais pouvoir me connecter sans avoir
à ouvrir un terminal[/quote] Avec gdm donc.

Les erreurs dans /var/log/Xorg.log quand la session souvre sur un écran noir ???
( $cat /var/log/Xorg.log )

Voici mon /var/log/Xorg.0.log :
Xorg.O.log (21.5 KB)

Bonjour,

J’ai survolé le log.

‘xserver-xorg-video-intel’ est il installé ?

Si oui, existe-il un /etc/X11/xorg.conf
Si oui, à quoi ressemble-t-il?

Si non, en générer un:

#su - #Xorg -configure
Et le tester :

Les options des cartes intel sont trés paramétrables mais elles sont aussi capricieuses :wink:

Re,
mon xorg.conf n’existait pas, je l’ai donc créé :

[code]#Xorg -configure
#cat xorg.conf.new
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 “Screen0” 0 0
InputDevice “Mouse0” "CorePointer"
InputDevice “Keyboard0” "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "dri"
Load "extmod"
Load "record"
Load "glx"
Load "dri2"
Load "dbe"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option “Protocol” "auto"
Option “Device” "/dev/input/mice"
Option “ZAxisMapping” "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section “Device”
### Available Driver options are:-
### Values: : integer, : float, : “True”/“False”,
### : “String”, : " Hz/kHz/MHz"
### [arg]: arg optional
#Option “AccelMethod” # []
#Option “DRI” # []
#Option “ColorKey” #
#Option “VideoKey” #
#Option “FallbackDebug” # []
#Option “Tiling” # []
#Option “Shadow” # []
#Option “SwapbuffersWait” # []
#Option “XvMC” # []
#Option “XvPreferOverlay” # []
#Option “DebugFlushBatches” # []
#Option “DebugFlushCaches” # []
#Option “DebugWait” # []
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Mobile GM965/GL960 Integrated Graphics Controller"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
[/code]

Par contre, quand je fais Xorg -config xorg.conf.new, j’ai un écran noir
sur lequel rien ne s’affiche…

Salut,

Bien sur le résultat de xconf.new a été transféré en /etc/X11/xorg.conf ?

Je pensais que la commande Xorg -config xorg.conf.new suffisait…
Du coup j’ai bien copié mon fichier en /etc/X11/xorg.conf, mais ça n’a rien changé.

Au fait, voici se qui s’affiche sur le terminal après avoir fait Xorg -config xorg.conf.new :

[code]X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32.29-dsa-ia32 i686 Debian
Current Operating System: Linux benjaminvu 2.6.32-5-686 #1 SMP Tue Mar 8 21:36:00 UTC 2011 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-686 root=UUID=39fe94e2-3287-47d5-a182-7aa3a353bcaf ro quiet
Build Date: 19 February 2011 02:37:36PM
xorg-server 2:1.7.7-13 (Cyril Brulebois kibi@debian.org)
Current version of pixman: 0.16.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Tue Mar 22 22:30:10 2011
(++) Using config file: “/root/xorg.conf.new”
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
FATAL: Module fbcon not found.
SELinux: Disabled on system, not enabling in X server
The XKEYBOARD keymap compiler (xkbcomp) reports:

Warning: Type “ONE_LEVEL” has 1 levels, but has 2 symbols
Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
AlpsPS/2 ALPS GlidePoint no synaptics event device found
Query no Synaptics: 6003C8
(EE) AlpsPS/2 ALPS GlidePoint Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device “AlpsPS/2 ALPS GlidePoint”
[/code]

quote=“BenjaminVu” Log file: “/var/log/Xorg.0.log”, Time: Tue Mar 22 22:30:10 2011
(++) Using config file: “/root/xorg.conf.new”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”[/quote]
C’est pas normal ça. Le fichier a-t-il bien été copié au bon endroit ?

Ps:

#invoke-rc.d gdm start Ça renvoit quoi ?

On ne sait jamais, vérifie que les droits sur le dossier /tmp
et /var/tmp sont bien positionnés (drwxrwxrwt)
guyr

[quote]quote Log file: “/var/log/Xorg.0.log”, Time: Tue Mar 22 22:30:10 2011
(++) Using config file: “/root/xorg.conf.new
(==) Using system config directory “/usr/share/X11/xorg.conf.d”[/quote]

C’est pas normal ça. Le fichier a-t-il bien été copié au bon endroit ?[/quote]

C’est parce que j’ai fait Xorg -config /root/xorg.conf.new
Si je fais Xorg -config /etc/X11/xorg.confj’obtiens la même chose, étant donné que xorg.conf est une copie de xorg.conf.new.

Ca renvoie "Starting GNOME Display Manager: gdm3."
puis ça retourne sur l’écran de connexion gdm, avec le même
problème (écran noir quand je me connecte, puis retour sur l’écran de connexion)

@guyr : bien vérifié les dossiers tmp et var/tmp, et tout va bien chez eux

Bon si gdm s’affiche c’est que la carte graphique n’est pas en cause.
Je dois dire que je seche :think:

PS:

En tapant sur google “debian fbcon” j’atterris sur ce bug datant de … été 2010 :open_mouth:
bugs.debian.org/cgi-bin/bugreport.cgi?bug=588560

Le système est-il bien a jour ( Debian v 6.0.1 )

Bon, du coup j’ai fini par installer xdm, et ça marche sans problème…
Merci quand même pour votre aide!

Bonsoir,
La coche verte :083

salut
Dis sous quel système d’exploitation fonctionne ton pc.