Impossible d'update une raspberrypi debian

Tags: #<Tag:0x00007fd6e66e5248> #<Tag:0x00007fd6e66e5068> #<Tag:0x00007fd6e66e4ed8> #<Tag:0x00007fd6e66e4d48> #<Tag:0x00007fd6e66e4b40>

Bonjour en prenant mon image sur raspi[dot]debian[dot]net, au 1er boot, je ne peux pas update :
# apt update
Err: 1 deb[dot]debian[dot]org/debian buster InRelease
Temporary failure resolving ‹ deb[dot]debian[dot]org ›
Reading package list… Done
W: Failed to fetch deb[dot]debian[dot]org/debian/dists/buster/InRelease
E: The value ‹ buster › is invalid for APT::Default-Release as such a release is not available in the sources

J’ai essayé ceci https://stackoverflow.com/questions/61567404/docker-temporary-failure-resolving-deb-debian-org qui mène à https://www.digitalocean.com/community/questions/apt-error-temporary-failure-resolving-deb-debian-org mais :
# ls -a /etc/
ne me liste aucun fichier resolv[dot]conf

  1. Que faire svp ?

Par ailleurs, c’est accessoire pour ceux qui comptent installer un desktop j’imagine, mais je n’arrive pas à mapper mon clavier azerty, l’image utilise un clavier anglosaxon initialement.
J’ai testé :
# setxkbmap fr
-bash: setxkbmap: commant not found
# loadkeys fr
-bash: loadkeys fr: command not found
# dpkg-reconfigure keyboard-configuration
dpkg-query: package ‹ keyboard-configuration › is not installed and no information is available

  1. Vous feriez comment vous?

Cdlt

(les [dot] sont dûs à la restriction de 2 liens pour les nouveaux utilisateurs)

Bonjour,

Quelle image as-tu utilisé ? Est-ce bien celle adaptée à la version de ton Raspberry Pi (0, 1, 2, 3 ou 4) ?
Comment ton Raspberry est-il relié au réseau : en filaire ou en WiFi ?
Que donne :

ip a

Bonjour,

as-tu regardé ce tuto ?

Installer Raspbian, premier démarrage et configuration