Imprimante navigateur web


#1

Bonjour,

J’ai un problème avec mon imprimante. En effet, je ne peux pas imprimer de page web, ou autre à partir de firefox ou mozilla.
J’ai configuré cette imprimante par CUPS (modèle HP 3420 deskjet), et dans le choix des imprimantes sous firefox, j’ai le choix entre:
lp@:64
xp_ps…
xp_pdf
Postscript/hp

or aucune des “imprimantes citées” ne me permet d’imprimer. Je n’ai rien trouvé sur le net concernant ce sujet!
Je précise que mon imprimante fonctionne avec openoffice, g+xpdf
Merci


#2

normalement, si elle imprime bien la page de test avec ton outil de config, la première file (lp@:64) ou la 4eme (Postscript/lp) devraient fonctionner.


#3

Oui je suis d’accord avec toi, mais en pratique ça ne marche pas :frowning: bien que je puisse imprimer une page de test comme un doc openoffice, pdf.
Pour tout dire, je tente d’imprimer un mail à partir de mon compte gmail, donc y aurait-il une erreur à partir de là?! Mais alors le problème est vrai pour toutes les pages web…

J’ai regardé le fichier des log:

#tail /var/log/messages/
Xprt_64: AUDIT: Mon Apr 18 08:48:12 2005: 3447 Xprt: client 1 connected from local host
Xprt_64: AUDIT: Mon Apr 18 08:48:12 2005: 3447 Xprt: client 1 disconnected

Je me suis aperçu que les travaux étaient dans la queue (#lpq) mais que rien ne sortait de l’imprimante,et idem quand je passe par un fichier ps.

une idée?

Merci


#4

lpstat -s ?


#5

J’ai command not found pour lpstat!!!

c’est quoi qu’il me manque? ou bien j’ai fais une erreur lors de l’installation…

Merci


#6

woody ou sarge ? tu as quelle version de cups ? tu es à jour sur tes paquets ?


#7

Alors, j’ai une knoppix modifiée…(faîte par ma fac), c’est donc à base de sarge si je ne m’abuse :unamused:

version de cups:
Package: cupsys
Version: 1.1.20final+rc1-10

et à jour de tous mes paquets:
#apt-get update
#apt-get upgrade
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Les paquets suivants ont été conservés :
cpudyn cpufreqd gksu gnomemeeting gstreamer0.8-misc gstreamer0.8-vorbis
j2re1.4 j2sdk1.4 libmime-perl libpt-plugins-alsa libpt-plugins-v4l
libreadline4 wmaker xprt-xprintorg
0 mis à jour, 0 nouvellement installés, 0 à enlever et 14 non mis à jour

Merci


#8

alors là, c’est vite dit…

[quote=“kiki”]version de cups:
Package: cupsys
Version: 1.1.20final+rc1-10[/quote]
avec apt-cache, j’ai trouvé des paquets allant jusqu’au 1.1.23-8, mais c’est peut etre du sid.

[quote=“kiki”]
et à jour de tous mes paquets:
#apt-get update
#apt-get upgrade
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Les paquets suivants ont été conservés :
cpudyn cpufreqd gksu gnomemeeting gstreamer0.8-misc gstreamer0.8-vorbis
j2re1.4 j2sdk1.4 libmime-perl libpt-plugins-alsa libpt-plugins-v4l
libreadline4 wmaker xprt-xprintorg
0 mis à jour, 0 nouvellement installés, 0 à enlever et 14 non mis à jour
Merci[/quote]
à jour de tes paquets ? tu rigoles ? as tu remarqué qu’entre autres xprt-xprintorg restait à mettre à jour ?
Que donne apt-get dist-upgrade ?


#9

JE suis un peu boulet, j’ai oublié de donner hier soir les dernières lignes de apt-get dist-upgrade :blush:
désolé

Quoiqu’il en soit, ça ne change j’ai toujours les mêmes problèmes.Comment changer un paquet en l’occurence cups pour avoir la même version dont tu me parlais, à partir de apt. si ça peut arranger ce problème

Merci


#10

pour connaitre la liste des versions que connait ta machine:
apt-cache show cupsys

ensuite, une fois que tu as vu la version qui t’interresse:
apt-get install cupsys=