Install debian sur Asus a7n8x-E et SATA


#1

Salux,

J’ai un autre problème a vous soumettre …
Sur mes 3 machines, j’aimerais convertir ma derniere au libre mais elle fait de la résistance :cry:

En fait, j’ai essayé debian et différences variantes basé sur debian, et j’obtiens toujours la même chose. Je m’explique :

Je boot sur le CD, je sélectionne langage, clavier, et j’arrive a la détection matérielle … Il commence a charger le module Silicon Image pour le HDD S-ATA et là il bloque dessus … Le lecteur CD s’arrete de bosser et je suis bloquer …

Donc j’ai fait un tour sur google pour voir qui a eu le même problème … Je tombe sur un topic sur hardware.fr qui suggerait a la personne de flasher son bios (PS : sont pas bourrin eux :slightly_smiling:). Donc j’ai mis mon bios a jour mais rien ne fait.

Je continue a chercher une solution sachant que Mandrake sinstall mais pitié tout sauf MDK :wink:


#2

est ce qu’une knoppix détecte bien tes disques SATA ? si oui, alors tu peux faire une install de ta debian depuis ta knoppix (je ne retrouve plus la ref, mais elle doit se trouver ds un autre post)


#3

Tiens la voila

egs-howto.com/fr/systemes/Knoppix.php


#4

N’comprends pas. Je suis en train d’appliquer cette méthode par ssh sur une machine qui n’a plus de clavier (ps2 mort, c’est pour faire un routeur), et j’ai pleins de problèmes sur l’étape debootstrap, alors que la dernière fois, tout s’était passé sans problème…
Scrogneugneu…


#5

enfin, l’install passe en mode expert26 mais le probleme c’est que après l’installation terminée avec succès ! je n’arrive pas a avoir le menu grub ou lilo (j’ai essayé les 2) et d’autres distrib aussi …

Je boot et ca me lance windows sans passer par un menu de boot :cry:
j’ai cru que j’avais un probleme avec ma mbr, j’ai booté sous DOS et fais un fdisk /mbr pour etre sur avant de faire mon enième essai mais j’obtiens le meme resultat … J’ai essayé aussi dinstall une Knoppix et idem sauf qu’avec la disquette de boot que j’avais faite la j’arrive a booter dessus. donc j’arrive pas a faire mon multiboot voila


#6

tu dois avoir installé ton boot loader sur une partition, ou sur un disque autre que ton disque de boot.
essayes, aprés avoir booté avec ta disquette
grub-install /dev/hda
(au lieu d’un truc du genre /de/hda1 ) pour l’installer sur le MBR de ton disque.
aprés, fais un ‘update-grub’ pour mettre a jour ton menu
et vérifies dans menu.lst que ta config est cohérente (je crois que c’est l’argument groot qui précise ou se fait l’install, chez moi elle est juste commentée)

si tu es en lilo verifies que l’option boot= pointe bien sur ton disque et pas sur une partoche
++


#7

ah au fait, update-grub ne va pas ajouter d’entrée pour booter sous windows, il faut que tu la rajoutes toi même aprés la partie qui se met à jour automatiquement.
aprés

END DEBIAN AUTOMAGIC KERNELS LIST

comme j’imagine que tu n’as qu’un disque dans ton portable, tu dois supprimmer l’option map dans ce qui suit (qui sert chez moi à “tromper” windows pour lui dire que le boot s’est bien effectué sur mon deuxieme disque), mais voilà mon entrée pour win2k:

title           MS Windobe 2000
map             (hd0) (hd1)
map             (hd1) (hd0)
rootnoverify    (hd1,0)
savedefault
makeactive
chainloader +1

bien sur, l’argument de rootnoverify est différent chez toi…


#8

Ce n’est pas un gel mais un énorme ralentissement ( 5-6 minutes ), pour les A7N8X avec Sil3112 il faut utiliser les noyaux 2.6.6 ou +.

Sinon jai eu effectivement le même problème bizarre concernant le boot loader avec Sarge, et la solution est encore plus étrange : quand il te demande sur quel disque installer le bootloader, indiques le second disque ( au lieu de /target0/ mets /target1/ ) au lieu du premier. C’est complètement absurde et illogique, mais ça marche ( note : jai utilisé lilo )