[install] disque SATA non reconnu


#1

Bonjour à tous,

Voila ca fait maintenant une semaine que je rame pour essayer d’installer une Debian.
J’ai essayé une sarge en netinstall mais impossible de détecter un disque à partitionner.
Du coup j’ai essayé la dernière testing en netinstall aussi, elle ne trouve toujours pas mon disque, du coup j’ai essayé de lancer tous les modules SATA qu’on me proposait… bad luck, aucun ne semble fonctionner.

J’ai vu un post sur le forum indiquant une autre méthode par debootstrap à partir d’un knoppix. Du coup, je tente ma chance avec mon live CD de Knoppix v4… pas de bol meme la, mon disque ne semble pas etre reconnu, impossible de monter sda ! :imp:

Je commence un peu à craquer la, qq1 aurait une idée ? Merci


#2

Alors là !
Si la knoppix ne reconnais même pas ton disque, c’est inquiètant.
La knoppix 4 est par défaut en 2.6 ? Tu as moyen de choisir un autre noyau sur cette knoppix 4 ?
Tu n’aurais pas une knoppix 3 qqchose, ou une ubuntu, pour voir si avec un autre noyau…
Il faudrait être sûr que ton SATA ne fait pas partie des matos non gèrés, mais ca me parait mal barré…
C’est quoi ton chipset ?
Tu n’aurais pas des pilotes propriétaires sur le CD de la carte mère ?


#3

Quand tu dis “impossible de monter sda”, tu veux dire “impossible de monter sdaX”, bien sûr ?
Parcequ’avant de pouvoir monter quoi que ce soit, il faut partitionner.
Tu as regardé si qtparted voyait ton disque (pas les partitions, s’il est vierge) ?


#4

Tout d’abord j’avais oublié qqchose d’important, j’ai déja 2 partitions NTFS crées sur ce disque avec un XP d’installé sur la première.

Le noyau de base de la Knoppix 4 est le 2.6.12.
Pour ce qui est d’ubuntu, j’ai déja essayé mais j’ai le meme probleme a l’install.

J’ai une carte mere ASROCK 939S56 avec un DD Maxtor 160G sur le slot SATA 1.
Effectivement il y a des pilotes propriétaires sur le CD mais ce sont des pilotes RAID.
Voila, voila. A ton avis je suis vraiment dans la m… ?


#5

qtparted me trouve en hda et hdb mon lecteur DVD et mon graveur.


#6

quand tu dis qu’il te trouve hda et hdb, c’est que c’est comme ça qu’il te détacte ton SATA, ou c’est un autre disque IDE ?
Parceque si c’est le SATA, c’est un peu étonnant de trouver tes partoches sous ce nom là, mais ca ne gène pas la suite, normalement…


#7

Non, c’est comme ca qu’il me détecte mes lecteurs cdrom sous Knoppix.
Je n’ai pas d’autre disque en IDE je n’ai que celui en SATA.


#8

dis donc ta carte, elle a deux mode de SATA, non ?
2 connecteurs SATA, et un connecteur SATA2 ?
c’est bien celle là asrock.com/product/product_939Dual-SATA2.htm ?
auquel cas ton chip SATA est un Uli M5289, et de ce que j’ai lu pour l’instant c’est ma&l supporté linux.
Mais je regardes encore ailleurs…


#9

Non la mienne c’est celle la : http://www.asrock.com/product/product_939S56-M.htm

Elle a deux sata, mais j’arrive pas a savoir quel chip c’est…


#10

Bon, ben puisque tu as la page de description de ta carte, pourquoi tu n’envoies pas un mail au support ?
En attendant, j’ai dl le ficjier pilote de ton SATA, et j’ai regardé le .inf windows, ton chip est décrit sous win comme “SiS 180/181 Raid Controller”.
bon, mais pas de surprise, pas de pilote nux (en tout cas dans la version 64 bits)


#11

Effectivement j’aurais peut etre du commencer par ca. Je viens de rectifier le tir en leur envoyant un mail. En attendant leur réponse je vais voir si je trouve pas des pilotes linux de mon côté.

[quote]
En attendant, j’ai dl le ficjier pilote de ton SATA, et j’ai regardé le .inf windows, ton chip est décrit sous win comme “SiS 180/181 Raid Controller”. [/quote]
Merci, j’aurais pu y penser mais je suis un peu newB dans ce domaine :blush:


#12

J’ai trouvé deux drivers sur le site de SiS:
http://www.sis.com/download/download_step2.php?id=155881&agree=1&country=France&Image7911.x=47&Image7911.y=7
http://www.sis.com/download/download_step2.php?id=155882&agree=1&country=France&Image7911.x=65&Image7911.y=7

Il y a les sources .c, les makefiles…

Maintenant, c’est possible de les utiliser au cours de l’install ?


#13

tu as un disque IDE (ou même une autre machine), pour préparer éventuellement le module sous knoppix ?
Si oui, il y a surement un moyen.
Sinon…


#14

Oui j’ai d’autres machines à disposition mais j’ai jamais préparé un module. Tu aurais pas une petite url à me conseiller ?


#15

tldp.org/LDP/lkmpg/2.6/html/index.html
et en particulier:
tldp.org/LDP/lkmpg/2.6/html/x384.html