Installation bumblebee primus sur debian 10

optimus
buster
Tags: #<Tag:0x00007fa9381d7200> #<Tag:0x00007fa9381d7020>

#21

Bonsoir,
Un commentaire. Il doit quand même manquer quelque chose à mon installation initiale car il n’est pas normal que la CG Intel ne soit pas vue par défaut (si c’était le cas je pourrais utiliser le terminal et internet). L’introduction du logiciel Bumblebee n’est qu’un plus permettant d’utiliser la CG dédiée nvidia si une application réclame plus de resources. Cette installation devrait donc être optionnelle. Pour avancer je ne peux utiliser que la console tty : il y a donc un manque à combler avant de penser à Bumblebee.
Merci de vos commentaires sur ce commentaire.
Bien cordialement
gerod


#22

Cela c’est la théorie. En fait, à partir du moment où la carte graphique nvidia est insérée dans la machine, il faut nécessairement un arbitrage pour gérer le signal vidéo et une palanquée de pilotes et nodules noyau :grinning:
Quels sont ces logiciels qui réclament tant de ressources ? Et quel est le surcoût financier et augmentation de consommation électrique de ces solutions Bumblebee/primus ?

Il faut faire la part des choses et considérer l’aspect marketing de ces combinaisons grand public.
Dans le cadre de la lutte contre le réchauffement climatique et pour limiter la consommation d’énergie, je verrais bien une taxe sur ce genre de produits.
Avoir des systèmes graphiques performants pour de l’imagerie médicale ou satellitaire pour la météo par exemple, cela se comprend, pour des jeux vidéo addictifs et abêtissants c’est nettement plus discutable.

Cordialement,
Regards,
Mit freundlichen Grüßen,
مع تحياتي الخالصة


F. Petitjean
Ingénieur civil du Génie Maritime.

« Il vaut mieux mobiliser son intelligence
sur des conneries que mobiliser sa connerie
sur des choses intelligentes. »
— vu sur linuxfr.org

« Moi, lorsque je n’ai rien à dire, je veux qu’on le sache. » (R. Devos)


#23

Bonjour,

Après avoir procédé à l’élimination de bumblebee, primus et "nvidia-*" - et que sais-je encore - comme expliqué dans les tutos comme rappelé par PengouinPdt :

Édition :

@PengouinPdt, je ne trouve aucun paragraphe ou chapitre concernant la désinstallation,
que ce soit dans https://debian-facile.org/doc:materiel:cartes-graphique:nvidia:optimus
ou https://wiki.debian-fr.xyz/NVidia_Optimus_Bumblebee
ni même https://wiki.debian.org/fr/Bumblebee

Oui : un serveur graphique et un environnement graphique de bureau (desktop environment ou DE).
Je n’ai pas en mémoire les commandes qui permettent d’installer un DE tout entier simplement.

Tu seras aidé.

Il faudra s’assurer que le pilote graphique Intel soit bien installé pour le fonctionnement du serveur graphique qui permet l’exploitation d’un DE.

Cela ne devrait pas poser de problème.

Par contre, l’accès à Internet et la carte graphique n’ont pas de point commun.
As-tu un accès à Internet depuis la console tty ?

ping -c 5 debian-fr.org

Ce WARNING d’apt est normal.
Autant dire que la commande suggérée n’a retourné aucun résultat.

Une petite bizarrerie de langage de Debian…
Pas de quoi s’alarmer :wink:

Quoique je remarque qu’il faille maintenant entourer de guillemets l’expression de recherche,
il me semble que ce n’était pas le cas avant. Qu’en penses-tu de ce détail @PascalHambourg ?

Réessaye avec :

sudo apt remove --purge "nvidia-*"

Elle l’est.
Ce sujet pourrait donc être clos. Même temporairement.

Bon courage !
C’est pas drôle du tout d’être coincé en console.


#24

Eh, bien toi, non plus, tu ne sais pas lire correctement !
Il faut que je recopie ce qui est exactement marqué - c’est quand même un comble !!! ?

ATTENTION : NE SURTOUT PAS CHERCHER À INSTALLER LES PILOTES NVIDIA PAR TOUTE AUTRE MÉTHODE !!!
Si jamais vous l’avez fait, désinstallez tout avant :
# apt remove --purge nvidia-*

Il me semble que, même si cela ne cible pas directement le propos, cela explique très clairement comment désinstaller le pilote nvidia, en (d)écrivant textuellement la commande, non ?!
OU, c’est parce que ce n’est pas dis explicitement : "pour supprimer le pilote nvidia, faite : " ???

Bref !
Bonne nuit !


#25

Ça n’a pas changé. Il a toujours été nécessaire d’utiliser des guillemets ou le caractère d’échappement \ pour éviter la substitution des caractères spéciaux comme “*” par le shell. C’est pareil que pour l’expression rationnelle d’une commande grep ou sed. Ceci dit l’oubli des guillemets n’a d’incidence que si le répertoire courant contient au moins un fichier ou répertoire dont le nom correspond à l’expression.


#26

Merci bien :slight_smile:
Je venais de remarquer cette incidence sans guillemets.

Bonne nuit Pascal


#27

Bonjour,
Je ne suis pas coincé dans la console mais je ne peux pas utiliser le DE disponible (le premier de la liste lors de l’installation).

Tout y est présent mais dans le terminal chaque frappe est dupliquée et se déplace sur la ligne, idem dans firefox (donc l’internet y est). Il n’y a que dans l’éditeur de texte que cela marche à peu près correctement et où j’ai pu créer le fichier custom.cfg préconisé par pH pour activer grub vers W.

Dans paramètres à la rubrique détails il y a un descriptif de la carte graphique :
llvmpipe
LLVM 7.0, 256 bits

Voulant utiliser debian avec des applications lourdes (simulateurs de vol) il est clair que le couplage avec nvidia est necessaire et devra être repris dès que ce premier problème sera réglé.

Il est également clair que sans votre aide je ne serai pas allé bien loin.
Bien cordialement
gerod


#28

Bonjour,
Suite à la recommandation précédente j’ai fait sudo apt remove --purge nvidia-* et j’ai eu la même réponse pour 4 paquets : ‘n’est pas installé, et ne peut donc être supprimé’.
Le problème reste donc : avant de passer à la phase “optimus” comment avoir un DE pouvant être utilisé ?
Bien cordialement.
gerod

Ces paquets sont :
nvidia-legacy-340xx-vdpau-driver
nvidia-legacy-304xx-vdpau-driver
nvidia-vdpau-driver
nvidia-libopenc11-dev


#29

Note : je n’ai pas lu le début de la discussion.

Si tu as bien un système Optimus avec double GPU Intel+Nvidia, une astuce que j’ai utilisée sur plusieurs machines de ce type pour contourner divers problèmes (mais pas celui que tu décris, que je n’ai jamais rencontré) consiste à désactiver le pilote “nouveau” du noyau. Il y a plusieurs méthodes possibles pour le faire, en voici une :

Créer un fichier /etc/modprobe.d/blacklist-nouveau.conf contenant :

blacklist nouveau

Exécuter la commande suivante pour reconstruire l’initramfs en prenant ce fichier en compte si nécessaire :

update-initramfs -u -k all

En revanche si les modules nvidia* du pilote propriétaire Nvidia sont encore installés, je ne sais pas lesquels il faut blacklister. La commande lsmod affiche la liste des modules chargés.


#30

La commande update-initramfs réclame que soit spécifié au moins -c, -u ou -d.
Faut il créer un nouveau initramfs (-c), updater l’existant (-u) ou détruire l’existant (-d) ?


#31

-u (update)
Désolé de l’oubli, je corrige mon message précédent.
EDIT IMPORTANT
+ correction d’une faute de frappe dans le fichier blacklist, sinon sera sans effet


#32

Il y a eu pas mal de lignes avec libkmod ERROR et également avec “Possible missing firmware …”.
Pour ce qui est du résultat ce n’est pas mieux, voire pire en ce sens que la souris ne répond quasiment plus. Quant au pavé tactile il n’a jamais marché.
Heureusement que j’ai un deuxième portable de 2008 qui marche encore très bien ce qui m’évite de devoir basculer sous W10 pour communiquer.


#33

A quel moment ? Exécution d’update-initramfs ou démarrage ?
Dans le premier cas, est-il possible de voir le détail des messages ?


#34

Ces messages sont apparus à l’exécution de update-initramfs -u -k all. Ils ont rempli plusieurs pages de l’écran. J’aurais du faire une redirection vers un fichier texte. Si je recommence maintenant cela sera t’il pertinent ?


#35

Oui. Ça va refaire la même chose.
EDIT : note que les messages d’erreur sont envoyés sur un flux de sortie distinct, donc pour les rediriger aussi il faut faire (l’ordre des redirections est important) :

commande > fichier.txt 2>&1

#36

Voici les fichiers update-initramfs.txt et lsmod.txt

lsmod.txt (5,8 Ko)
et
update-initramfs.txt (23,0 Ko)

Ce comportement initial du DE est quand même anormal : faudra t’il que je recommence encore toute l’installation (il y a forcément encore des problèmes que je n’ai pas eu).


#37

Aucun module nvidia* n’est chargé.
Le module nouveau est toujours chargé, et il est bien chargé par l’initramfs donc l’update est nécessaire.

Tu n’as pas corrigé l’erreur que j’avais faite puis signalée dans blacklist.conf : c’est “blacklist”, pas “blackslist”.

Tu peux installer le paquet firmware-misc-nonfree (section non-free) pour supprimer les messages de firmwares manquants. Souvent ces firmwares ne sont pas réellement nécessaires. Il faut regarder dans la sortie de la commande dmesg s’il y a vraiment des firmwares manquants.

dmesg | grep -i firmware

On t’a suggéré de tester un autre environnement de bureau que celui par défaut (Gnome) qui est l’un des plus exigeants. Tu peux le faire via l’interface de la commande tasksel.


#38

Après correction de l’erreur dans blacklist-nouveau.conf les fichiers obtenus sont :
lsmod.txt (5,8 Ko)
et
update-initramfs.txt (17,2 Ko)

L’ajout du paquet firmware-misc-nonfree aura t’il une influence sur la qualité du DE actuel ou faut il vraiment que je change le DE ?. Ce n’est pas un problème mais je suis quand même surpris et ne comprend pas qu’une distribution officielle présente un tel niveau de non qualité pour le DE de base (ou alors cela est lié à ma configuration matérielle). Je reste persuadé qu’il doit y avoir autre chose dans les réglages notamment (j’ai balayé les options possibles pour un utilisateur lambda).


#39

En passant en rapido : en effet, si c’est “nouveau” qui est chargé, et que le GPU n’est pas géré correctement, cela peut expliquer les saccades qu’il a à utiliser le DE !
“nouveau” ne gérant pas son GPU, il n’y a pas d’accélération graphique, donc saccades.

Comme on le voit sur cette page du site FreeDesktop, ce GPU fait partie de la famille architecturale dite Pascal, c’est même le NV136 exactement. Comme le fait remarquer cette autre page, il y a tout à faire pour la gestion du support !

Donc, de fait, ma recommandation est, avant de triturer dans initramfs et le reste, de “supprimer” nouveau !!!
(et ce n’est pas faute de ne pas l’avoir écrit dans les deux documentations sur le sujet !)


#40

C’est encore plus simple maintenant : après la sélection debian dans grub l’écran reste noir et il faut que je passe par le bouton power !!!