Installation de Debian 12.5.0 sur 2 HD

Tags: #<Tag:0x00007fedda27d088>

Bonjour
J’ai une machine que je veux dédier à Debian 12.5.0 (64 bits) pour en faire un serveur de fichiers.
Je dispose de 2 disques : 1 HD de 250 Go et 1 HD de 500 Go.
Je souhaite installer le système sur le 250 Go et conserver l’autre pour le répertoire /home et y stocker les fichiers.
Lors de l’installation (en mode graphique), je partitionne manuellement les disques, les 2 HD apparaissent ainsi que le support d’installation (clé USB). Petite précision, je n’ai pas de connexion internet pour ce PC.
L’installation se fait sans difficulté, j’enlève la clé USB avant de redémarrer et là… erreur Grub (grub rescue) qui indique qu’il manque un support. Si je replace la clé USB et que je redémarre sur le HD système, tout se passe correctement.
J’ai testé en faisant une installation avec un DVD après avoir supprimé toutes les anciennes partitions, même problème au redémarrage si le DVD n’est pas dans le lecteur.
Quelqu’un aurait-il une explication avant que je me tourne vers une autre distribution ?
Merci d’avance

Bonjour,

un truc tout bête, mais vers la fin de l’installation, l’installeur te propose d’installer Grub sur un périphérique, tu as bien sélectionné le périphérique correspondant à ton disque 250 GB ?

C’est forcément ça l’erreur .

Merci pour la réponse mais j’ai bien validé cette option et installé le grub sur le bon disque…

Pour info, le message affiché est le suivant :
error : no such device : 77c117f8-… (je vous passe la suite)
error : unknown filesystem

J’ai fait des recherches sur les forums, pour le moment ce que j’ai trouvé est lié à un dual boot alors que seule Debian est installée sur les disques.

Je rappelle que le phénomène est identique si j’installe à partir d’un DVD. Si le DVD est absent du lecteur, j’ai le message, s’il est présent le système démarre sans problème. Que je sache, grub ne s’écrit pas sur un DVD simple qui n’est qu’en lecture.

Boot à modifier dans le bios/uefi ?

Et si tu laisses le partitionnement automatique de l’installeur se débrouiller tout seul sur le 1er HD ? (tu pourras toujours déplacer ton home sur le 2e disque plus tard, c’est très facile et rapide à faire).

Tu as fait ton installation avec quelle ISO?

Avec l’ISO officielle et en ayant vérifié le téléchargement.

Pour finir avec ce cas d’école, partant du principe qu’on n’est jamais si bien servi que par soi-même, je m’auto-réponds.
Alors que Windows ne s’offusque pas si un média réputé bootable n’est pas présent physiquement alors qu’il est mentionné dans l’ordre de démarrage du BIOS, le petit pingouin n’admet pas cette tromperie et bloque le démarrage. La solution est simple, changer l’ordre du boot dans le BIOS.
Merci à tous de votre participation.

sauf que tu as parlé d’erreur de grub, ce qui suppose que tu as déjà démarré à prtir du bios, non ?

où es-tu zargos? XY ! XY !

1 J'aime

N’importe quoi. Linux n’a rien à voir là-dedans, il n’est pas encore lancé. Quant à GRUB, il se fiche royalement de l’ordre de boot du BIOS. D’ailleurs il n’y a même pas accès.

Et l’explication l’est tout autant : le PC ne bootait pas sur le bon disque. Et il se trouve que l’autre disque contenait un reste de GRUB d’une précédente installation.

@antek t’avait donné la solution ceci dit !