Installation de webmin et problème de dependance perl

Bonjour, je travaille sur le debian
je veux installer webmin
Mais cela ne fonctionne pas en faisant la commande : apt-get install
j’obtien ceci :
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 webmin : Depends: libnet-ssleay-perl but it is not going to be installed
          Depends: libauthen-pam-perl but it is not going to be installed
          Depends: libio-pty-perl but it is not going to be installed
          Depends: apt-show-versions but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

puis j’ai essayer d’installer les dependance et j’otien ceci :
root@ns343832:~# apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions python
Reading package lists… Done
Building dependency tree
Reading state information… Done
libpam-runtime is already the newest version.
python is already the newest version.
python set to manually installed.
perl is already the newest version.
openssl is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apt-show-versions : Depends: libapt-pkg-perl (>= 0.1.21) but it is not going to be installed
 libauthen-pam-perl : Depends: perlapi-5.14.2
 libio-pty-perl : Depends: perlapi-5.14.2
 libnet-ssleay-perl : Depends: perlapi-5.14.2
E: Unable to correct problems, you have held broken packages.

Voici mon fichier sources.list:
deb http://debian.mirrors.ovh.net/debian/ wheezy main contrib non-free
deb-src http://debian.mirrors.ovh.net/debian/ wheezy main contrib non-free

deb http://download.webmin.com/download/repository sarge contrib
deb http://webmin.mirror.somersettechsolutions.co.uk/repository sarge contrib

merci d’avance pour votre aide

Perso, je l’installe en direct. La version actuelle est la 1.860 pour debian. Assures-toi que ta distribution soit à jour.

cd /root

wget http://prdownloads.sourceforge.net/webadmin/webmin_1.870_all.deb

apt-get install libio-pty-perl libnet-ssleay-perl libauthen-pam-perl

dpkg -i webmin_1.870_all.deb

Tu devras peut-être faire un “apt-get -f install” pour régler les prob de dépendances.
Voilà, tu pourras te connecter en faisant : “https://000.00.000.00:1000

Debian wheezy : humm je ne sais pas si c’est bien de rester sur une vieille dsitrib, tu as eu par la suite jessie et maintenant stretch donc tu risque d’avoir des prob avec des paquets qui utilises php7 ou une version d’apache2 supérieure. C’est mon avis.

Merci de ta réponse.
alors j’ai essayer de faire comme ceci mais quand je fait apt-get install libio-pty-perl libnet-ssleay-perl libauthen-pam-perl j’otien ceci :

Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libauthen-pam-perl : Depends: perlapi-5.14.2
 libio-pty-perl : Depends: perlapi-5.14.2
 libnet-ssleay-perl : Depends: perlapi-5.14.2
E: Unable to correct problems, you have held broken packages.

ets ce que cela peut provenir de la version de debian ?

Bah là, je comprends qu’il estime que tu utilises une version non stable de ta distrib.

Je te conseille de virer dans ton sources.list tout ce qui fait mention à webmin, ensuite faire un “apt-get update && upgrade” puis “apt-get autoremove” histoire de nettoyer un peu tout ça.

puis relance ce que je t’ai envoyé.

Les lignes pour webmin dans ton sources.list concernent Sarge (Debian 3.1). Tu es sûr qu’ils n’ont pas plus récent ? Parce que forcément, vouloir installer des packages d’un dépôt Debian 3.1 quand on est sur une Debian 7, ça facilite pas les choses.

Je pense que leur doc est pas hyper à jour de ce côté là.

je vien de faire ce que tu me demande mais quand je fait

apt-get install libio-pty-perl libnet-ssleay-perl libauthen-pam-perl

j’obtien ceci :

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libauthen-pam-perl : Depends: perlapi-5.14.2
 libio-pty-perl : Depends: perlapi-5.14.2
 libnet-ssleay-perl : Depends: perlapi-5.14.2
E: Unable to correct problems, you have held broken packages.

apt-get -f install

Il va se débrouiller à trier ce qu’il a besoin.

ok je viens de faire apt-get -f install sa me donne ceci

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

je pense que cela n’a pas résolu mon souci

sinon est ce que tu ne connaitrai pas un outils similaire a webmin

ok merci je vais voir cela

Ce message a été signalé par la communauté et est temporairement masqué.