Installation Debian 9.6 9.99 10 impossible, refus d'installer GRUB

Tags: #<Tag:0x00007fae4eeefd50> #<Tag:0x00007fae4eeefa08> #<Tag:0x00007fae4eeef7b0> #<Tag:0x00007fae4eeef530>

Bonjour,

Mon pc: NUC 6 processeurs 4*Intel Core i3-6300U CPU @ 2,30 GHz
Mémoire vive 8 Go
SSD de marque (256 Go)

  1. Abandon de W10 pour Debian 9.6, que du bonheur…

  2. Installation de Debian 9.99 (USB Rufus en Gpt).

    Les ennuis commencent, installation avortée au moment de l’installation de GRUB, bug à environ 50%.
    Multiples essais infructueux : changement de clef, utilitaire différent de Rufus, en Mbr …

  3. Installation de Debian 9.99 en ligne, miracle, installation correcte,

  4. Installation de Debian 10, USB ou en ligne, installation avortée au moment de l’installation de GRUB, bug à environ 50%.

  5. Test de l’état du SSD, pas de défaut.

  6. Par curiosité j’essaye de réinstaller Debian 9.99 ou Debian 9.6, impossible, bug GRUB comme précédemment… même en ligne ???

  7. J’essaye d’installer d’autres distributions…Idem

  8. J’installe W10.

  9. J’installe openSUSE Leap 15.1, qui partage le SSD avec W10 et installe un multiboot.

Si vous avez, ne serait-ce que quelques pistes de reflexions, elles sont le bienvenues.

Merci.

Installeur Debian lancé en mode BIOS/legacy ou EFI ?
Qu’est-ce qui est affiché dans la console des logs (Ctrl+Alt+F4) au moment de l’erreur de GRUB ?

Bonjour,
Es-ce que tu as lancé windows récemment ?
Il se pourrait que l’un de tes disques dur soit bloqué par windows, en effet j’ai eu un problème d’écriture des disques sous linux lorsque j’avais windows 10.
Il faut toujours éteindre windows proprement par c:/Windows/System32>shutdown /s /f /t 0

Je dis pas que c’est le coeur du problème mais ça peut aider.

L’installateur est lancé en mode EFI.
Debian demande au bout de 3 échecs pour installer GRUB de procéder autrement en utilisant une “autre méthode”, cela ne résous pas le problème.
La console affiche toutes les étapes et signale la non installation de GRUB.
Le message d’erreur propose de lancer GRUB en ligne de commande.

Merci pour votre aide.

L’installation de W10 me sert uniquement pour permettre l’installation de openSuse, c’est la seule distribution que j’ai réussie à installer… grâce à W10 présent sur le SSD.

Je ne me sert jamais de W10, et les pbs avec GRUB sont antérieures à ce bidouillage avec W10.

Merci pour votre suggestion.

Si tu ne donnes pas les informations complètes, exactes et précises, on ne pourra pas t’aider.