Installation Debian et carte Ethernet introuvable

Tags: #<Tag:0x00007fd6e99a3e50> #<Tag:0x00007fd6e99a3d88> #<Tag:0x00007fd6e99a3cc0>

Bonjour à tous,
je switche de Ubuntu vers Debian et suis donc totalement nouveau ici :slight_smile:
J’ai récupéré l’ISO Debian sur le site debian.org : debian-9.6.0-amd64-netinst.iso

Lors de l’installation, on me dit qu’aucune carte Ethernet n’a été trouvée et on me demande de choisir un driver.
Mon PC est un Dell OptiPlex 5060 avec carte Ethernet intégrée à la carte mère (machine récente commandée le mois dernier).

Un lspci me renvoie ces informations :
Ethernet Controller : Intel Corporation Device 15bc (rev 10)

Sur le site d’Intel https://www.intel.fr/content/www/fr/fr/support/articles/000005480/network-and-i-o/ethernet-products.html, je vois que les pilotes (non libre du coup ?) sont de la forme :
IGB-x. x. x. tar. gz Driver
e1000e-x. x. x. x. tar. gz Driver
e1000-x. x. x. tar. gz Driver

J’ai bien ces entrées dans le menu de l’installeur mais quand je les choisis, ça réfléchit quelques secondes avant de réafficher à nouveau le message d’erreur “Carte Ethernet Introuvable” avec le menu de sélection des pilotes…

Qu’en dites-vous ?
Je ne comprends pas bien ce qu’il se passe… Est-ce qu’il a essayé (sasn succés manifestement) d’utiliser un pilote libre pour utiliser l’interface réseau ?
A défaut, j’essaierais :

  1. avec l’image disque DVD qui semble plus complète
  2. avec l’image disque contenant les pilotes non-libre (si je n’ai pas le choix)

A moins que vous n’ayez d’autres idées ou suggestions ??

Merci d’avance pour votre aide :slight_smile:

Donut

Bonjour DonuttMan,

J’ai eu le même problème sur un DELL 3630 [15bb] - e1000e-x. x. x. x. tar. gz Driver
Il faut que tu récupères le bon Pilote chez Intel (e1000e-x. x. x. x. tar. gz) à vérifier
tu compiles le module (e1000e.ko par exemple) et tu replaces l’ancien e1000e.ko se trouvant /lib/modules…/kernel/4.9xxx/…/intel/e1000e.ko
puis te recharge le module insmod.

Stef

Bonjour DonutMan et bienvenue :slight_smile:

La commande :

lspci -knn | grep -iA2 ethernet

est pratique pour mieux identifier le périphérique Ethernet ainsi que le module utilisé.

La carte** Ethernet Controller : Intel Corporation Device 15bc (rev 10) **
elle doit correspond à une carte intel I219-V --> https://pci-ids.ucw.cz/v2.2/pci.ids

modinfo --field firmware e1000 e1000e igb

ne renvoie rien donc les pilotes e1000, e1000e et igb ne déclarent pas avoir besoin de firmwares. Normalement l’installateur est capable de détecter si un pilote réclame un firmware et le fait savoir. L’image incluant les firmwares non libre ne servira probablement à rien.

Si la machine est récente, les pilotes du noyau 4.9 de Debian 9/Stretch sont tout simplement probablement trop anciens pour prendre en charge cette carte réseau. Il faudrait essayer avec un noyau plus récent comme celui de Debian testing.

2 J'aime

Bonsoir à tous,
merci pour vos retours rapides !
En effet, la bonne solution était de recompiler le pilote e1000e-x. x. x. x. tar. gz.
J’ai eu quelques petites sueurs froides quand je me suis rendu compte que ma Debian fraîchement installée ne disposait pas de l’outil Make (et n’avait pas du tout accès à Internet), mais je me suis débrouillé avec la Debian d’un collègue.

Bonne fin de soirée à tous, et à bientôt !

Donut

P.S : j’ai rajouté “résolu” dans le titre du message mais je ne suis pas sûr que ce soit pratique courante ici ? Il y a un modus operandi particulier ici pour les fils résolus ?

1 J'aime

Salut à tous,
Je suis tombé sur le même problème que DonutMan avec un Intel NUC 8 i3 BEK2 équipé d’une carte ethernet i219-v.

Je note la solution de recompiler le pilote e1000e à la mano (pareil, je vais devoir le faire sur une VM Debian car je n’ai pas make sur l’install fraîche du NUC).

Pour info, la carte i219-V fonctionne sous Buster. Aussi, je me demande si une mise à jour du kernel ne ferait pas aussi l’affaire pour réparer ce problème ? Quelqu’un qui s’y connait mieux que moi a-t-il un avis sur la question ?

Merci !

salut
ça te trouvé

https://pci-ids.ucw.cz/v2.2/pci.ids

rendez vous sur iso +nonfree : https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/10.2.0-live+nonfree/amd64/iso-hybrid/

Personnellement je préfère la version DVD dont vous trouverez le liens ci-dessous, téléchargez le fichier " firmware-10.2.0-amd64-DVD-1.iso " qui inclus les drivers pour cartes réseau et le tour est joué :

https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/10.2.0+nonfree/amd64/iso-dvd/

Vous aurez le choix d’installer le / les bureau(x) que vous désirez durant le processus d’installation.

La fonction sudo tasksel est à utiliser dans un terminal en post installation pour vous permettre de rajouter facilement un environnement de bureau.

firmeware-debian10.2 veux pas avec i219-v et aussi e1000e non plus debian ne veux pas accpeter :frowning:
dommage j’attendre nouvelle carte réseaux tplink TG-3468 si sure accpete la

SI vous utilisez une carte réseau d’un grand constructeur tel Intel et qu’elle ne vient pas de sortir sur le marché, elle doit être compatible de base, si non il faut voir avec le constructeur de votre carte réseau pour obtenir un pilote pour Debian pour autant qu’ils conçoivent des pilotes pour Linux…

La fonction :

inxi -Fxz

Vous donnera des informations plus précises sur votre matériel embarqué.

Les cartes Wifi Intel 92xx sont prises en charge par la version de Debian que je vous ai conseillée tout comme les cartes Intel I2xx qui semblent équiper votre machine

https://www.dell.com/support/home/ch/fr/chbsdt1/product-support/product/optiplex-5060-desktop/drivers