Installation echouée " installation du systeme"

Tags: #<Tag:0x00007efeded4dff8>

Bonjour , cela fait quelques années que je suis sur des systemes linux principalement ubuntu car j ’ ai toujours beaucoup de mal a installer debian sur mes ordis .

je me disais que maintenant et avec la V11 , ce dvrait mieux se passer qu ’ il y a une decennie , et bien malheureusement ce n’ es pas le cas …

Bref , lors de l’ installation au moment de la copie des fichiers sur le disque j ’ ai un retour : une partie de l’ installation a echoué : installation du systeme .

j ’ ai essayé en mode automatique dans un espace libre , indiqué une partition racine et une partition swap manuellement dans un espace libre , en selectionnant autre chose et en indiquant l ’ espace libre a partitionné en ext4 et en indiquant racine comme point de montage et d’ autres methpdes que j’ ai du oublier , le blocage apparait toujours au meme endroit .

Comment savoir ce qui bloque precisement ?
Merci pour vos lumieres .

Comment as-tu préparé le support d’installation (quelle image ISO, méthode…) ?
Fais-tu l’installation depuis un système Debian live ou avec l’installateur classique ?
Avec l’installateur classique, tu peux basculer dans la console tty4 pour afficher les derniers logs avec Ctrl+Alt+F4. Si cela ne suffit pas, tu peux basculer dans la console tty2 (Alt+F2) pour lancer un shell et examiner le contenu du fichier /var/log/syslog. Par exemple pour afficher les 100 dernières lignes page par page :

tail -n 100 /var/log/syslog | more

Bonjour , j ’ ai ltelecharger l’ iso debian-live-11.1.0-amd64-cinnamon.iso.torrent sur cette page : Index of /debian-cd/current-live/amd64/bt-hybrid

ensuite j’ ai inseré ma cle USB , ouvert " disques dans ubuntu , selectionner la clé USB ( SDE ) cliquer en haut a droite sur restaurer une image disque , selectionner le fichier apres telechargement du torrent nommé " debian-live-11.1.0-amd64-cinnamon.iso " et " grraver l’ image sur ma cle USB , attendu la fin de la " gravure " , redemarrer l ’ ordi , appuer sur sup pour entrer dans le BIOS , mis les clés USB en priorité de boot et sauvegarder .

Ensuite apparait le menu debian 11 dans lequel j ’ ai selectionner installateur graphique ou celui sans option dont je ne me rapelle plus le nom ( entierement en mode console graphique ) , mais les resultats sont identiques .

Apres Apparition de l’ erreur j ’ ai basculé sur la console 4 qui affiche ( j ’ aurais du prendre une photo … ) un truc dans le genre comme si le disque etait abimé ou des secteurs defectueux mais je me rappelle pas exactement .

je vais tenter de graver a nouveau l ’ image avec la CLI sait on jamais , mais lors du 1er essai avec cette methode , la clé clignotait sans arret meme apres 15 minutes et pourtant le prompt etait de retour apres une minute , si il y avait une commande qui montre l’ etat d’ avancement , ca serait tout de meme un plus .

C’est dommage que tu n’ais ni noté ni pris de photo. Il faudrait savoir si c’est la clé USB ou le disque cible.
As-tu vérifié l’intégrité du support en revenant au menu principal de l’installateur à partir de n’importe quelle étape ?

non pas verifié l’ integrite apres gravure sur clé , sachant que normalement en telechargeant par torrent le fichier est deja automatiquement verifié , et vu que la " gravure " c ’ est fini sans incident je n’ ai pas pris la peine de verifier , j’ aurais du .

Actuellement j’ ai lancé la commande copie suivant apres insertion de ma clé USB :
cd /datas/iznobe/Téléchargements
puis:

iznobe@iznobe-PC:/datas/iznobe/Téléchargements$ cp debian-live-11.1.0-amd64-cinnamon.iso /dev/sde
cp: impossible de créer le fichier standard '/dev/sde': Permission non accordée
iznobe@iznobe-PC:/datas/iznobe/Téléchargements$ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda           8:0    0   3,6T  0 disk 
├─sda1        8:1    0   3,4T  0 part 
├─sda2        8:2    0 195,3G  0 part 
├─sda3        8:3    0  14,1G  0 part 
├─sda4        8:4    0   513M  0 part 
├─sda5        8:5    0  18,1G  0 part 
└─sda6        8:6    0   977M  0 part 
sdb           8:16   0   7,3T  0 disk 
├─sdb1        8:17   0   6,8T  0 part /Vidéos
└─sdb2        8:18   0 520,3G  0 part 
sdc           8:32   0   2,7T  0 disk 
├─sdc3        8:35   0   2,7T  0 part /datas
└─sdc4        8:36   0    32G  0 part [SWAP]
sdd           8:48   0 465,8G  0 disk 
└─sdd1        8:49   0 465,8G  0 part /media/iznobe/Sauvegardes
sde           8:64   1   3,8G  0 disk 
├─sde1        8:65   1   2,6G  0 part 
└─sde2        8:66   1   2,6M  0 part 
nvme0n1     259:0    0 476,9G  0 disk 
├─nvme0n1p1 259:1    0   125G  0 part 
├─nvme0n1p2 259:2    0   637M  0 part 
├─nvme0n1p3 259:3    0   100M  0 part /boot/efi
├─nvme0n1p4 259:4    0   535M  0 part 
├─nvme0n1p5 259:5    0  30,5G  0 part 
├─nvme0n1p6 259:6    0  49,4G  0 part 
└─nvme0n1p7 259:7    0  49,3G  0 part /
iznobe@iznobe-PC:/datas/iznobe/Téléchargements$ sudo cp debian-live-11.1.0-amd64-cinnamon.iso /dev/sde
[sudo] Mot de passe de iznobe : 
iznobe@iznobe-PC:/datas/iznobe/Téléchargements$

je trouve cela curieux qu ’ il ait fallu que j’ utilise sudo

la copie a pris presque 20 minutes , mais aucune erreur en retour de CLI .
je vais tenter une verif , puis d’ installer a nouveau .

Comme je l’ai écrit, tu peux aussi vérifier l’intégrité du support lors de l’installation.

Non, c’est normal, il faut les privilèges root pour écrire directement sur un périphérique bloc (ou être membre du groupe « disk », mais c’est une très mauvaise idée).

Un support défectueux ne génère pas forcément d’erreur lors de l’écriture, c’est à la relecture qu’on s’en aperçoit. Pour vérifier, tu peux utiliser

sudo cmp debian-live-11.1.0-amd64-cinnamon.iso /dev/sde

Si la commande se termine en atteignant la fin de l’image ISO, alors le support est bon.

Alors apres recopie de l ’ image iso sur la clé , redemarrage cette fois j’ ai choisi essayer debian avant de directement vouloir installer , je ne sais pas quel etait la cause du probleme precedemment , mais bon avec ce nouvel essai ca a fini par installer correctement le systeme , jen ’ ai pas mis de partition ESP / boot , ni de partition de swap .

Ayant deja une partition de swap sur sdc4 me semble t il , puis je l’ indiquer dans mon fichier /etc/fstab pour l ’ utiliser aussi bien sur debian que sur ubuntu ?

Pour le menu de demarrage GRUB , apres l’ installation de debian j ’ ai 11 redemarrer sous ubuntu 21.10 pour y passer la commande sudo update-grub, ca a bien pris le nouvel OS en compte a partir duquel j ’ ecris actuellement :

iznobe@iznobe-PC:~$ lsb_release -id
Distributor ID:	Debian
Description:	Debian GNU/Linux 11 (bullseye)
iznobe@iznobe-PC:~$

Oui, à condition de ne pas mettre un système en hibernation puis redémarrer sur l’autre. Cela effacerait l’image d’hibernation enregistrée dans le swap, empêcherait la reprise et pourrait provoquer une corruption des systèmes de fichiers montés.

Et tu devras le refaire après chaque installation ou suppression d’un noyau (donc à peu près à chaque révision mineure) ou modification des paramètres du noyau dans Debian pour la reporter dans le menu de démarrage d’Ubuntu. Je trouve que ce n’est pas très pratique pour gérer un multiboot de plusieurs distributions Linux et je préfère créer des entrées dans le menu de la distribution principale qui affichent directement le menu des autres distributions. Mais c’est une autre histoire.

Bonjour , je ne pouvais plus repondre apres un certain nombre de message la derniere fois , je devais attendre 23 heures …

Effectivement , la solution proposée parait plus adaptée , mais etant en EFI je ne sais faire ce genre de chose .
Y a t ’ il un tuto ou une documentation pour appliquer cette procedure , qui simplifierait grandement la coexistence des multiples OS ?

L’UEFI, s’il n’est pas trop pourri, permet de sélectionner l’OS à lancer depuis un menu de boot, en évitant de passer par le GRUB d’un OS pour démarrer un autre OS.

mon UEFI doit etre plutot pourri dans ce cas , ou alors je ne sais pas ou chercher l ’ UEFI en question .

De mon coté je n’ ai que 2 solutions , la 1ere , dans le BIOS ( pas pratique ) me propose 2 choix , le GRUB ubuntu ou bien windows .
La 2eme ( avec le BIOS reglé sur le GRUB ) me propose la liste des OS que je peux choisir .

En général il faut appuyer sur une touche (variable selon le firmware UEFI) pour afficher le menu de boot au démarrage. Par contre Debian devrait être proposé dans ce menu si tu as bien mis GRUB en place lors de l’installation.

lors de l’ install de debian , apres beaucoup d ’ essais , je n ’ ai fait l’ install que de la partition racine , j’ ai ajouté manuellement dans le fstab la partition de SWAP .
la partition de boot/efi etant deja presente dans mon systeme multi O-S , je n ’ en ai pas ajouté avec l’ installation de debian . j ’ ai juste redemarrer sur l’ os principal et fait un sudo update-grub comme indiqué dans un des messages precedent .

je ne connais pas la touche pour lancer le menu EFI mais une ligne supplementaire est presente en derniere place dans le menu GRUB qui , si je la selectionne , m ’ eteins l’ ordi pour demarrer dans le BIOS …

C’est généralement une touche de fonction entre F1 et F12. Parfois elle est affichée à l’écran lors du démarrage, par exemple : « Press F9 for boot menu ».

C’est l’entrée « System setup » qui exécutre la commande fwsetup permettant d’entrer dans les paramètres UEFI (ce n’est plus un BIOS). Pas grand intérêt ici.

Avant d’aller plus loin, j’ai besoin d’en savoir un peu plus sur ton système Debian. Peux-tu poster le contenu du fichier /etc/fstab et la sortie des commandes suivantes depuis celui-ci ?

dpkg -l grub-efi-amd64 grub2-common efibootmgr
# pour voir si ces paquets sont installés
efibootmgr # à installer au préalable s'il ne l'est pas

Bonjour ,
alors voici les retours :

iznobe@iznobe-PC:~$ sudo apt update
Atteint :1 http://deb.debian.org/debian bullseye InRelease
Atteint :2 http://security.debian.org/debian-security bullseye-security InRelease
Atteint :3 http://deb.debian.org/debian bullseye-updates InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Tous les paquets sont à jour.
iznobe@iznobe-PC:~$ 
iznobe@iznobe-PC:~$ sudo apt install efibootmgr
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
efibootmgr est déjà la version la plus récente (17-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
iznobe@iznobe-PC:~$ 
iznobe@iznobe-PC:~$ dpkg -l grub-efi-amd64 grub2-common efibootmgr
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom            Version      Architecture Description
+++-==============-============-============-=======================================================
ii  efibootmgr     17-1         amd64        Interact with the EFI Boot Manager
ii  grub-efi-amd64 2.04-20      amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 version)
ii  grub2-common   2.04-20      amd64        GRand Unified Bootloader (common files for version 2)
iznobe@iznobe-PC:~$

je ne peux pas modifier mon message precedent pour une histoire de lien , alors desolé mais je double poste , d’ ailleurs , je n’ ai mis aucun lien , enfin bref .

Je voulais preciser , que ubuntu budgie 21.10 etant ma " distribution par defaut actuellement "
j ’ ai modifié les permissions du fichier " /etc/grub.d/30_os-prober " des autres systemes pour enlever le bit d’ execution et donc enlever la capacité des autres OS a rechercher des OS a l’ exterieur de leur propre systeme .

[HS]
Pourquoi je n’ ai pas le retour a la ligne dans ma section code , ca rend illisible , j ’ en suis desolé , j ’ ai cliqué deux fois pour avoir les " ’ " , car avec les espaces pas facile d ’ inseré le code a l’ interieur .
[/HS]

Un aimable modérateur l’a fait pour toi, merci à lui comme toujours.

C’est l’URL des dépôts de paquets qui est considéré comme un lien. D’ailleurs je ne pense pas avoir demandé la sortie de apt update. Par contre j’avais demandé la sortie de efibootmgr et le contenu du fichier /etc/fstab. J’ajoute une question : le fichier /boot/grub/grub.cfg est-il présent ? (pas besoin de son contenu)

Ah, il n’y a pas qu’Ubuntu et Debian ?
Enlever le bit d’exécution de 30_os-prober n’est pas la méthode la plus propre pour désactiver os-prober ; certes /etc/grub.d/30_os-prober est géré en « conffile » par le paquet grub-common donc ne sera pas remplacé sans te demander lors d’une mise à jour de ce paquet, mais il y a une option prévue pour ça dans /etc/default/grub : GRUB_DISABLE_OS_PROBER=true

Merci effectivement au moderateur pour l’ edition de mon message precedent . :grinning:

Pour les liens , effectivement je n’ avais pas pensé a ceux là .

ok , donc si jamais , on ne modifie pas les sorties , je remetrrait le bit d’ execution sur chaque fichier et activerai l’ option prevue a cet effet dans /etc/default/grub , merci pour l’ info .

non effectivement :

iznobe@iznobe-PC:~$ sudo chmod +x /etc/grub.d/30_os-prober
[sudo] Mot de passe de iznobe : 
iznobe@iznobe-PC:~$

iznobe@iznobe-PC:~$ sudo os-prober
/dev/nvme0n1p3@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
/dev/nvme0n1p5:Linux Mint 20.2 Uma (20.2):LinuxMint:linux
/dev/nvme0n1p6:Ubuntu 18.04.6 LTS (18.04):Ubuntu:linux
/dev/nvme0n1p7:Ubuntu 21.10 (21.10):Ubuntu1:linux
/dev/sda3:Ubuntu 21.04 (21.04):Ubuntu2:linux
iznobe@iznobe-PC:~$

j ’ ai du mal a maitriser les balises du forum , je ne sais pas ce que je fais de mal , mais meme en editant je n’ arrive pas a avoir une mise en forme correcte :cold_face:

Pour le fichier fstab , autant pour moi , j ’ espere que je ne l’ ai pas modifié n ’ importe comment vu l ’ ajout de la partition EFI + SWAP , voici :

iznobe@iznobe-PC:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=eb4da8d1-c3ea-4788-9692-e9e23690066e /              ext4    defaults,noatime 0 1

# /boot/efi was on /dev/nvme0n1p3 during installation
UUID=C071-9050					/boot/efi			vfat		defaults		0	1

# swap was on /dev/sdc4 during installation
UUID=61218fe2-0bd1-4ada-9dd3-5ec996a02456	none				swap		sw			0	0
iznobe@iznobe-PC:~$

Pour efibootmgr :

iznobe@iznobe-PC:~$ efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0001,0003,0004,0005
Boot0001* Windows Boot Manager	HD(3,GPT,fa603a69-ea88-11ea-84d7-2cf05d2920f2,0x3a247800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)..BO
Boot0002* ubuntu	HD(3,GPT,fa603a69-ea88-11ea-84d7-2cf05d2920f2,0x3a247800,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)..BO
Boot0003* UEFI:CD/DVD Drive	BBS(129,,0x0)
Boot0004* UEFI:Removable Device	BBS(130,,0x0)
Boot0005* UEFI:Network Device	BBS(131,,0x0)
iznobe@iznobe-PC:~$

Pour la question supplémentaire :

iznobe@iznobe-PC:~$ cat /boot/grub/grub.cfg 
cat: /boot/grub/grub.cfg: Aucun fichier ou dossier de ce type
iznobe@iznobe-PC:~$ 

en esperant que cette fois-ci je n ’ ai rien oublié :innocent:.

A priori pour les balises , il faut sauter une ligne a chaque fois , d ’ ou le fait que je n’ y arrivais pas …

Pas besoin de changer la permission du script 30_os-prober pour exécuter os-prober lui-même. Le script n’est utilisé que par grub-mkconfig (utilisé lui-même par update-grub pour générer le menu de GRUB).

Si je résume tes informations, la partition EFI est censée être montée et le paquet grub-efi-amd64 est installé, Debian devrait donc avoir installé GRUB dans la partition EFI et créé une entrée « debian » dans les variables d’amorçage EFI. Or il n’y a ni fichier grub.cfg ni entrée « debian ». Je me demande comment tu as réussi ça…

Bref, ce n’est pas le sujet. La première préoccupation concerne l’absence du fichier grub.cfg.

Dans l’immédiat, l’absence de ce fichier risque d’empêcher Ubuntu d’inclure correctement Debian dans son menu de GRUB. Si tu regarde une entrée « menuentry » pour Debian dans le fichier /boot/grub/grub.cfg d’Ubuntu (à moins que ce soit /boot/efi/efi/ubuntu/grub.cfg), mais tu peux le voir aussi au démarrage en appuyant sur « e » après avoir mis l’entrée Debian en surbrillance, il se peut que la ligne qui commence par « linux » contienne « root=/dev/sdxx » au lieu de « root=UUID=xxxx », et ne contienne pas les paramètres usuels comme « ro » et « quiet ». L’utilisation de /dev/sd* pour désigner la racine n’est pas fiable car les noms peuvent changer d’un démarrage à l’autre s’il y a plusieurs disques SATA.

Il devrait être généré automatiquement à la prochaine mise à jour de noyau Debian mais tu peux le créer immédiatement avec update-grub dans Debian puis dans Ubuntu.

A terme, si tu veux remplacer la détection par os-prober par l’inclusion du menu de démarrage de Debian en tant que sous-menu, tu auras besoin du fichier grub.cfg de Debian.

Pour l’ajouter au menu d’Ubuntu, tu peux ajouter ceci dans le fichier /etc/grub.d/40_custom d’Ubuntu :

menuentry 'Debian GNU/Linux' --class gnu-linux --class gnu --class os --id 'debian' {
        insmod part_gpt
        insmod part_msdos
        insmod ext2
        search --no-floppy --fs-uuid --set=root eb4da8d1-c3ea-4788-9692-e9e23690066e
        configfile /boot/grub/grub.cfg
}

Et exécuter update-grub.

merci , c ’ est noté .

il me semble que c ’ est bien le cas vu que lors du demarrage du GRUB ubuntu " principal " j ’ ai les choix pour debian , ainsi que les options avancées avec les differents noyaux etc …

je n ’ ai jamais vraiment compris dans le BIOS ou l’ UEFI , je sais meme plus comment il faut appeller cela , il n ’ affiche jamais tous les choix des OS et seulement windows ou le " ubuntu principal " .

il faut creer une partition EFI par OS pour avoir cela ?

j ’ ai fai au plus simple lors de l’ installation , c ’ est a dire choix autre chose et installer debian sur partition ext4 avec point de montage " /" racine uniquement .
Ensuite j’ ai edité mon fichier fstab pour y adjoindre la partition EFI de l ’ OS " principal " et la partition de SWAP comune .
j ’ ai ensuite proceder aux mises a jour de debian , il a installer un nouveau noyau et a donc surement fait le reste pour moi je suppose .

Pour la suite , il faut que je relise plusieurs fois pour bien comprendre , j’ avoue etre une peu perdu .

bon , apres avoir monté le systeme de fichier de ubuntu budgie , et fais :

iznobe@iznobe-PC:~$ cat /media/iznobe/budgie_SSD/boot/grub/grub.cfg
cat: /media/iznobe/budgie_SSD/boot/grub/grub.cfg: Permission non accordée
iznobe@iznobe-PC:~$ sudo cat /media/iznobe/budgie_SSD/boot/grub/grub.cfg

j ’ obtiens pour la section menuentry de debian :

menuentry 'Debian GNU/Linux 11 (bullseye) (sur /dev/sda4)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-eb4da8d1-c3ea-4788-9692-e9e23690066e' {
	insmod part_gpt
	insmod ext2
	set root='hd0,gpt4'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  eb4da8d1-c3ea-4788-9692-e9e23690066e
	else
	  search --no-floppy --fs-uuid --set=root eb4da8d1-c3ea-4788-9692-e9e23690066e
	fi
	linux /boot/vmlinuz-5.10.0-9-amd64 root=/dev/sda4
	initrd /boot/initrd.img-5.10.0-9-amd64
}

on y voit , a priori , si je me trompe pas de ligne : linux /boot/vmlinuz-5.10.0-9-amd64 root=/dev/sda4
que l’ UUID de la partition n ’ est pas present et que effectivement si je deplace ajoute ou supprime un disque , il va y avoir un probleme …

Effectivement apres avoir explorer ce fichier plus en profondeur , on y voit que seul debian est dans ce cas ! Alors là , j ’ ai envie de dire , un grand bravo pour avoir identifier cela :hugs:!

Donc j ’ ai passé la commande : sudo update-grub puis , verifier que le fichier etait bien generé avant de redemarrer sur le " ubuntu principal " avec cat /boot/grub/grub.cfg , alors je ne met pas le contenu , mais c ’ est bon , il est maintenant present et rempli .

je ne comprends pas , que va faire precisement cette derniere partie ? c ’ est ce dont vous parliez au tout debut du post ?
cela :