Installation fraîche de Debian 10 sur Asus FX503V : Conflit des pilotes nvidia_drm et Nouveau dans APT

buster
nvidia
xorg
nouveau
kde
Tags: #<Tag:0x00007fa92b23ee80> #<Tag:0x00007fa92b23ed40> #<Tag:0x00007fa92b23ec00> #<Tag:0x00007fa92b23eac0> #<Tag:0x00007fa92b23e890>

#1

Bonjour,
Ayant rencontré des problèmes pour le lancement du bureau KDE avec Xorg, je poste ici la solution que j’ai trouvé pour l’installation à partir d’un USB bootable en minimal net-install de Debian Buster.

Le Asus FX503v dispose de deux cartes graphiques intégrées donc une avec le chipset intel pour la gestion du bureau VGA) , et l’autre avec un chipset nvidia pour la 3D (accéleration 3D).

lspci | grep -e VGA -e 3D

Il est possible que le module nouveau (pilote libre nvidia) entre en conflit avec le module intel i915 intégré au noyau mais ce n’est qu’une supposition.

La technique consiste à ne pas installer d’environnement graphique lors du choix d’installation des paquets, je le ferais après, une fois les pilotes propriétaires installés, le système redémarre et l’USB bootable retiré.

En effet, lors de ma première installation, avec l’environnement graphique installé dès le départ (Graphical Install de l’USB Bootable), APT était par la suite dans l’impossibilité d’installer les paquets propriétaires et de blacklister le module nouveau (pilotes libres intégrés et chargés par défaut dans le noyau Linux).

De plus, toujours lors de la première installation, pour pouvoir utiliser les terminaux TTY correctement, il faut rajouter au GRUB_COMMAND_LINE_DEFAULT, l’option “nomodeset splash” (Taper e à l’invite Grub de choix du noyau à lancer, puis modifier la ligne contenant quiet en rajoutant “nomodeset” pour éviter de précharger les modules) pour avoir accès au terminal sans le message système “CPU stuck for 22s” avec un bon lag permanent, ou un shutdown de la machine (processor burning) au redémarrage de la machine après l’installation.

Ce qui marchait le mieux était de lancer Debian en Recovery Mode.

Mais n’appliquons pas cette procédure d’installation, celle qui suit est plus pertinente pour résoudre le problème Xorg :

En effet, j’ai uniquement réussi à installer les pilotes propriétaires Nvidia en n’installant Xorg et KDE qu’après les pilotes propriétaires de la carte graphique installés sans installer d’environnement graphique dès le départ (c’est clair non ? :grinning:). Concernant Gnome utilisant Wayland, je ne pourrais pas vous dire, cette technique ne concerne que Xorg et Plasma 5 de KDE (ou avec Xfce, Cinnamon, Mate possible aussi mais non testé).

**

N’installer donc pas d’environnement graphique lors de l’installation via l’USB bootable, nous le ferons dans un dernier temps !

**

Pour la deuxième tentative d’installation, après l’installation du système, à l’invite de connexion du terminal, se connecter en root puis (pour Asus FX503v):

Ajouter les dépôts “non-free” et “contrib” dans /etc/apt/sources.list sur le dépôts “main
puis en root (pour de nouvelles aventures ?)

Je n’ai pas rencontré de problème de connexion réseau en filaire, mais si vous n’avez pas d’accès internet filaire, il ne sera possible d’installer le pilote du contrôleur Wifi (firmware-iwlwifi) qu’en le chargeant à partir d’un support amovible, ce qui est proposé durant l’installation de Debian.

  • Mise à jour de la listes des dépôts à utiliser par APT:
apt-get update
  • Pour installer les pilotes propriétaires wifi:
apt-get install firmware-iwlwifi 
  • Pour installer les pilotes propriétaires audio Realtek
apt-get install firmware-realtek
  • Enfin, en ce qui concerne la carte graphique :
apt-get install nvidia-detect

root# nvidia-detect indique qu’il faut installer le paquet propriétaire version 390 (concerne le téléchargement du pilote nvidia version 390 sur le site du fabriquant)

Your card is supported by the default drivers and legacy driver series 390.
It is recommended to install the nvidia-driver

Nous nous contenterons d’utiliser le paquet fourni par Debian, qui blacklist automatiquement le pilote libre nouveau et le désactive après un Reboot.

apt-get install nvidia-driver

Le système demande de rebooter pour décharger nouveau

Au reboot, si ça ne marche pas, vérifier que nomodeset n’est PAS présent dans les options de démarrage Grub du noyau.

Tentez un nvidia-xconfig, pour détecter la configuration optimale pour votre matériel graphique

nvidia-xconfig

Normalement, au prochain reboot, tout devrait fonctionner :slight_smile:

Cette méthode (installation des pilotes propriétaires nvidia avant Xorg et KDE) peut fonctionner avec les cartes utilisant le même chipset, avec une allergie malheureuse aux pilotes libres.

Ensuite, pour installer l’environnement de bureau Plasma5 de KDE, exécutez dans un terminal:

root# tasksel install kde-desktop

En espérant vous avoir permis d’installer Debian Buster avec Xorg avec facilité sur un ASUS FX503V, en attendant une correction de ce problème dans le gestionnaire de paquet, ou une meilleur prise en charge du pilote libre nouveau pour ce laptop.

GC

Voir aussi: https://linuxconfig.org/how-to-install-nvidia-driver-on-debian-10-buster-linux