Installation HP Envy 7830

Bonjour
Je voudrais installer une imprimante HP Envy 7830 et voilà le message que j’obtiens au bout de la procédure :

RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK


RE-CHECKING DEPENDENCIES
------------------------
-No protocol specified

(xsane:4084): Gtk-WARNING **: 16:33:15.805: cannot open display: :0
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.

J’ai tenté d’installer python-qt4 et voici le message :

apt install python-qt4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
python-qt4 est déjà la version la plus récente (4.12.1+dfsg-2+b1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

BWAAAH!

Quelle procédure as-tu exécuté ?

j’ai exécuter le programme fourni par hp pour debian avec la commande en root et en non root :
./hplip-3.20.9.run

Pourquoi ne pas utiliser l’outil graphique (menu Paramètres→HPLIP Toolbox) ?
C’est empaqueté dans Debian.

1 J'aime

Je ne connais pas du tout. J’ai installer HPLIP via Logiciels, j’arrive a imprimer mais je ne vois pas comment faire fonctionner le scanner. L’imprimante est bien reconnu comme imprimante mais lorsque je veux numériser un document il n’y a apparemment pas de reconnaissance imprimante/debian.
Et j’ai lance xsane mais il ne reconnait pas l’imprimante multifonction.

J’ai lancé cette commande mais je ne vois pas vraiment quoi faire :
apt-cache policy hplip
hplip:
Installé : (aucun)
Candidat : 3.18.12+dfsg0-2
Table de version :
3.20.9+dfsg0-4~bpo10+1 100
100 http://deb.debian.org/debian buster-backports/main amd64 Packages
3.18.12+dfsg0-2 500
500 http://deb.debian.org/debian buster/main amd64 Packages
100 /var/lib/dpkg/status
3.12.6-3.1+deb7u1 500
500 http://archive.debian.org/debian wheezy/main amd64 Packages

Bonjour,

Est-ce que le paquet « libsane-hpaio » est installé ?

invar

apt-cache policy libsane-hpaio
libsane-hpaio:
Installé : (aucun)
Candidat : 3.18.12+dfsg0-2
Table de version :
3.20.9+dfsg0-4~bpo10+1 100
100 http://deb.debian.org/debian buster-backports/main amd64 Packages
3.18.12+dfsg0-2 500
500 http://deb.debian.org/debian buster/main amd64 Packages
100 /var/lib/dpkg/status
3.12.6-3.1+deb7u1 500
500 http://archive.debian.org/debian wheezy/main amd64 Packages

alors il faut l’installer et voir ce qu’il en est …

J’ai installé libsane-hpaio . En utilisant non pas xsane mais simplement outil de numérisation j’ai réussi à numériser une feuille. A noter j’ai voulu réinstaller ./hplip-3.20.9.run et en fait au début de l’installation il me supprime libsane-hpaio. Mais comme tout à l’air de bien fonctionner je vais laisser comme ça et ne pas installer les drivers proposés par hp.

Pour info, si votre imprimante est récente (compatible « airprint ») on peut se passer du logiciel proposé par HP …