Installation hplip


#1

Bonjour,

Je galère un peu à l’installation de hplip : ma debian est en 8.11. L’imprimante hp office jet 3831 réclame une version hplip supérieure de celle dans les dépôts. J’ai donc téléchargé le script sur le bureau ‘hplip-3.18.12.run’. Je lance le script en user. Il me demande l’installation de dépendances. Ok. Il plante car il manque les dépendances :

error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.

Or l’installation de ces dépendances semblent nécessiter debian 9 !!!

Je tourne en rond !

Help !


#2

Oui, en fait, c’est pour ça que la version supérieure n’est disponible qu’à partir de Debian 9.
Je sais qu’il existe des outils pour installer des version spécifique dans un environnement cloisoné à base de conteneur LXC, mais je n’y connais rien. Je crois que c’est docker ou snap, si quelqu’un connait l’outil ici, pourra t’aider.