Installation mysql sur debian 3.1


#1

Salut !

Je voudrais installer mysql sur mon serveur debian 3.1, mais j’ai cette erreur :

Starting MySQL database server: mysqld…failed.
Please take a look at the syslog.
/usr/bin/mysqladmin: connect to server at ‘localhost’ failed
error: 'Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (111)'
Check that mysqld is running and that the socket: ‘/var/run/mysqld/mysqld.sock’ exists!

J’ai cherché un peu partout, mais je ne trouve pas de quoi ça pourrai venir.

En espérant que quelqu’un pourra m’aider.

Merci

Tilix.


#2

slt,

Comment as-tu installé myqsl ? as tu des logs, des infos, des messages d’erreur a coller ici ? comment démarre tu mysql ?


#3

j’ai installer mysql via : apt-get install mysql-server-4.1

Je démarre le serveur en faisant : /etc/init.d/mysql start

Dans syslog, voilà ce qu’il y’a marqué :

[size=75]Feb 22 23:20:28 ns1081 mysqld_safe[16634]: started
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: Error: auto-extending data file ./ibdata1 is of a different size
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: 0 pages (rounded down to MB) than specified in the .cnf file:
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: initial 640 pages, max 0 (relevant if non-zero) pages!
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: Could not open or create data files.
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: If you tried to add new data files, and it failed here,
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: you should now edit innodb_data_file_path in my.cnf back
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: to what it was, and remove the new ibdata files InnoDB created
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: in this failed attempt. InnoDB only wrote those files full of
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: zeros, but did not yet use them in any way. But be careful: do not
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: remove old data files which contain your precious data!
Feb 22 23:20:29 ns1081 mysqld[16637]: 060222 23:20:29 [ERROR] Can’t init databases
Feb 22 23:20:29 ns1081 mysqld[16637]: 060222 23:20:29 [ERROR] Aborting
Feb 22 23:20:29 ns1081 mysqld[16637]:
Feb 22 23:20:30 ns1081 mysqld[16637]: 060222 23:20:30 [Note] /usr/sbin/mysqld: Shutdown complete
Feb 22 23:20:30 ns1081 mysqld[16637]:
Feb 22 23:20:30 ns1081 mysqld_safe[16652]: ended
Feb 22 23:20:36 ns1081 /etc/init.d/mysql[16707]: 0 processes alive and ‘/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping’ resulted in
Feb 22 23:20:36 ns1081 /etc/init.d/mysql[16707]: ^G/usr/bin/mysqladmin: connect to server at ‘localhost’ failed
Feb 22 23:20:36 ns1081 /etc/init.d/mysql[16707]: error: 'Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (111)'
Feb 22 23:20:36 ns1081 /etc/init.d/mysql[16707]: Check that mysqld is running and that the socket: ‘/var/run/mysqld/mysqld.sock’ exists!
Feb 22 23:20:36 ns1081 /etc/init.d/mysql[16707]: [/size]


#4

slt,

Je crois qu’il faut que tu efface tout les fichiers ibdate, essaie un “updatedb” locate “ibdata” puis efface tout sauf les bibliotheques et les fichiers de conf…pas sur


#5

J’attend une autre suggestion…


#6
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: Could not open or create data files.
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: If you tried to add new data files, and it failed here,
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: you should now edit innodb_data_file_path in my.cnf back
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: to what it was, and remove the new ibdata files InnoDB created
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: in this failed attempt. InnoDB only wrote those files full of
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: zeros, but did not yet use them in any way. But be careful: do not

Tout est écrit…

Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: remove old data files which contain your precious data!
Feb 22 23:20:29 ns1081 mysqld[16637]: 060222 23:20:29 [ERROR] Can't init databases
Feb 22 23:20:29 ns1081 mysqld[16637]: 060222 23:20:29 [ERROR] Aborting
Feb 22 23:20:29 ns1081 mysqld[16637]: 

#7

Je tape quoi exactement comme action ?


#8

slt,

Sur cette erreur, ca ne m’ai pas encore arrivé sous mysql, la les logs sont clairs, apparement tu utilse un connecteur ( InnoDB ) peut-etre pour te connecté a un type de base extérieur, je pense que c’est InnoDB, enfin les databases générés par ce derniers qui empêche mysql de demarré, donc ce logs dit il faut que tu efface ces derniers :

Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: Error: auto-extending data file ./ibdata1 is of a different size
...
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: Could not open or create data files. 
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: If you tried to add new data files, and it failed here
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: you should now edit innodb_data_file_path in my.cnf back

La, à mon avis soit tu desactive InnoDD dans /whereis/my.cnf ou t’en as besoin et c’est volontaire donc :

Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: in this failed attempt. InnoDB only wrote those files full of
Feb 22 23:20:29 ns1081 mysqld[16637]: InnoDB: remove old data files which contain your precious data! 

Tu localise les fichiers, les répertoires générés par InnoDB (les variables qui contiennent les chemins sont peut-être définit dans le file my.cnf ou dans un fichier conf InnoDb) puis tu les deplaces (comme ça pas effacer, backuper :wink:)…et tu restart mysql si ca démarre pas et que c’est pas les memes erreurs tu reposte les logs…:wink:


#9

dans my.cnf, j’ai seulement ceci en rapport avec InnoDB

* InnoDB

InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.

Read the manual for more InnoDB related options. There are many!

Dans /var/lib/mysql, je n’ai rien. (2 fichiers de 0 oct, debian-4.1.flag & ibdata1)

et je n’ai rien d’autre avec InnoDB…

Information sur InnoDB : manuelphp.com/mysql/innodb-overview.php


#10

Si tu es sur de ne pas avoir d’autre fichier de configuration InnoDB et bien tu supprime ce file ibdata1:

Et tu restart, et tu reposte si ca va pas :slightly_smiling:


#11

Aucune différence… toujours la même erreur


#12

Bizarre en tout c’est clair que c’est InnoDB, tu es en quel version de debian (etch, sarge ?


#13

C’est bon, mysql marche, mais je ne saurai dire comment j’ai fais… a force d’insister ! lol

Un autre problème s’ouvre à moi (tjs des problemes…)
Apache2 marché avant que j’install mysql…

A présent, dès que je me connecte sur un site " bidon " que j’ai mis sur mon serveur, en html, mon navigateur me dit " Le document ne contient aucune donnée ", et apache2 s’arrete, j’suis obligé de le relancé…

De quoi cela pourrait venir ?

Merci.


#14

slt,

rebelotte paste des logs, des erreurs, des infos etc…mais moi je plonge dans mon lit…


#15

[Thu Feb 23 02:00:18 2006] [warn] pid file /var/run/apache2.pid overwritten – Unclean shutdown of previous Apache run?
[Thu Feb 23 02:00:18 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) configured – resuming normal operations
[Thu Feb 23 02:00:18 2006] [alert] (11)Resource temporarily unavailable: apr_thread_create: unable to create worker thread
[Thu Feb 23 02:00:18 2006] [alert] (11)Resource temporarily unavailable: apr_thread_create: unable to create worker thread
[Thu Feb 23 02:00:29 2006] [alert] Child 20167 returned a Fatal error… Apache is exiting!

j’ai cette erreur avec Apache2

j’ai installé apache 1.3, sa fonctionne niquel…


#16

mysql remarche pu :’(

Voilà mon bleme :

Sous apache 1.3, mysql marche pas… mais apache niquel !
Sous apache 2, mysql marche, mais apache 2 marche pas (erreur que j’ai cité avant)

Et lorsque je veux charger le module libphp4.so, apache me répond :
Cannot load /usr/lib/apache/1.3/libphp4.so into server: /usr/lib/apache/1.3/libphp4.so: undefined symbol: ap_block_alarms

Si quelqu’un peu m’aider à les resolvés svp…
merci


#17

slt,

A min avis c’est que des erreus de configurations, regarde bien avec vigilance ce que tu fait…


#18

si tu n’as rien à perdre, fais un apt-get purge de tous tes paquets apache et mysql, nettoies ce que tu vois qui reste dans /etc, puis reinstalles un seul apache, et ton mysql, et recommences ta config à blanc.


#19

J’ai déjà fait sa, mais rien n’y fait !

Lorsque j’essai de changer le module php, j’ai cette erreur :

Starting web server: Apache2Syntax error on line 395 of /etc/apache2/apache2.conf:
Cannot load /usr/lib/apache2/modules/libphp4.so into server: /usr/lib/apache2/modules/libphp4.so: undefined symbol: ap_block_alarms


#20

slt,
destination-linux.org/article30.html