Installation nouvel environnement

Tags: #<Tag:0x00007fb987b67608>

Bonjour
je ressuscite périodiquement un petit Dell portable 32bits que j’ai upgradé de Debian 9 en buster. Bon ce truc a + de 15 ans et 40go de disque dur… 1 Go de ram. Bref ce n’est pas un cheval de course mais je l’aime bien pour refaire mes gammes debian. J’en ai donc profité pour l’alléger en passant de Gnome à Xfce puis Mate pour voir.
Le hic c’est que ce pc est infirme et n’accepte plus les branchement USB d’aucune sorte : souris ou disque externe depuis longtemps et j’ai dû m’en accomoder. Vous imaginez les galères pour installer cet OS sans USB ni CD, il y a quelques années déjà.
Quand j’ai voulu configuré le touchpad , je l’ai désactivé par mégarde et me retrouve donc bloqué avec mon pointeur comme un cheveu sur la soupe que je ne peux enlever.
Pour les environnements testés, j’ai fait la même connerie.
Du coup, désinstallation, réinstallation mais rien n’y fait ce système a de la mémoire quand il veut et garde de paramètre de la précédente installation.
J’ai fait des remove et autoremove en veux tu en voilà mais rien n’y fait ; àchaque réinstallation d’environnement (grace à mon jocker LXDE) , Xfce et Mate gardent obstinément ce paramètre touchpad désactivé avec le pointeur comme le nez au milieu de la figure sans possibilité de se gratter.
Si quelqu’un(e) peut me donner le sésame, je l’en remercie d’avance.

A ce niveau, c’est de l’acharnement thérapeutique…

Le réglage du touchpad est peut-être dans les paramètres utilisateur. As-tu essayé avec un autre utilisateur ?
Qu’appelles-tu « joker LXDE » ?

2 J'aime

hahaha
le problème c’est qu’une fois que je rentre sur l’environnement je suis paralysé. La paramètre utilsateur ne peut s’accéder qu’à partir de celui-ci…
Joker LXDE
c’est l’environnement que j’ai conservé pour accéder à un terminal et dont je me sers pour installer/désinstaller les environnements…

je vais effectivement essayer de voir en créant un nouvel utilisateur à partir de LXDE…
merci

Qu’est-ce que LXDE a de différent ? Le touch est opérationnel ?

Bingo ! Un utilisateur nouveau crée sur ce pc de la taille d’un confetti m’a permis d’entrer sur mate comme un chef dans la salle et de dire ; c’est qui qui commande ici .
Merci Pascal.

Oui sur LXDE ca marche très bien.

En fait je cherchais initialement avec mate de cliquer avec le touchpad option double clic au lieu de d’appuyer sur la touche physique gauche du touchpad. Ca fonctionnait avec gnome.
Mais avec mate et xfce j’ai pas trouvé le paramètrage.

et pour terminer avec mate mon touchpad fonctionne aussi parfaitement avec doubleclic.
Tout est bien qui finit bien.
Merci

Avertissement : je n’y connais rien en environnement graphique, ça ne m’intéresse pas particulièrement. Le coup de changer d’utilisateur, ça fait partie de la base élémentaire du dépannage, les tests croisés : on remplace un élément à la fois, et on regarde ce qui se passe. Ça permet de savoir à quel(s) éléments le dysfonctionnement est lié ou pas.

Là on sait qu’il est lié à un utilisateur et à certains environnements de bureau. C’est peut-être un paramètre géré par gsettings (que je ne connais pas particulièrement) utilisé par Xfce et Mate mais pas par LXDE. Tu peux comparer les différences dans la sortie de la commande suivante entre l’ancien et le nouvel utilisateurs :

gsettings list-recursively | grep touchpad

Je ne serais pas surpris que « send-events » soit à ‹ disabled › pour l’un et ‹ enabled › pour l’autre.

Si ça t’intéresse de récupérer l’usage du touchpad avec ton ancien utilisateur…

Te remercie pour cette réponse.
Bon tu as raison , le changement d’utilisateur était le réflexe à avoir et ça m’est passé par-dessus.
Une fois le nouvel utilisateur crée, j’ai désinstallé mon utilisateur précedent et conséquemment je ne peux pas répondre à cette vérification de commande pour le défunt utilisateur.
Effectivement enable pour le nouveau, mais j’ai perdu l’occasion d’apprendre à modifier ce paramètre en cli. Dommage.