Installation package

installation
Tags: #<Tag:0x00007fa92614aa88>

#1

Bonjour.

Je cherche à installer sous buster les logiciels de gestion d’identité estonienne.

Je suis les instructions de Jens Getreu, qui est semble-t-il parvenu à les installer.

Je bute sur le point 2, Install broken awp package.

Si je télécharge la chose selon ses instructions, j’obtiens ceci :

$ sudo apt download awp
Réception de :1 https://installer.id.ee/media/ubuntu cosmic/main amd64 awp amd64 5.3.0.18.04.75 [15,5 MB]
15,5 Mo réceptionnés en 14s (1 078 ko/s)                                                                                                         
W: Le téléchargement est effectué en dehors du bac à sable en tant que « root » car le fichier « /home/patrick/awp_5.3.0.18.04.75_amd64.deb » n'est pas accessible par l'utilisateur « _apt ». - pkgAcquire::Run (13: Permission non accordée)

J’ai ensuite utilisé synaptic pour télécharger ce paquet. Malheureusement, cela ne me permet pas de passer à la suite :

$ ls /var/lib/dpkg/info/aw*
ls: impossible d'accéder à '/var/lib/dpkg/info/aw*': Aucun fichier ou dossier de ce type
$ sudo /var/lib/dpkg/info/awp.postinst
sudo: /var/lib/dpkg/info/awp.postinst : commande introuvable

Par ailleurs, l’instruction sudo /var/lib/dpkg/info/awp.postinst ne me semble pas receler de commande à proprement dit.

Quelqu’un aurait-il des lumières à m’apporter ?


#2

Salut

Vu les commandes qui te sont fournies en suite, il ne faut pas simplement télécharger le paquet, mais l’installer.

$ sudo apt install awp

Une fois le paquet installé, les autres commandes devraient passer.


#3

C’est en effet le cas. Je ne comprends pas la manière donc cette doc est rédigée. Toujours est-il que ça fonctionne.


#4

Jens Getreu, l’auteur dudit tuto, l’a modifié suite aux remarques que je lui ai faites : merci à lui. Désormais, il n’y a plus qu’à suivre les instructions et ça fonctionne.

En revanche, rien encore au sujet de la mise à jour des paquets ainsi installés. Je posterai ici les solutions trouvées si je devais rencontrer des difficultés.


#5

En fait, quand on consulte le script d’install sur github.com (https://github.com/open-eid/linux-installer/blob/master/install-open-eid.sh) on voit bien qu’il ajoute un dépôt tiers. Du coup, les mises à jours des paquets suivront l’évolution du dépôt ajouté.

Comme, en plus, le dépôt est initialement prévu uniquement pour ubuntu, pas pour debian, il y a un transfert de branche à ‘bionic’ pour ‘buster’. C’est pas super élégant et ça risque de devenir un peu pénible à suivre sur la durée (pour l’instant ça va, mais il faudra guetter que la branche ‘bionic’ reste dans le temps, ce qui devrait être le cas pour un moment mais pourra poser problème lors du passage à debian 11 qui sera à aligner sur une ubuntu LTS plus récente).


#6

Tout à fait d’accord avec cette analyse. Je posterai ci-dessous les prochains épisodes du feuilleton.