Installation php + mysql [Resolu]


#1

Bonjour et merci de vouloir m’aider !

Je viens d’installer apache marche bien ensuite il faut que j’installe php mais la j’ai un problème

Pour qu’Apache charge le module PHP, il faut décommenter la ligne :

LoadModule php4_module /usr/lib/apache/1.3/libphp4.so

mais dans httpd.conf
je ne trouve pas de ligne loadmodule php4…
et cela me blocke !

Merci d’avance, sa fait deux heures que je suis dessus !


#2

slt,

Normalement tu trouve ca dans “/etc/apache/php/” ou dans “/etc/apache/conf.d” ou dans “/etc/apache/module”


#3

Merci je viens de regardé, dans apache j’ai ces fichiers la :

Donc j’ai regardé dans modules.conf j’ai sa :

Or je dois décommentez une ligne qui est celel là :

LoadModule php4_module /usr/lib/apache/1.3/libphp4.so

mais elle y est pas

et dans conf.d j’ai ce fichié la :

Ya rien qui pourrait être bon :confused:

Merci d’avance si vous avez d’autre idée je vais continuer à regarder de mon côté :wink:


#4

slt,

Une bonne doc c’est mieux qu’un long discour :smiley: ac-creteil.fr/reseaux/system … mysql.html


#5

Je suis parfaitement d’accord avec toi mais c’est justement le tuto que j’utilise et je blocke à l’installation de php :wink:

edit : je viens de me rencontrer que mon tuto viens du même site ac-creteil mais n’est pas vraiment en explication.

Voici mon site à moi :

ac-creteil.fr/reseaux/system … ebian.html

Que faut’il faire au juste pour qu’apache prend en compte php ?

Je pense sa sera plus simple !

Merci d’avance.


#6

Question idiote, tu as installé php4??

apt-get install php4

Il te propose de modifier le fichier de config d’apache.

Tu peux éventuellement refaire un dpkg-reconfigure php4


#7

Voila justement c’est sa que j’ai pas saisi
j’ai tape le commande

apt-get install php4

il m’a fais des choses mais il ne m’a en aucun cas proposé une modification.

je vais reconfiguré pour voir !


#8

Tu ne doit rien décommenter ( c’est pas comme dans windows !)
essai

ou va voir ce tuto : Tutoriel


#9

ok merci bien l’ami je vais regarder sa !! :wink:


#10

Je viens de tester et :

les commandes s’éxécute correctement mais normalement on est bien d’accord que mon php devrait fonctionner aprés la commande suivante :

apt-get install libapache2-mod-php4 php4-mysql php4-gd php4-cli

la commande s’éxécute bien mais lorsque je tape avec mon explorer

127.0.0.1/essai.php

la page ne s’affiche pas mais j’ai une fenétre qui s’affiche afin de télécharger !

J’obtien ceci :

Le contenu de mon essai.php :

<? phpinfo(); ?>

Il y a aussi une chose lorsque je tape cette commande :

Pour redémarrer mon apache:

Jobtien ceci

Ensuite la commande suivante pour installer phpmyadmin qui est cele là :

apt-get install phpmyadmin

elle s’éxécute correctement mais lorsque qu’aprés avoir reboot car la commande pour rebooter apache n’a pas l’air de fonctionner, je vais dans mon explorer et je tape : 127.0.0.1/phpmyadmin/

Et j’obtiens sa :

alors que je devrai accéder à phpmyadmin !!

Je ne comprends pas trop c’est disfonctionnement !

Merci d’avance pour votre aide si précieuse !


#11

que donne le résultat de dpkg -l | grep php (c’est un L minuscule) :slightly_smiling:

Apparement il y aurais plusieurs choses de mélangé tu as installé apache 1.3 mais tu aurais la librairie php d’apache 2.0


#12

Comme demandé voici ce que cette commande donne :

Grand Merci


#13

tu as oublié le pipe entre les deux commandes c’est altgr + 6


#14

excuse moi voila

merci !!


#15

Juste avec l’url 127.0.0.1 tu tombe sur une erreur ou sur la page principale d’apache?

Si c’est sur la page principale ca viens alors de ta config tu as regardé les virtalhost? httpd.apache.org/docs/1.3/vhosts/name-based.html
httpd.apache.org/docs/1.3/

Sinon ca peux venir du documentroot aussi


#16

quand je tape 127.0.0.1
je tombe sur mon site :

Pour ce qui est des virtualhost je ne sais pas trop ce que c’est donc je ne pourrai pas te dire !! dsl

merci d’avance


#17

Tu as regardé au niveau des droits de lecture/ecriture des fichiers?

Pour les virtuals host je t’ai donné un lien tu n’as plus qu’a lire et comprendre :slightly_smiling:


#18

Il y a quel fichier qu’il faut mettre en chmod 777 ??

Merci


#19

J’ai regle mon probleme merci !!


#20

Comment l’as tu résolu?