Installation sarge sur portable acer


#1

Bonjour,

J’essaye d’installer debian sarge sur mon portable (acer extensa 4100)

bon, pour pouvoir lancer l’installation, il a fallut que je fasse :

linux26 acpi=off, sinon l’installation ne se lançait pas.

A partir de la, l’installation se déroule bien jusqu’au redémarrage.

en effet lorsque je redémarre après avoir fini l’install, ma machine se bloque sur la ligne :

i810_audio : can’t be loaded missing kernel or usermode driver i810_audio

Je suis obligé de rebooter sauvagement avec le bouton d’arret car plus rien ne fonctionne. J’ai essayé ALT+F2 pour ouvrir une autre session mais rien ne fonctionne donc impossible d’intervenir sur quoi que se soit.

suis-je obligé de réinstaller mon système et si oui comment le configurer correctement pour éviter se désagrément.

description du portable : acer extensa 4100

  • HD = 80 go
  • CPU = intel centrino 1,7
  • carte graphique = ATI mobility radeon x700
  • ram = 1000 mo
  • carte son = AC’97
  • graveur de DVD
  • plus une carte reseau intel et une carte wifi

#2

Et avec le mode linux26expert ?


#3

Faudrait désactiver le chargement du module i810_audio au chargement de l’image au menu de grub, mais je sais plus du tout comment on fait, quelqu’un aurait un souvenir?


#4

Bon j’ai essayé de refaire l’installation en mode expert, mais comme je n’ai pas su ou desactiver le module i810_audio, ça n’a rien changé et je me retouve dans la même situation.


#5

Pour désactiver le chargement du module i810_audio, il faut passer un paramétre au kernel au moment du boot. Je parierais pour noaudio ou nohotplug.

Par la suite, une fois alsa installé, tu n’auras plus besoin de ce paramétre, du fait qu’il s’agit d’un driver OSS, et qu’il sera blacklisté pas alsa.


#6

si tu peux booter en mode monoutilisateur (linux 1 sous lilo, ou sans echec sous grub), tu peux proscrire le module en mettant une ligne ‘alias i810_audio off’ dans un des fichiers de modprobe.d (ou de modutils, si tu as un noyau 2.4).
Tu peux aussi aller rajouter cette ligne la en démarrant sur une knoppix.
Sinon, as tu bêtement la possibilité de désactiver l’audio au niveau du bios, pour voir si ça démarre ?


#7

alors j’ai plusieurs questions :

  • comment dois-je faire si je veux passer le paramètre noaudio au demarrage du kernel ?

  • J’ai essayé de démarrer en “mode sans echec” (recovery mode ?), il bloque sur la même ligne, donc je vais être obligé d’utiliser knoppix, c’est bien ça ?

  • Dans quel fichier de modprobe.d dois-je ajouter la ligne “alias i810_audio off”, n’importe lequel ou y a t-il un fichier à préférer ?


#8

[quote=“titiB”]alors j’ai plusieurs questions :

  • comment dois-je faire si je veux passer le paramètre noaudio au demarrage du kernel ?[/quote]
    tu es ss lilo ou grub ?

Pas pour l’installer, juste booter sur le CD pour accèder au fichier et lke modifier.

Tu peux prendre celui que tu veux: modprobe utilisera la concatenation de tout ce qu’il trouve. Si tu veux faire propre, tu crées un fichier “off” dans lequel tu mets tous les modules que tu veux désactiver.


#9

j’utilise grub

J’ai essayé de modifier un fichier de modprobe.d après avoir démarrer via knoppix mais je n’ai pas les droits pour enregistrer le fichier modifier.


#10

par defaut, knoppix monte les disques en read-only.
pour remonter ton disque en read/write:
mount -o remount,rw


#11

oui, j’ai essayé de changer le mode read/write avec un click droit sur le raccourci de mon disque dur mais ça n’a pas marché, je vais réessayer.


#12

Bon j’ai essayer en remontant mon disque comme ceci :

mount /dev/hda3 -o remount,rw

seulement lorsque j’essaye de modifier un fichier dans /etc/modprobe.d il me dit que je n’a ipas les droits nécessaires pour modifier ce fichier. voilà les droits du fichier :

-rw-r–r-- 1 root root


#13

alors ‘su’ pour passer en root…


#14

Ok, ça marche, un grand merci à tous (surtout à MattOTop) !!!

J’ai pu finir l’installation. J’ai installé le serveur graphique et j’ai même réussi à faire fonctionner ma carte son.

Mais du coup, j’ai plein de question. Commençons par la première :

  • pourquoi, puisque je peux écouter toutes sortes de fichier audio (mp3, wave, etc…) je ne peux pas écouter de CD. Quand je met un CD audio, le lecteur se lance tout seul, je vois la lecture avancer mais j’ai pas de son ?

#15

T’as jeté un oeil dans le mixer audio, si l’entrée CD n’est pas sur 0 ?


#16

j’ai vérifié alsamixer, c’est pas ça…


#17

Salut a tous,

Voilà je suis étudiant en Bts IG option Réseau et cette année ont va bosser sur la debian…

J’ai acheté un acer 1691 donc :

  • centrino 1,7
  • 1 go de DDR
  • 80go disque dur
  • radeon x700 mobility (pci express)
  • Chipset Intel® 915PM Express

J’ai aussi ce problème de i810 audio…
Je vois qu’il faut crée un fichier « off » dans modprobe.d et rentré la ligne « alias i810_audio off » exacte ? :unamused:

Mon prof me dit que je vais avoir des problèmes avec la x700 c’est vrai ? :unamused:


#18

salut,

c’est effectivement ce qu’il a fallu que je fasse. créer /modeprobe.d/off

et dans le fichier off tu mets la ligne :

alias i810_audio off

maintenant pour la carte graphique, je suis en train d’essayer de l’installer.

J’ai telecharger les drivers : ati-driver-installer-8.16.20-i386.run

l’install semble bien se passer, le problème c’est que quand je redémarre X, rien n’a changé. Alors que je suis sensé pouvoir monter en résolution jusqu’à 1280 x 800. La je peux au mieux en 1024 x 780 (comme avant l’install des drivers). J’ai fais un test avec glxgears mais les résultat sont pas très élevés.

Je sais pas d’ou ça vient, je vais continuer à chercher mais si quelqu’un à une idée…


#19

Ca n’est pas parceque tu as changé de serveur X que ta config X (résolution, fréquences, disposition éventuel du multihead) est changée !
Je ne sais pas si l’install que tu as faite est compatible avec une reconfiguration ‘debian’ du fichier de config, et surtout, tu ne dis pas si tu es en XFree (sarge) ou Xorg (Etch).
Sinon, à la main, il faut ajouter les résolutions qui t’interressent soit dans /etc/x11/XF86Config-4 soit dans /etc/x11/Xorg.conf, suivant le cas…


#20

Je tourne sous sarge (donc xfree)

pour l’install, j’ai fait :

./ati-driver-installer-8.16.20-i386.run

puis # fglrxconfig, ensuite j’ai répondu aux questins qu’il m’a posé. et j’ai redémarrer.

Je crois qu’il modifie le fichier XF86Config-4 à la fin de l’installation puisqu’il me demande si je veux enregistrer les modification faites par l’installeur ati.