Installer Debian sur un OLinuXino Micro

boot
installation
Tags: #<Tag:0x00007f092b3981f0> #<Tag:0x00007f092b397f98>

#1

Salut à tous,
j’ai fait l’acquisition, il y a quelque temps, d’une carte SoC d’Olimex: la OLinuxino Micro (la version de base et je souhaiterais y installer Debian avec une carte SD (cela semble possible).
J’ai donc tenté de l’installer avec u-boot en suivant la procédure du wiki de debian, en vain: j’accède à u-boot qui m’annonce charger debian-installer et le kernel pour me conduire à un écran noir et affreusement vide avec un tiret qui clignote en haut à gauche.
J’ai également essayé avec une clef USB (même résultat) et via TFTP en utilisant u-boot ainsi qu’un serveur ftp de debian (impossible de contacter un quelconque équipement réseau en utilisant ethernet y compris en définissant l’adresse ip, le masque réseau et la passerelle manuellement, sans dhcp/bootp).

Je veux simplement installer Debian stable avec une carte SD :sweat:

ps: ne souhaitant pas être dépendant d’Olimex, leur version customisée ne m’intéresse pas

Merci d’avance !


#2

bonjour, bonne année
je n’ai pas cette carte

OLIMEX

©

2018

A20-OLinuXino-MICRO user’s manual
page 35/56 les leds OK?


#4

Merci pour ta réponse.
Elles sont toutes éteintes pendant la phase du bootloader (sauf celles
du port ethernet), la LED1 (page 45) s’allume et reste en vert à la
suite du chargement du kernel (l’écran noir avec le tiret).

J’ai également pu observer un nouveau comportement un peu aléatoire que
je ne parvient plus à reproduire: la carte s’éteint à l’apparition de
l’écran noir.


#5

bonsoir,
un peu plus que la page 45 des switchs bootloader


#6

désolé, mais je n’ai rien compris :confounded:


#7

Ah, quand même, je commençait à me demander si tu n’avais pas un super pouvoir pour comprendre @jb12.


#8

je te conseil Armbian


#9

J’ai déjà essayé Armbian et cela semblait plutôt bien fonctionner.
Cependant, le support de ma carte n’étant plus actif (lien), je préfère installer une distribution pérenne comme Debian stable.

edit: il semblerait que la version Debian de Armbian utilise les dépôts “officiels” de Debian. J’ai supprimé les quelques paquets et dépôts privateurs dispensables et le résultat est plutôt correct.
Il reste également beaucoup de traces des ajouts de Armbian (principalement des scripts pour faciliter l’administration) que je vais devoir effacer également.
Une installation de Debian aurait été plus simple et plus propre :woozy_face: