Installer lecteur zip et graveur scsi


#1

Bonjour,

j’ai installer la debian sarge en serveur internet, tout fonctionne.

mais j’ai un lecteur zip 100 en ide et celui si n’existe pas, y 'a t’il un package a installer.
de plus j’ai une carte scsi initio inic 1060 avec un lecteur cd et un graveur cd

Aucun de ces peripheriques n’est reconnu.

Merci de votre aide.


#2

Ton ZIP, tu es sûr qu’il est bien détecté par le bios ?
parcequ’à priori, s’il est IDE, c’est qu’il est ATAPI, et dans ce cas, il est immédiatement reconnu…
plus d’info ici au paragraphes 4.5 et 4.6:
ibiblio.org/pub/Linux/docs/H … Drive.html
concernant tes autres périphériques, il faut juste inserer le module correspondant à ta carte scsi, et je pense que ca suffira pour les trois.
Fais par exemple un
modprobe initio


#3

Bonjour,
j’ai fais un modprod initio et cela m’a mis module inition not found

pour le lecteur zip ide j’ai regarder la doc mais il est ecris qu’il est detecte or moi il n’apparait pas dois je telecharger quelque chose.

En attendant une reponse je vais cherchez sur google

merci de votre aide


#4

déjà, est ce qu’il est détecté dans le bios ?
L’as tu déjà utilisé sous windows ?
quelle est ta version de noyau ( uname -r ) ?


#5

le lecteur zip ainsi que la carte scsi et les lecteurs scsi ont ete utilise sur windows.

le lecteur zip est detecte par le bios
les lecteurs sont detecte par la carte scsi

lorsque je fais uname -r cela me donne
2.6.8-2-386

merci pour cet aide


#6

[quote=“andarius40”]Bonjour,
j’ai fais un modprod initio et cela m’a mis module inition not found[/quote]
le n dans module inition not found, ce n’est pas parceque tu as tapé inition au lieu d’initio ?
De plus, c’est modprobe, pas modprod…
Si tu n’as rien fait de spécial à ton noyau, tu l’as forcément, il est dans les noyaux de distrib…


#7

j’ai fait modprobe initio

cela m’a mis :
FATALE : Module initio not found.

et je n’ai pas touché au noyau, c’est celui d’origine


#8

[quote=“andarius40”]Bonjour,

j’ai installer la debian sarge en serveur internet, tout fonctionne.

mais j’ai un lecteur zip 100 en ide et celui si n’existe pas, y 'a t’il un package a installer.
de plus j’ai une carte scsi initio inic 1060 avec un lecteur cd et un graveur cd

Aucun de ces peripheriques n’est reconnu.

Merci de votre aide.[/quote]
Ta carte SCSI, elle est branchée dans un port PCI ?
Si c’est le cas essayes de lancer:lspci -v
Et poste le résultat de ta commande.


#9

voici la reponse de lspci -v
ServeurInternet:/home/andarius# lspci -v
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge (rev 80)
Subsystem: VIA Technologies, Inc.: Unknown device 0000
Flags: bus master, 66MHz, medium devsel, latency 8
Memory at e0000000 (32-bit, prefetchable) [size=32M]
Capabilities: [80] AGP version 3.5
Capabilities: [c0] Power Management version 2

0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, medium devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
Memory behind bridge: dde00000-dfefffff
Prefetchable memory behind bridge: cdd00000-ddcfffff
Capabilities: [80] Power Management version 2

0000:00:08.0 SCSI storage controller: Initio Corporation INI-A100U2W (rev 01)
Subsystem: Initio Corporation INI-A100U2W
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 169
I/O ports at ec00 [size=256]
Memory at dffff000 (32-bit, non-prefetchable) [size=4K]
Expansion ROM at dffe0000 [disabled] [size=64K]
Capabilities: [50] Power Management version 1

0000:00:0b.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)
Subsystem: Micro-Star International Co., Ltd.: Unknown device 590c
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 169
Memory at dffc0000 (32-bit, non-prefetchable) [size=64K]
Capabilities: [48] Power Management version 2
Capabilities: [50] Vital Product Data
Capabilities: [58] Message Signalled Interrupts: 64bit+ Queue=0/3 Enable-

0000:00:0e.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46) (prog-if 10 [OHCI])
Subsystem: Micro-Star International Co., Ltd.: Unknown device 590d
Flags: bus master, medium devsel, latency 32, IRQ 177
Memory at dfff7800 (32-bit, non-prefetchable) [size=2K]
I/O ports at e800 [size=128]
Capabilities: [50] Power Management version 2

0000:00:0f.0 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06) (prog-if 8a [Master SecP PriP])
Subsystem: Micro-Star International Co., Ltd.: Unknown device 5901
Flags: bus master, medium devsel, latency 32, IRQ 185
I/O ports at fc00 [size=16]
Capabilities: [c0] Power Management version 2

0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81) (prog-if 00 [UHCI])
Subsystem: Micro-Star International Co., Ltd.: Unknown device 5901
Flags: bus master, medium devsel, latency 32, IRQ 193
I/O ports at d800 [size=32]
Capabilities: [80] Power Management version 2

0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81) (prog-if 00 [UHCI])
Subsystem: Micro-Star International Co., Ltd.: Unknown device 5901
Flags: bus master, medium devsel, latency 32, IRQ 193
I/O ports at dc00 [size=32]
Capabilities: [80] Power Management version 2

0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81) (prog-if 00 [UHCI])
Subsystem: Micro-Star International Co., Ltd.: Unknown device 5901
Flags: bus master, medium devsel, latency 32, IRQ 193
I/O ports at e000 [size=32]
Capabilities: [80] Power Management version 2

0000:00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81) (prog-if 00 [UHCI])
Subsystem: Micro-Star International Co., Ltd.: Unknown device 5901
Flags: bus master, medium devsel, latency 32, IRQ 193
I/O ports at e400 [size=32]
Capabilities: [80] Power Management version 2

0000:00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86) (prog-if 20 [EHCI])
Subsystem: Micro-Star International Co., Ltd.: Unknown device 5901
Flags: bus master, medium devsel, latency 32, IRQ 193
Memory at dfffee00 (32-bit, non-prefetchable) [size=256]
Capabilities: [80] Power Management version 2

0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800 South] Subsystem: VIA Technologies, Inc.: Unknown device 0000
Flags: bus master, stepping, medium devsel, latency 0
Capabilities: [c0] Power Management version 2

0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
Subsystem: Micro-Star International Co., Ltd.: Unknown device 5901
Flags: medium devsel, IRQ 201
I/O ports at d400 [size=256]
Capabilities: [c0] Power Management version 2

0000:01:00.0 VGA compatible controller: nVidia Corporation NV15DDR [GeForce2 Ti] (rev a4) (prog-if 00 [VGA])
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 209
Memory at de000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (32-bit, prefetchable) [size=128M]
Expansion ROM at dfef0000 [disabled] [size=64K]
Capabilities: [60] Power Management version 1
Capabilities: [44] AGP version 2.0

merci encore pour cet aide


#10

Bon, je viens de regarder sur une machine en 2.6.8-2-386, et j’ai compris…
En 2.6.8 il était experimental, et donc effectivement, il n’etait pas compilé avec le noyau.
Donc de deux choses l’une: soit tu le compiles pour ton noyau courant et un peu ancien( :slightly_smiling: ), soit tu installes un noyau plus récent.
Tu dis, et on t’aide…


#11

je preferai compiler le nouveau noyau, j’ai deja essayer mais cela m’affichai comme koi il ne pouvais pas charger la partition n°9, pour booter. Et en cherchant sur le net cela m’avais mis qu’il fallait mettre en dur le module ide pour le dur, or il y etait.

donc j’ai arreter.
mais je suis pres a essayer


#12

bon, j’éspèrais t’orienter vers un nouveau noyau, mais si tu préfères compiler pour ton noyau actuel…
Déjà, en général, quand on à les sources et qu’on utilise le même noyau que les sources, il est judicieux d’aller chercher /boot/config-???, et de le recopier dans /usr/src/linux, sous le nom .config.
Ca permet de commencer avec comme config par défaut la même que celle du noyau actif (et qui marche donc). Aprés, tu peux ajuster.
Bon, je pars du principe que les sources de ton noyau sont bien rangées avec un lien symbolique /usr/src/linux qui pointe vers ce repertoire source.
donc dans l’ordre:
0/
$ cd /usr/src/linux
1/copier la config courante comme base de travail:
/usr/src/linux$ cp /boot/config-2.6.8-2-386 .config
2/rentrer dans la configur noyau pour ajuster le type de processeur et aler mettre en module l’initio:
/usr/src/linux$ sudo make menuconfig
3/créer les diffèrents paquetages noyau:
/usr/src/linux$ sudo make-kpkg --append-to-version=-andarius kernel-image
4/installer le produit:
/usr/src/linux$ sudo dpkg -i kernel-image-2.6.8-andarius*.deb

puis rebooter…

mais je me répète: tu ferais mieux bêtement d’installer un noyau plus récent déjà compilé, en cherchant lequel installer avec ‘.apt-cache search kernel-image | grep 2.6 | less’, puis en l’installant bètement avec apt-get.


#13

[quote=“andarius40”]je preferai compiler le nouveau noyau, j’ai deja essayer mais cela m’affichai comme koi il ne pouvais pas charger la partition n°9, pour booter. Et en cherchant sur le net cela m’avais mis qu’il fallait mettre en dur le module ide pour le dur, or il y etait.

donc j’ai arreter.
mais je suis pres a essayer[/quote]

Tu l’as compilé comment ton noyau ?
A la manière Debian ?
Si oui, tu as fait un “–initrd” ?
Si tu as fait un initrd, tu n’est pas obligé mettre ton module ide en dur.


#14

oops… Jabba a raison: en 3, c’est
sudo make-kpkg --append-to-version=-andarius kernel-image –initrd


#15

j’ai recompiler le kernel 2.6.14

lors du redemarrage j’ai l’erreur:
VFS:Cannot open root device “hda9” or unknow-block(0,0)
please append a correct “root” boot option
kernel panic - not syncing: VFS: unable to mount root fs on unknow-block(0,0)

j’aimerai savoir comment supprimer le kernel comportant des erreurs

merci de votre aide


#16

j’ai recompile avec --initrd

cela fonctionne mais j’ai lorsqeu je fais lspci -v
capabilities :
j’aimerai savoir comment faire pour autoriser tous les utilisateurs a utiliser le materiel.

merci


#17

la question n’a pas vraiment de sens sous linux, en fait, et de plus, même si c’est théoriquement possible d’ouvrir complètement une machine pour en faire une passoire à la windows, dans les faits, c’est presque impossible.
tu veux quoi comme accés sur quel périphérique ?
Si je suppose que ce dont tu veux parler, c’est de l’accés à tes périphériques de stockage, il faut que tu configure les entrées de fstab avec une option user ou users (la différence est subtile, et je te laisse le soin de faire un man fstab, pour savoir laquelle des deux s’adapte à ton cas.
Par ailleurs, si tu veux travailler comme tout le monde avec linux, il faut que tu comprennes et utilises la commande sudo:
sudo
va executer la commande en tant que root, mais il faut d’abord configurer ton utilisateur avec des droits, et ca se fait dans /etc/sudoers (man sudoers pour comprendre la syntaxe et l’utilisation de ce fichier)
Vala…


#18

bonjour,

je peux utiliser les peripheriques en utilisateur (son, graveur et lecteur scsi) sauf la carte reseau ce qui fait que le pc n’a pas acces au reseau comment faire, merci pour l’aide.