IP en utilisant PPPOE

Tags: #<Tag:0x00007fb99542df28>

Bonjour à tous,

Je rencontre actuellement un problème pour configurer l’ip d’un serveur avec Debian 10, via PPPOE. Voici mes caractéristiques techniques :
Caractéristique technique :
image

Mon provider m’a fourni un id et un password pour me connecter en PPPOE. J’ai donc installé les paquets et j’ai configuré sur Debian 10 la connexion ppp. Voici ce que j’obtiens : :

ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
        valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 84:47:09:07:a8:be brd ff:ff:ff:ff:ff:ff
    inet 10.92.20.139/19 brd 10.92.31.255 scope global dynamic noprefixroute enp2s0
        valid_lft 511sec preferred_lft 511sec
    inet6 fe80::8647:9ff:fe07:a8be/64 scope link noprefixroute
        valid_lft forever preferred_lft forever
3: wlp1s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether ba:05:cf:3b:2f:14 brd ff:ff:ff:ff:ff:ff
root@cyragroup:/home/bencg# pon
/usr/sbin/pppd: In file /etc/ppp/peers/provider: unrecognized option '/dev/modem'
root@cyragroup:/home/bencg# 
root@cyragroup:/home/bencg# pon padaf-provider
Plugin rp-pppoe.so loaded.
root@cyragroup:/home/bencg# 
root@cyragroup:/home/bencg# ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
        valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 84:47:09:07:a8:be brd ff:ff:ff:ff:ff:ff
    inet 10.92.20.139/19 brd 10.92.31.255 scope global dynamic noprefixroute enp2s0
        valid_lft 491sec preferred_lft 491sec
    inet6 fe80::8647:9ff:fe07:a8be/64 scope link noprefixroute
        valid_lft forever preferred_lft forever
3: wlp1s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether ba:05:cf:3b:2f:14 brd ff:ff:ff:ff:ff:ff
9: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN group default qlen 3
    link/ppp
    inet 195.88.181.6 peer 195.85.248.252/32 scope global ppp0
        valid_lft forever preferred_lft forever
root@cyragroup:/home/bencg# 

Donc j’ai bien configuré en 9 mon ppp, mais mon ip de base reste toujours celle en 2. J’aimerai faire que l’interface réseau se connecte directement via le ppp0 et obtienne donc la bonne ip.

Je reste à votre disposition,

Merci par avance pour votre aide,

Peux-tu monter la sortie de

ip route

Comment configures-tu l’interface ethernet enp2s0 ? en DHCP dans /etc/network/interfaces ?

1 J'aime

Merci @PascalHambourg pour ton retour (encore!^^)

Voici la sortie de IP ROUTE :

root@cyragroup:/etc/network# ip route
default via 10.92.0.1 dev enp2s0 proto dhcp metric 100 
 10.92.0.0/19 dev enp2s0 proto kernel scope link src 10.92.20.139 metric 100 

Aucune configuration particulière pour le moment, je dois peut être faire quelque chose ?

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
source /etc/network/interfaces.d/*
# The loopback network interface
auto lo
iface lo inet loopback

Encore merci !

Dois-je ajouter cela ?

auto enp2s0
iface enp2s0 inet manual

auto padaf-provider
iface padaf-provider inet ppp
pre-up    /sbin/ifconfig enp2s0 up
provider padaf-provider

Avec la liaison PPP active ? Il devrait au minimum y avoir une route vers le « peer » qu’on voit dans ip addr.

Ça et la métrique 100, je suppose que la connexion ethernet est gérée en automatique par NetworkManager ?

Pour une activation automatique au démarrage, ça me paraît pas mal. Cela ressemble à ce que j’ai sur mon propre serveur. On peut aussi gérer une connexion PPPoE avec NetworkManager, mais je ne l’ai jamais fait.

Avec la modification ci-dessus, j’ai ça en sortie de IP route :
195.85.248.252 dev ppp0 proto kernel scope link src 195.88.181.6

Par contre je n’ai plus internet

Non je ne suis pas passé par là, tout en ligne de commande

Pas de route par défaut liée à ppp0 ? Dans ce cas il faut ajouter une option « defaultroute » dans le fichier de configuration /etc/ppp/peers/padaf-provider, voire « defaultroute replacedefaultroute » pour remplacer la route par défaut existante, mais cela ne devrait pas être nécessaire compte tenu de sa métrique.

C’est-à-dire ? Directement avec dhclient ?

Merci @PascalHambourg

J’ai bien ajouté les deux options dans le /etc/ppp/peers/padaf-provider, mais le problème reste le même. IP route donnne toujours la même chose après pon, et le ip address reste inchangé également.

Je ne suis pas sur de bien comprendre, je ne suis pas passé par dhclient non plus

En fait ça fonctionne ^^
Bizarrement, la debian voit que le réseau filaire n’est pas connecté mais en essayant, je tombe bien sur mon serveur, y compris a partir d’une connection 5G (donc en dehors du réseau local !).

Merci beaucoup une fois de plus @PascalHambourg
Cela fait chaud au cœur d’avoir de l’aide de personne aussi compétente que toi !