Ipv6 fourni par le FAI?

Bonjour

Dans mon compte client chez OVH j’ai vu que ipv4 était activé mais pas ipv6.
Sans raison formelle j’active ipv6, en me disant que depuis le temps qu’on en parle ça devrait servir à quelque chose.
Une fois activé je fais des test ipv6 et les résultats sont toujours “unreachable”.
J’en parle à OVH et on me répond :

L’IPv6 est bien actif sur votre modem actuellement.
Est-ce qu’il y a une raison pour laquelle vous souhaitez l’utiliser ?
Est-ce que vos appareils sont paramétrés pour ?

Et c’est là que j’attends vos avis . . . !
car je trouve la réponse bizarre, comme si c’était à moi de décider de l’usage ipv6 et le noyau prend en charge nativement ipv6 ?!

Je crois qu’une explication me ferait du bien.

Merci

Bonjour,

La première chose à faire et de t’assurer d’avoir redémarré ton « modem » (box /routeur) et de vérifier sur son interface de configuration qu’il fournit bien de l’IPv6 (voir les docs OVH).

Ensuite tu pourra regarder sur ta machine ce que dit la commande ip :

ip a

Je demande de l’aide sur 3 forum, ce qui suit est un retour “commun”.

Box redémarrée -> idem ipv6 unreachable

Dans mon compte client l’adresse ipv6 est présente avec une terminaison /56

Sur le PC une commande

ip a

retourne

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp27s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:d8:61:34:0c:b1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.69/24 brd 192.168.1.255 scope global dynamic enp27s0
       valid_lft 75270sec preferred_lft 75270sec
    inet6 2001:41d0:fe53:ce00:2d8:61ff:fe34:cb1/64 scope global dynamic mngtmpaddr 
       valid_lft 2535278sec preferred_lft 548078sec
    inet6 fe80::2d8:61ff:fe34:cb1/64 scope link 
       valid_lft forever preferred_lft forever

Il y aurait-il quelque chose à renseigner dans les paramètre réseaux du PC ??

J’ai mis le retour entre balises code mais ça affiche un platras, désolé !

Ta machine a bien une adresse IPv6 publique pour l’interface Ethernet enp27s0 :

Donc au niveau de la box et de la configuration réseau cela semble bon.
Est-ce que tu as une route en IPV6 :

ip -6 route

Est-ce que tu peux faire un ping :

ping -6 -c2 ipv6.google.com

Sinon il faudra regarder au niveau du pare-feu, sur la box et éventuellement sur le PC.

jarek@prozerpine:~$ ip -6 route
::1 dev lo proto kernel metric 256 pref medium
2001:41d0:fe53:ce00::/64 dev enp27s0 proto kernel metric 256 expires 2520614sec pref medium
fe80::/64 dev enp27s0 proto kernel metric 256 pref medium
jarek@prozerpine:~$ ping -6 -c2 ipv6.google.com
connect: Le réseau n'est pas accessible

Le pare-feu sur le modem est paramétré “normal”

Merci

Je viens de découvrir un wiki IPV6 qui semble convenir à mon cas je le consulte demain.

Bonne soirée !

Je rame, tout ce que j’ai trouvé de pertinent est là :

jarek@prozerpine:~$ cat /proc/sys/net/ipv6/conf/lo/disable_ipv6
0
jarek@prozerpine:~$ cat /proc/sys/net/ipv6/conf/enp27s0/disable_ipv6
0

Merci

Tu n’a pas de route / passerelle pour « sortir » en IPv6.
Soit il y a une mauvaise configuration de la box/routeur qui n’enverrait pas de paquets RA (Routeur Advertisement). Encore une fois il faut consulter la doc OVH sur ce sujet.
Soit tu as un pare-feu qui bloque l’ICMPv6.

C’est noté, merci !

Dans un cas comme dans l’autre, comment l’interface aurait-elle acquis cette adresse IPv6 globale dont la partie hôte est manifestement basée sur l’adresse MAC ? Par DHCPv6 ? (ça marche sans RA ?)

Exact c’est bien une adresse obtenue d’après l’adresse MAC. Ce que j’ai dit est une connerie :pensive:

Merci à vous, mais là je me rend concrètement compte qu’un ordinateur n’est pas une machine à laver . . .
Pour info, ce matin j’ai installé bullseye sur un nouveau PC.
En cours d’installation j’ai eu un “configuration automatique ipv6 impossible” !

C’est à se demander à quoi ça sert (à part écrire des articles), d’autant plus que les seuls tuto usager que j’ai trouvé concernent sa désactivation . . .

La doc OVH ne m’a rien appris.
Est-ce que ce qui suit permettrait de m’orienter pratiquement ?
Je persiste parce que ça m’agace . . .


Configuration de mon modem (fourni par OVH)

IP LAN -> statique

DHCP -> actif
passerelle -> renseigné
DNS p/s -> renseigné
nom domaine DHCP -> LAN
plage DHCP -> renseigné
durée d’allocation -> renseigné

baux DHCP -> néant
redirection de ports -> néant

configurations avancées
les services activables (mais non activés) sont FTP et partage contenu


Sur le PC en interface graphique j’ai accès à “configuration réseau avancée” ->
ethernet -> wired connexion 1 ->

paramètres ipv4 -> methode -> automatique (DHCP)

paramètres ipv6 -> methode -> automatique
avec choix entre

  • ignorer
  • automatique
  • automatique (adresse uniquement)
  • automatique (DHCP uniquement)
  • manuel
  • lien local uniquement
  • partagé avec d’autres ordinateurs

Le passage en gras n’est pas volontaire.

Bon dimanche !

Si tu as le même problème sur une autre machine, cela laisse supposer un problème avec de configuration du routeur (modem). Il serait intéressant de voir le retour des commandes ip a et ip -6 route sur cette nouvelle machine.

Ce serait intéressant de capturer une annonce de routeur IPv6 (RA) émise par ce modem. Le programme/paquet radvdump est fait spécialement pour ça. Il faut lui indiquer sur quelle interface réseau écouter, et le laisser tourner jusqu’à ce qu’un RA soit reçu. Normalement un routeur IPv6 en émet périodiquement, et sur demande lorsqu’il reçoit une sollicitation d’une machine qui vient de se connecter au réseau.

Mes hypothèses sont que ces annonces pourraient contenir une donnée incorrecte dans ces annonces, ou bien une particularité qui ne s’accorde pas bien avec Linux.

La nouvelle n’est pas fonctionnelle.

J’ai refait une install bullseye en mode “expert” (c’est assez valorisant . . .) et ipv6 s’est “automatiquement installé” sans le redouté “impossible”.
Une dernière question :
Comment déterminer le gestionnaire de connexion installé (NM, ifupdown, . . .) ?

Je reviendrai plus tard pour le problème ipv6.

merci et bonne soirée !