J'ai fait des bétises !


#1

Bonjour,

j’ai pas mal de prob gênant depuis l’installation de logiciel ( j’aime bien fouiller )

je sais plus ce que j’ai installer mais voilà ce qui se passe :

il boot, j’ai un logo debain ( je voulais voir ce que c’était ), ok, il veut lancer X, il y a le bruit à l’écran, puis revient, sans erreur… déjà là, je lui avait demandé d’ouvrir automatiquement KDE en schlopa. KDM veut plus j’ai l’impression.

ensuite, je tape mon user ( schlopa ) et fais " startx " ok non pb, sauf que je vais sous Xfce !! Je venais aussi de l’installer pour voir comment c’était, mais là j’ai plus le choix entre KDE &co

aie aie aie je me dit que j’suis dans le caca !

autre idée, tenter de lancer KDM, je tape donc kdm, veut pas je suis en user, je vais en root, magique, c’est … KDE qui se lance tout seule, et en …USER !!

je comprends plus rien !!

j’aimerai que KDM se lance tout seule au démarrage, et que je puisse choisir entre KDE et XFce.

je sais pas si j’étais assez clair…

voici le log de mes 2 dernière connection à kdm ( je crois )
c’est un peu long mais tant pis

[quote]XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-10 20041217234706 root@me)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.9 x86_64 [ELF]
Build Date: 18 December 2004

This version of XFree86 has been extensively modified by the Debian
Project, and is not supported by the XFree86 Project, Inc., in any
way. Bugs should be reported to the Debian Bug Tracking System; see
<URL: debian.org/Bugs/Reporting >.

We strongly encourage the use of the “reportbug” package and command
to ensure that bug reports contain as much useful information as
possible.

Before filing a bug report, you may want to consult the Debian X FAQ:
XHTML version: file:///usr/share/doc/xfree86-common/FAQ.xhtml
plain text version: file:///usr/share/doc/xfree86-common/FAQ.gz

Module Loader present
OS Kernel: Linux version 2.6.8-9-amd64-k8 (mrvn@frosties) (gcc version 3.4.2 (Debian 3.4.2-2)) #1 Sat Dec 11 07:30:15 UTC 2004
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/XFree86.0.log”, Time: Wed Jan 26 12:17:21 2005
(==) Using config file: "/etc/X11/XF86Config-4"
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o”: No symbols found
(EE) xf86OpenSerial: Cannot open device /dev/psaux
No such device.
(EE) Configured Mouse: cannot open input device
(EE) PreInit failed for input device “Configured Mouse”
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
No such device.
(EE) Generic Mouse: cannot open input device
(EE) PreInit failed for input device "Generic Mouse"
The XKEYBOARD keymap compiler (xkbcomp) reports:

Warning: Type “ONE_LEVEL” has 1 levels, but has 2 symbols
Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
No core pointer

Fatal server error:
failed to initialize core devices

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file “/var/log/XFree86.0.log”.
Please report problems to submit@bugs.debian.org.

XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-10 20041217234706 root@me)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.9 x86_64 [ELF]
Build Date: 18 December 2004

This version of XFree86 has been extensively modified by the Debian
Project, and is not supported by the XFree86 Project, Inc., in any
way. Bugs should be reported to the Debian Bug Tracking System; see
<URL: debian.org/Bugs/Reporting >.

We strongly encourage the use of the “reportbug” package and command
to ensure that bug reports contain as much useful information as
possible.

Before filing a bug report, you may want to consult the Debian X FAQ:
XHTML version: file:///usr/share/doc/xfree86-common/FAQ.xhtml
plain text version: file:///usr/share/doc/xfree86-common/FAQ.gz

Module Loader present
OS Kernel: Linux version 2.6.8-9-amd64-k8 (mrvn@frosties) (gcc version 3.4.2 (Debian 3.4.2-2)) #1 Sat Dec 11 07:30:15 UTC 2004
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/XFree86.0.log”, Time: Thu Jan 27 21:01:01 2005
(==) Using config file: "/etc/X11/XF86Config-4"
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o”: No symbols found
(EE) xf86OpenSerial: Cannot open device /dev/psaux
No such device.
(EE) Configured Mouse: cannot open input device
(EE) PreInit failed for input device “Configured Mouse”
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
No such device.
(EE) Generic Mouse: cannot open input device
(EE) PreInit failed for input device "Generic Mouse"
The XKEYBOARD keymap compiler (xkbcomp) reports:

Warning: Type “ONE_LEVEL” has 1 levels, but has 2 symbols
Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
No core pointer

Fatal server error:
failed to initialize core devices

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file “/var/log/XFree86.0.log”.
Please report problems to submit@bugs.debian.org.

XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-10 20041217234706 root@me)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.9 x86_64 [ELF]
Build Date: 18 December 2004

This version of XFree86 has been extensively modified by the Debian
Project, and is not supported by the XFree86 Project, Inc., in any
way. Bugs should be reported to the Debian Bug Tracking System; see
<URL: debian.org/Bugs/Reporting >.

We strongly encourage the use of the “reportbug” package and command
to ensure that bug reports contain as much useful information as
possible.

Before filing a bug report, you may want to consult the Debian X FAQ:
XHTML version: file:///usr/share/doc/xfree86-common/FAQ.xhtml
plain text version: file:///usr/share/doc/xfree86-common/FAQ.gz

Module Loader present
OS Kernel: Linux version 2.6.8-9-amd64-k8 (mrvn@frosties) (gcc version 3.4.2 (Debian 3.4.2-2)) #1 Sat Dec 11 07:30:15 UTC 2004
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/XFree86.0.log”, Time: Thu Jan 27 21:04:55 2005
(==) Using config file: "/etc/X11/XF86Config-4"
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o”: No symbols found
Skipping “/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o”: No symbols found
The XKEYBOARD keymap compiler (xkbcomp) reports:

Warning: Type “ONE_LEVEL” has 1 levels, but has 2 symbols
Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
Warning: font renderer for “.pcf” already registered at priority 0
Warning: font renderer for “.pcf.Z” already registered at priority 0
Warning: font renderer for “.pcf.gz” already registered at priority 0
Warning: font renderer for “.snf” already registered at priority 0
Warning: font renderer for “.snf.Z” already registered at priority 0
Warning: font renderer for “.snf.gz” already registered at priority 0
Warning: font renderer for “.bdf” already registered at priority 0
Warning: font renderer for “.bdf.Z” already registered at priority 0
Warning: font renderer for “.bdf.gz” already registered at priority 0
Warning: font renderer for “.pmf” already registered at priority 0
SetClientVersion: 0 8
AUDIT: Thu Jan 27 21:10:12 2005: 3062 X: client 28 rejected from local host
SetClientVersion: 0 8
SetGrabKeysState - disabled
SetGrabKeysState - enabled
AUDIT: Thu Jan 27 21:28:49 2005: 3062 X: client 23 rejected from local host
AUDIT: Thu Jan 27 21:28:49 2005: 3062 X: client 23 rejected from local host
AUDIT: Thu Jan 27 21:28:49 2005: 3062 X: client 23 rejected from local host
[/quote]

voilà, je crois que j’ai tout donné

merci pour votre aide !
@++


#2

J’ai le m^ problème :
j’arrive à l’invite, je suis obligé de me loguer en root et de taper 'kdm’
Là, ensuite, tt colle, j’arrive ds le gestionnaire de connexion et j’ai le choix de User ou root.
Si tu n’as pas l’arrêt à ce niveau, c’est que tu as programmé en connexion automatique.
Dis si c’est ça qui te gêne ?


#3

C’est probablement parce que vos Login Managers (KDM ou GDM …) ont été configurés au départ pour se lancer automatiquement au démarrage de la machine. Via les script

/etc/init.d/KDM ou GDM

En entrant dans les run levels /etc/rc2.d ou /etc/rc3.d (je ne suis jamais foutu de me rappeler le niveau par défaut pour le démarrage de X sous Debian, donc à vérifier…)

Il exécute le lien /etc/rc2.d/SUnChiffreKDM qui pointe sur /etc/init.d/KDM

Ce qui lance ton Login Manager.

Et bien sûr, si le lien n’est plus là, on reste en mode texte. Je suppose donc que le login manager DOIT être lancé par root pour fonctionner correctement. Si on le lance en tant que simple user, il n’a pas les bons droits et démarre n’importe comment … ou pas du tout ! Ce qui expliquerait ce comportement bizarre …

Donc vérifier les runlevels 2 et 3 pour voir s’il y a des liens qui pointent sur /etc/init.d
S’il ne sont plus là, il faut les recréer avec une commande du genre:

update-rc.d KDM (ou GDM) defaults un_chiffre

voir la man page de update-rc.d pour y mettre les paramètres corrects, je ne l’ai pas sous la main …

Ensuite, KDM devrait se lancer correctement …


#4

$ update-rc.d kdm start 99 2 3 4 5 . stop 1 0 1 6 .

plus exactement pour éviter de tout foutre en l’air


#5

Thanks SuperDindon d’être venu aussi rapidement au secours de ma mémoire défaillante ! :wink:


#6

Super, merci à vs 2, je vais ptet faire ça ce soir.


#7

merci, j’ai fait autrement, étant donnée que j’ai aussi installer XFce, je veux pas forcement démarrer sous KDE et dans le centre de configuration, j’ai décoché la case pour démarrer la session automatiquement et voilà, tout baigne à qq détails :

j’ai crée deux new utilisateurs et il y a que ceux la qui s’affiche. Il n’y a plus “schlopa” et “root”

comment faire pour résoudre ça ?

merci bcp !
@++


#8

ricardod@debian:~$ update-rc.d kdm start 99 2 3 4 5 . stop 1 0 1 6 . bash: update-rc.d: command not found
en user, il ne veut pas

ricardod@debian:~$ su - Password: debian:~# update-rc.d kdm start 99 2 3 4 5 . stop 1 0 1 6 . System startup links for /etc/init.d/kdm already exist. debian:~#
sous ‘root’, il veut bien mais c’était déjà fait apparemment.
Pourtant, rien de changé :cry:

PS :
Ce qui paraît anormal, à la fin du chargement de linux, c’est qu’on a l’impression que la commande ‘kdm’ “hésite” un certain tps puis ça revient au prompt. Comme si elle n’arrivait pas à “accrocher”
:wink:
Voici les dernières lignes du chargement, une fois revenu au prompt :

Stating K Display Manager : kdm ip_tables:(C) 2000-2002 Netfiler core team ip_conntrack version 2.1(4095 buckets,32760 max) - 332 bytes per conntrack Debian GNU/Linux 3.1 debian tty1 debian login _

Il n’y aurait pas une histoire de firewall ?


#9

Effectivement, en voyant le dernier message ca pue le problème de droit d’accès à plein nez …

Je ne connais malheureusement pas assez ip_tables pour pouvoir t’aider plus … :confused:

Essayes déjà de voir quels sont tes modules chargés et vire tout ce qui a trait à ip_tables et autres configs de firewall

(lsmod pour lister et modprobe -r pour virer pui s /etc/init.d/kdm stop puis start)